I tried upgrading to Klipper today, but could not get FluiddPi to connect to the Ender 3 v2. The expected connection was there, but Fluidd would try to connect and give up. All the available help I could find was about configuring serial; it looked exactly right to me.
So I decided to go back to Jyers Marlin for now. I copied the binary to the SD card, gave it a unique name with a .bin ending (no other .bin on the card) and rebooted.
I still had the screen detached because Klipper doesn’t use it and I heard it can even interfere with it booting.
Attached the screen and rebooted. The screen backlight comes on, but nothing else.
I attached OctoPrint’s USB cable to it to see if it was just a screen problem, but it will not connect.
I’ve tried two other (appropriate) Marlin binaries. Nothing flashes. The machine is bricked.

Time to calmly step back, scratch my head, and ask if anybody else has any ideas.

My next step would be to attach a computer to the printer serially and try to connect using Pronterface.

Also, does Jyers allow the use of anyname.bin or does it have to be a specificname.bin, such as firmware.bin?

Is it possible the cable is plugged into the wrong port on the LCD?

Thanks, @Ender5r!
I attached Pronterface using an old Surface. I selected Debug Communications. No ports were listed, but the device manager showed a COM4 that came and went with my plugging into the printer.
I typed COM4 into Pronterface, and it connects, then sends M105s forever. No response. If I unplug the printer, the trace is filled with pages of exceptions, so serial communications seems to be working, but I seem to be talking to a zombie.
Jyers is just a fork of Marlin with some fixes and custom settings, so its rules are Marlin’s rules. I may be wrong exactly here, but I think it just looks for a bin file, different than the last (possibly last few?) files used for flashing. I have also tried firmware.bin, however. I will try it again.
I unplugged/replugged the display cable at the display, not the control board, and the plug is keyed and is seated well. I think that’s OK. I know it is powered because I see its backlight.

Using ‘firmware.bin’ doesn’t work.
I see no sign that the SD card is being recognized. I suspect the bootloader now. Making the Klipper software included selecting a bootloader (28k for Ender 3v2.) This software did install. I suspect it’s still installed.
Is there some way I can reinstall the Ender 3 v2 bootloader? (I know, I’ll ask Google…)

So there’s only 1 connector on the LCD board? I ask because the display on my Ender 5 has 3 connectors (only 1 works of course).

Yes, only one. It’s a unique design, a little computer itself.

Some info for you to try to find the bin file name. I have a JG Maker Artist-d pro "and the firmware name is “Robin_pro35.bin” Robin is the name of the main board. This may help you find the bin file name.

Thanks, but the link downloads Robin_pro.bin. I’m going to try to contact Creality tech support.
I revisited the Jyers installation video I’d successfully used before; it’s just anyname.bin on a FAT32 card, and that’s worked multiple times for me.
I’ve filed a service request with Creality; my first. We’ll see how that goes.

I’m starting to think the motherboard was damaged. There’s a lot of static electricity lately. I make a point of being careful, but I’ve been handling the USB cable a lot more than normal trying to make this change-over. Maybe I let a spark hit the board one of those times.
I may be out of business. :frowning:

Creality tech support was like crickets chirping. They asked for everything but a copy of my birth certificate, then dropped the conversation.
At this point, the only course of action that seems to make sense to me is to order a new controller board. (I will upgrade to 4.2.7 from 4.2.2, as the difference in cost is $1.)
But before I do, I’m considering the following and would love some input:

  1. Should I consider other controller boards? I know there are a bunch out there, but once I switch, my printer isn’t really an Ender 3v2 anymore, which has its advantages (popularity/community support.)
  2. Should I build my own controller? I have an Arduino Mega 2560 I bought for another project, but it seems like the stepper drivers and proper mounting might come to the cost of the previous solution, with all the disadvantages and none of the advantages. Probably not, but I’m only guessing about costs.
  3. Should I replace the board that failed with a similar board at 1/4 the cost of a new printer? I wouldn’t want to do that two or three times. Am I suffering from the ‘sunken cost’ fallacy?
  4. Should I buy a new printer instead? Even if this was easy to fit into the budget, I can’t see leaving an almost complete printer on the trash heap, so I still want to get the E3 working.

Unfortunately, 4.2.7 boards have gone up about $20US, but they’re still $50-$55, which is not too bad I guess. That would be the route I would go. 1 thing I would do, though, is get some aluminum cooling fins for the stepper drivers. There are quite a few on Amazon. I would get some that aren’t too tall.

Now that I seem to be printing again I would like to take the cheap way out to solve a problem with Prusa Slicer and my Ender 3 pro. My 1.1.8 version of Marlin on an 8 bit card doesn’t recognize Prusa’s M600 change filament command.

I would like to attempt to insert some G code that can read by this card so that I don’t have to go through the ordeal or the expense of buying and installing a 32 bit card that has those capabilities. I think I will have to hook my computer to my printer via Pronterface and experiment. I need to have a well thought out sequence of steps (which I don’t have) to insert.

Perhaps someone could suggest a painless way to do this. My old brain doesn’t work like it used to many years ago.

Chep had a very informative video on this Creality conundrum that I just watched. Understanding Creality Ender 3 Control Board Firmware Fiasco - YouTube

My 1st thought is that you could use PrusaSlicer’s ability to insert code at specific layers. You could insert code to move the printhead to a specific location, retract the filament 50mm, then wait for you to press the button on the LCD display. While the printer waits, you pull out the original filament and insert the new filament. Then you press the button and have gcode after the pause command to feed filament and maybe even draw a purge line.

Ehat happens to the nozzle heat? Do you keep everything heating or turn it off and turn it on again?

Hmmm, good question. I think it depends on the situation. For safety, it would make sense to turn it off, or at least turn it down. If you are going to be nearby and ready to do the filament change quickly, then the heat loss shouldn’t be too, too bad. If you’re not going to be close by then it really makes sense to turn the heat off. After the button press, you have the code reheat the nozzle and bed and wait for them to heat up.

I shall try tomorrow to jumble some code together and see if it works. G code fascinates me because it is quite easy to understand (it seems) maybe I will change my tune later.

GCode is actually quite easy. As long as you have a modicum of logical thinking you should get it.

That remains to be seen.

Got my brand new 4.2.7 board today.
Carefully installed it, turned it on, and nothing but beeping.
I consulted we web and found that that indicated it needed to be flashed.
Flashed new 4.2.7 Ender 3 v2 software onto it and the beeping stopped.
All the stepper motors are engaged and locked. The screen is blank. Pronterface and Octoprint find nobody home. Just like before.
I tried other Ender 3v2 compatible Marlin firmwares. Exact same deal.
Farewell. If I ever get another printer I’ll be back.

@vankichline, I feel your frustration. Can’t help but wonder if something on the printer is causing issues. Perhaps disconnecting all the steppers and heaters, leaving just the LCD display, then trying to connect might produce different results.

Aaaaaand… I’m back,
Thanks, @Ender5r, we think alike. Tried that, no luck.
Then, my lovely wife, who is not prone to such acts, approved the purchase of a Prussa i3.
I was delighted, but still couldn’t let things go.
So I tried once more, combed the web, found many people had experienced this, advice was to reformat the SD card, make sure it’s FAT32 w/ 4K blocks, have nothing on the card but the bin file, and make sure its name is unique (ie: the factory often uses firmware.bin, so try firmware1.bin)
I tried all these, then added one of my own; ignore the common advice and stick to an 8.3 filename.
So I named the firmware file firm0118.bin, and it booted right up!
Just doing a bed leveling print now.
And yes, my Prussa permissions have been postponed one year.

Yes, printers can be pretty picky about firmware files on SD cards. Personally, as a programmer, I find it ridiculous. It simply is not that hard to code a routine that could search for and find all .bin files on an SD card. Then, it could pick the most recent, or even present a list of them on the screen so the user could select 1. The 2nd option would require more code, so it might not be the best 1, but the 1st option should be easy.

As for Prusa permissions go, save them up for a couple of years and go for an XL :wink: