anyone with experience to prepare ender 3D PRO with 4.2.7 board, and BL Touch?

anyone with experience to prepare ender 3D PRO with 4.2.7 board, and BL Touch installed? Mine won’t work.

I’m going to assume you mean you have an Ender-3 Pro printer. If so, did yours come with an 8-bit or 32-bit control board?

Even if it came with an 8-bit board, AFAIK there really shouldn’t be any actual prep work. From what I know, the board is a direct replacement for the control boards that come with the Ender-3 Pro. You simply replace the existing board with the new 1, making sure to move the cables to exactly the same connectors.

What you may not have done is flash the new board with the firmware. You should download the latest firmware from Creality: [U][/U]. You will have to choose the correct file based on whether you have a BL Touch or not. You copy the file to a micro SD card as the only file on the card, put it into the printer when it’s turned off, then power on the printer. It should auto-flash the firmware chips on the 4.2.7 board.

The printer came with a 4.2.2 board, which I think was 32 bit.
I had tried the latest firmware from the Creality site, but it still didn’t work.
I am going to try installing the firmware from another video on the web:

I will let you know the results after loading this new firmware.
thanks again, as it seems there is almost no one with experience in this package.

The 4.2.7 board is a direct replacement for the 4.2.2. As long as you made certain to move the wires to exactly the same locations on the new board, then loaded the Ender-3 Pro firmware according to the directions, it should flash the firmware and you should be good to go.

BTW, I forgot to ask the 1st, most important question: exactly what do you mean when you say, “Mine won’t work”? Please provide details about what is happening.

What I meant was that after auto home which took it to the center, the next move crashed it into the right hand side. I bought the 4.2.7 board and BL Touch separately from Amazon.
Ok, tried the new firmware. It tok it OK, after a couple of tries to reset EEPROM, Now says Marlin 2.0. but when trying to level the bed, it crashed again into the right hand side.
I am amazed that no one else has come across this problem!

On the main screen, the X, Y, and Z figures flash between 0 and ? Is this normal?

Also just noticed it says Ender 3, 4.2.7 not Ender 3 PRO 4.2.7 (not sure if this matters?)

Is this the file you use: Ender-3 Pro_4.2.7_Firmware_Marlin2.0.1_V1.0.1_TMC2225.bin ?

Yes. And have also tried various other firmware, but all seem to have the issue of moving the print head to crash into the right hand side. What could cause this and how to fix it?

It is not true that firmware is firmware. The firmware for any specific printer must be configured for that printer. While many hobby level, Marlin based printers have a number of things in common, it is also true that firmware configured for 1 model of printer most likely will not work for another printer. Microsoft Visual Studio Code (VCode) is the most common compiler used to configure and compile Marlin for a particular printer.

That said, I am now using Klipper on my Ender 5 Pro. It only uses stub firmware on the printer’s control board. The bulk of the processing is handled on a Raspberry Pi. It took me a few hours, but I was able to configure it to run the Ender 5 very well. One advantage of Klipper is that it doesn’t require compiling. Virtually all of the configuration is done through 1 configuration file: printer.cfg. The 1 disadvantage is that a Raspberry Pi is required. That said, I am now printing @ 100mm/sec, twice what I was doing with Marlin, and I don’t think I’ve found the top end yet.

Thanks. I intend to start with Raspberry Pi, and then Kipper etc. as yo suggest. But first, I want to fix why my printer is doing that crazy smash against the right hand side…

It sounds as though the bed parameters may not be set up properly in Marlin, but I can’t be sure.

That’s is what I was thinking. I am surprized that if that’s the case, that no one even at Marlin has clued into this yet. Not sure that I can fix this myself, as I am a newby. I am hoping comeone else has come across this bug, and that there is a fix for it.

Well, the Creality firmware you flashed didn’t do it, did it?

No, nor did any other which I downloaded and tried. like I mentioned I am surprized no one else has cone across this, or knows how to fix it.

Did the 4.2.2 board do this? If not, then I would suggest you’ve got some of the wiring mismatched. It really sounds like the printer is expecting to have the carriage hit an endstop switch, but it’s going the wrong way, or the wrong axis is moving.

I would reflash the firmware. Do you use Cura? if so, under machine settings with the printer make sure the bed dimensions are correct and that the origin at the center box is unchecked. then put the card in your machine and turn it on. Hopefully this helps, I’m running Klipper on a pi too on my modded Ender 3V2 and have added a setup dual Z axis. I print at 150 to 200 normally 100 when using hard to print things and have printed at 300 but it becomes violent. I had to install a Z Axis gantry brace because it was flexing and the nozzle was hitting the print at high speed. Good Luck!