I have an Ender 3 pro with a bl touch I just upgraded to a color screen but cannot seem to find the right firmware, I have tried several and every time I turn printer on after loading the sd card all it does is beep.Can someone please help me.

Have you confirmed that it still works with the original FW and screen?

Yes I have put it back to original and it works fine. I did have one firmware were it loaded but when I did autohome it went to the right and when it got to the end it kept trying to go further. then when I tried to level bed it went down and kept trying to go further.

It seems pretty clear that that 1 firmware is flawed. I don’t know what firmware you need for the color screen, but it seems to me that it’s more important to have a working printer than a color screen. I presume you have searched the net for “Ender 3 Pro” and “whatever color screen you have” in trying to find a compatible FW?

Yes I have, it is the screen from a Ender 3 V2.

Is it this 1: Buy Upgraded Touch Panel Screen Display for Ender-3(Pro)/Ender 3 V2?

No mine is not a touchscreen

The Ender 3 v2 had it’s own firmware that needs to match the version of firmware on the MB. Which motherboard do you have in your Pro?

I have the 4.2.2

Try flashing the LCD with the attached firmware. You will need a 8gb or less SD card. You will need to open the LCD case and use the SD card slot on the screens MB. In the zip file will be a folder named DWIN_SET put that folder on the SD card, put it in the screen’s SD card slot and power up the printer. Been a while since I’ve don’t it but I think the screen changes color when it’s finished flashing. (207 KB)

Thank you will try it tonight

Nothing but beep

Personally I prefer the screen that comes with the the Ender Pro, I put one on my Ender 3 v2 when I put a EZABL on it. My E3V2 has the 4.2.2 mb too but not Creality firmware. I know when I switched to the Pro LCD I had to compile the firmware for an Ender 3 Pro. You may need to do it the other way and flash your Ender Pro as a Ender 3 v2. I use Unified2 firmware.

Tried that didn’t work

Maybe you have a bad screen

I don’t know but I gave up and put the original back on,but thanks for the help everybody