My second Ender 3V2, My second blank screen.

Please, please, please help me…

I just sent back my Ender 3V2 and got a replacement because I was having all sorts of problems with it. The last thing that went wrong before I sent it back was when I installed the BL Touch and tried to update the firmware. Here’s what I did on the old machine:

  1. Installed the BLtouch hardware. I have the 4.2.2 board so it plugged right in. When I turned on the machine the BLtouch clicked twice and was lit up so it looked good.
  2. So then I went to upgrade the firmware. I copied the CORRECT firmware from Smith onto the SD card that came with the printer, without formatting it first. (It was already in FAT32, so I figured it was all set.)
  3. I inserted the SD card and the machine powers up but the screen shows nothing.
  4. I tried a zillion different things with different SD cards, formatting it over and over, different versions of the firmware (with a different name every time) etc. NOTHING WORKED.

I sent that printer back ordered a replacement and just finished assembling the new one. It was perfect. Nice and level, nice and square, etc. I’m excited to get going again. Boots up perfectly looks great… So I…

  1. Took a freshly formatted SD card and put JUST the new .bin file on it from Smith.
  2. Put the SD card in the printer and turned it on. Boots up fine, but no new menu items or anything.
  3. Repeated steps 1 and 2 several times.

Then I made the same mistake I did on the first printer…

  1. I put the new .bin card on the SD card that came with the printer (thinking maybe my SD card was bad) and turned the machine on and I’m back to a dead printer. Nothing on the screen no way to reload the firmware or anything.
  2. I put the other SD card in that I had used on the previous attempes, and nothing happens.

I’m back to a dead printer and SO DAMN DEPRESSED about it!

So please, please help me to reset my printer. I can find NOTHING anywhere on the internet that gives me a clue as to what to do except the same thing I have done over and over again. Where is the “RESET TO FACTORY SETTINGS” switch???

PLEASE HELP ME. I can’t take this happening again.


Holy Moly… The six billionth thing I tried worked…! Hope this helps someone else in the future.

  1. I reformatted the SD card using the SD Formatter Application not Windows.
  2. I loaded the 0.9 version of the .bin file from the ender site along with the DWIN_Set folder
  3. I put the SD card in the display unit and rebooted. The screen turned orange after a few seonces as it should. Reassembled and reattached the control panel…
  4. I powered down, removed the power cord, inserted the SD card into the main slot. Plugged in the power cord, crossed my fingers, and turned it back on.


After about 20 second the loader screen came on and the original firmware was installed. So…

  1. I reformatted the SD card again, and this time put the SMITH version of the firmware on it.
  2. Removed the power cord. Inserted the card, put the power cord back in, crossed my fingers agian. tuned on the power switch and

HORAY!!! It rebooted properly and now I have all the fancy new stuff that the Smith firmware offers.

I can use my BL touch and start printing again.

I am SOOOOOOOO releived!

Hope this helps someone in the future.!