help with firmware uploading please

Hey guys, I need a little assistance. I spotted, on a Creality website, Marlin 2.0.1 firmware for my Ender 5 Pro. But, it’s a .BIN file & I’m not sure how that gets uploaded to the printer. Can anyone point me in the right direction?

well on my ender 3 v2 the bin file is put on a sd card and the printer is turned on and that’s it. But my printer has a boot loader and i’m assuming yours does not. the bin file has to be loaded via a boot loader so i’m assuming your not going to be able to use it unless you can somehow get a boot loader on your controller board,

Have you done any firmware upgrades previously? That aside, I’m going to point you to the best resource I know for working with firmware updates - Teaching Tech - Updated Marlin firmware setup guide - VS Code and Auto Build Marlin - YouTube

Hope this helps.

All Silent 1.1.5 controllers, like mine, have a bootloader built in, but that doesn’t help. As I understad it, bootloaders don’t automatically have the ability to upload new firmware. I know the Ender 3 V2 does, but I don’t believe mine does. What it can do is receive firmware uploads sent to it from a USB-connected computer, without having to use a ‘programmer’.

That said, I will copy the firmware to the SD card and see if anything happens.

The results are negatory, mon capitaine.

I cleared out the SD card and copied the .BIN file to it as the only file on the card. I left the name exactly as Creality provided it. The printer booted up and paid zero attention to the .BIN file.

I renamed the .BIN file to firmware.bin and powered up the printer. Again, it paid zero attention to the file.

Bottom line: I still have no way to upload a .BIN file to the printer. I will look into other firmware updaters but would welcome any hints or tips.

I had the same problem using the creality firmware. I downloaded firmware from another place and it worked.
My latest firm ware is the Smith3D. Uploaded with no problem.

What’s the storage size of your SD card. Must be Fat32 format and not the windows FAText format

I’m currently running the TH3D Studio firmware, but it doesn’t support the BL Touch I have coming. I believe there is a version of the TH3D firmware that will support BL Touch, but I would still like to know how to upload Creality’s provided firmware.

Did you try what @FosterBDAV66 suggested about watching the video that teaching tech shows how to do? Updated Marlin firmware setup guide - VS Code and Auto Build Marlin - YouTube

I did watch it, and I was able to take the default version of Marlin 2.0 bugfix, along with the corresponding configuration files, and compile & upload it to my printer. I haven’t tried printing with it yet, but it seems to have loaded into the printer’s firmware. There were 4 options available for compiling; 2 or them worked.

That’s all great & all, but it still doesn’t answer my original question: how do I upload a supplied .BIN file. The YT video shows how to use VS Code, so it was helpful in getting me started with that. I’ve looked a little bit, but still haven’t found a way to get VS Code to upload a BIN file that wasn’t compiled by VS Code.

For a lot of editing, I use Notepad++. There’s an addon for bin files. Also, VS studio should be able to directly import the file.

How to view binary files with NotePad++ - Programmer Sought.

I’ve used Notepad++ for years, but it won’t help in this situation. I’m not trying edit a .BIN file, I’m trying to upload it to my printer, to replace the existing firmware. So far, no luck. I did just notice that there’s an arrow that points to the right, much like the upload arrow in Arduino IDE, at the very bottom left of the VS Code window. When I hover my mouse over it, it says PlatformIO, so I’m wondering if I could use it to upload a non-VS Code compiled .BIN file to the printer. Will have to check it out.

BTW, the reason I want to do this is because I found a video on YT wherein a BL Touch was added to an Ender 5 with genuine Creality firmware. The process was so easy it didn’t require a recompile of the firmware, or even an upload of different firmware. The detection of the BL Touch was automatic: the firmware took care of it. The YouTuber was actually quite surprised at how easy it was. Since I have a BL Touch coming, I wanted to be prepared by having genuine Creality firmware on the printer.

I am on pins and needles to see the results. As I remember you still only have 8 bits and not 32 on your printer.

Yes, my Silent 1.1.5 board is 8-bit, based on the ATMega1284p chip. I do have an SKR 1.4 Turbo board coming, along with 5 TMC2209 stepper drivers.

I finally got my fan and my screw in thermistor. I actually have an old fiddly thermistor in at the moment I shall do the upgrades tomorrow,en sha Allah or whatever the Muslims say.

Inshallah (or InshAllah or In sha Allah).

It’s phonetic, they don’t speak English necessarily. More likely to speak French. At least in the Arab countries I know a little bit about.

Did you order your bltouch through the Creality website?
“The BL Touch kit sold by Creality applies to 8-bit motherboard 3D printers.”

I ordered it thru, but it supposed to be a genuine Creality package, which should work well with my Silent 1.1.5 control board. My understanding is that I will be able to migrate it to the SKR 1.4 Turbo board I have on order.

For a moment, I thought the poster here was you… [URL=“”]

It may be of some assistance to you.

Nope, not me. I have never used Reddit.