Ender5 Pro firmware update for BLTouch

Installed BLTouch but I can’t update the firmware.
The problem is that my computer (Windows 10 home edition) does not recognize USB ISP. I tried all the drivers on the internet (see attach driver_failed.png).
I tried on several computers, but it doesn’t work.
I also tried PrusaSilcer but it didn’t work (see attach prusa_failed.png).
It didn’t work on Cura either.

I failed to update the firmware. :frowning:

Does anyone have any ideas?


Three things come to mind.

  1. Check with a different USB cable.
  2. Make sure no other software is hooking the USB. (eg Putty, YAT etc)
  3. Unplug power to both printer and computer, then power up printer then computer. USB settings seem to persist in sleep and standby modes on some systems.

If you have done all the above without joy, then you might consider disconnecting some peripherals. “Com Port 11” suggests that you might have other gear hooked up?
Let us know how you get on.

I agree, unplug every USB device you can while still remaining functional: e.g. keep mouse and KB plugged in. Then, reboot the computer to ensure nothing is hanging on to ports.

I just installed Windows 10 on an older laptop. Not working. Same messages.
I sent an email to Creality. Let’s see what I answer.

#Leo From frustrating experience over the years I have never found that OS upgrades work faultlessly with legacy hardware. This is especially the case with laptops which tend to be more tightly integrated with “special versions” of standard hardware chips. The consequence being that the newer drivers either don’t work at all, or worse lead to seemingly unconnected software problems. For the hundreds of wasted hours and because laptops are so cheap (comparatively) I now always recommend shelving the laptop with its original OS and working software installs and investing in a new machine. I have an XP laptop, a Vista laptop, a Win 7 laptop (my favorite VAIO) and a Win 10 laptop. They are all useful, running odds and ends of software that either I could not afford to upgrade or were never ported to the new OS version.
Don’t expect too much from Creality, as covering all the possible permutations of hardware is just not going to be possible. One additional suggestion was to check that you are not using a USB hub, as I find sometimes these can cause problems with more complex peripherals.
Keep digging.

I use a USB hub, but I also tried without a HUB. I tried on three laptops 2006, 2016, 2019 and on the desktop since 2017. On none of the computers did the USB ISP recognize me.

#Leo Sounds like you have already done everything I would have done. The 32bit BTT boards are well known for not being flashable via their USB cable link, only via the “firmware.bin” on a thumbnail drive. The Creality silent boards should work fine with USB, but you could just see if the thumbnail drive flashes OK. At least that might get you up and running again?

The main problem is that the computer does not recognize the USB ISP.
And I don’t know any other method to load the hex file on Ender5 Pro. :frowning:

#Leo OK. The process it really quite simple. Find a precompiled .bin file for Ender5 Pro on Github. Copy it onto the thumbnail drive. Insert the drive into the computer and switch it on. It will take longer to boot up, as it is flashing the new firmware. Once it does boot you can remove the drive. This may actually resolve the comms error as it resets the settings. If you are running Marlin I will post a link. TH3D have their own procedure.

I finally got around to looking up what a USB ISP is. I’ve never seen one of these before. I gather they are supposed to allow for loading of software onto certain controller boards. I don’t know what ISP stands for though, other than Internet Service Provider, which doesn’t seem applicable here.

Ah, found it in a Wikipedia article on AVR microcontrollers: in-system programming. From Wikipedia:

[I]The in-system programming (ISP) programming method is functionally performed through SPI, plus some twiddling of the Reset line. As long as the SPI pins of the AVR are not connected to anything disruptive, the AVR chip can stay soldered on a PCB while reprogramming. All that is needed is a 6-pin connector and programming adapter. This is the most common way to develop with an AVR.

The Atmel-ICE device or AVRISP mkII (Legacy device) connects to a computer’s USB port and performs in-system programming using Atmel’s software.

AVRDUDE (AVR Downloader/UploaDEr) runs on Linux, FreeBSD, Windows, and Mac OS X, and supports a variety of in-system programming hardware, including Atmel AVRISP mkII, Atmel JTAG ICE, older Atmel serial-port based programmers, and various third-party and “do-it-yourself” programmers.[SUP][17][/SUP][/I]

@Mr_Doohickey Is this the file you mean: [U]https://github.com/christran206/Marlin2.0-SKR-Mini-E3-1.2/blob/2.0.x-bltouch/compiled/firmware.bin[/U]

#Leo #EnderSr
This has just popped up https://www.youtube.com/post/Ugxfe4jHIDHt12siwV14AaABCQ
Going forward, can you still access you printer with terminal software eg Pronterface or Octoprint? Please share the output of a M503 command. Just cut and paste it. A photo of your BL-Touch wiring into the mb would be helpful too. Just trying to be systematic as if your machine was here on my bench.

OK, so that’s definitive: Daniel says it won’t compile; Koyodee says it did for him. Hmmmmmm… what to do, what to do… maybe just stick with what’s working.

#EnderSr I concur, however we have not established which version of Marlin #Leo had installed or was trying to upgrade to. #Leo, if you have the time to spend working through this, I’ll help.

@Mr_Doohickey yes, sorry. I was sort of making a joke about what I should do. For sure we need to help @Leo in whatever ways we can.

OK, so I looked up how a USB ISP is used. Interesting process. Luckily, when I had the PS box of my Ender 5 Pro open, I took a photo of the controller board. Looking at it, I can see the 6-pin header next to the LCD ribbon connector socket. It’s even labelled ISP.

So, connect the ribbon cable from the USB ISP to the ISP header on the controller, plug the USB end into a Windows computer (it seems a lot of the USB ISP units only have SW for Windows), boot up the computer, then run the software designed to run with the USB ISP in use, and download the firmware. Is that about it?

No source code: https://github.com/Creality3DPrinting/Ender-5-Pro

Do you have 2 different products there? I can see a ribbon cable at the right edge of the instruction sheet. Is that real, or just part of the instructions?
I don’t see a photo of the pinboard at all. If the ribbon cable in the photo is just an image on the instruction sheet, I don’t see a photo of the real ribbon cable.
From the diagram I strongly suspect the pinboard, the correct one for your controller, is essential. I think the pinboard is used to match the wiring of the USB ISP to the header wiring on the controller board. I would suspect the pinboard is specific to a particular group of controller boards, and that other groups of controllers might have different wiring that would require different pinboards.IOW, the pinboard is a wiring corrector.
I don’t quite understand what you mean about the URL you posted. You say, “No source code”. What does that mean?

Just part of the instructions.
It is the BLTouch package received from Creality.

The main problem is that the computers do not recognize the USB ISP device in the image.
It doesn’t matter if I connect it to the MB of the printer or not.

But you did get a pinboard, right?

Agreed, whether or not the USB drive is connected to the printer, it should be picked up by the computer. You don’t even get the happy “USB connected” sound?