Reported error: Probing Failed

Howdy from the bootheel of Missouri, Dr. Vax and the Dr. Vax community! I recently purchased an Ender 3 V2, RPI 4, and a BLTouch. I followed your instructions to the T and installed Smith3D firmware as well. All went well for 2 or 3 prints. Then, I started getting an error in Octoprint that said " Error reported by printer, Your printer’s firmware reported an error. Due to that OctoPrint will disconnect. Reported error: Probing Failed ". I turned off the RPI and the E3V2 and turned them back on and got 1 print done and then the problem returned. I read up and thought that it could be the 5v pin on the USB so I eliminated that as a possibility in the scenario but still got mostly failures when trying to print from OctoPrint. I finally gave up on trying to use OctoPrint and went back to manually inserting the MicroSD Card. Of course, I have given up all of the great features that Octoprint offers. I am now in search of a solution to the problem that I am having but have not gotten anywhere. Do you have any suggestions as to what I could try to resolve the problem?

Thanks in advance

OctoPrint always shuts down on error.

It does the same on thermal runaway. I think the disconnect is caused by the firmware, as the error screen is a loop, which requires a reboot and because serial data is no longer processed OctoPrint “thinks” the printer is disconnected. The last thing OctoPrint gets is the error status.

Also OctoPrint has no impact in failed prints. It is just a data sending unit and the chances of failing are minimal. Especially when using a raspberry pi.

In your case I expect a broken wire or a loose connection to be the issue, as it is random. Well, if the loose stuff is not inside the BL-Touch itself.

The printer is moving all wires during the homing/probing, which probably triggers the problem randomly.

The only other issue I can think of is that your pi is using to much power. Since you use a Pi4, which is hell of an overpowered system for the job, you need a beefy power supply. Especially not using an external power supply this can be an issue, as the printers power converter is not made for such power on the 5V rail. However, if you are using an external power supply to power the Pi, this is most likely not the issue.

I agree with @Geit, especially about the loose or broken wire. In particular, I had a problem with the 5V wire at the BL Touch end (the 1 on the right end of the connector). Once I reseated the wire, the issue I had went away. I would start there.

I had the same issue with my Ender 3 v2 and Bltouch. The 1st Bltouch I had was defective and I returned it. The 2nd one worked for a while then crapped out entirely. Like @Ender5r said make sure your connections are tight. There are also reports of interference from the hotend. I used the shielding that @Larry mentioned in this thread Bltouch caused print job to fail - MakeWithTech Community Forum this worked but wasn’t perfect as the probe would still fail about 1 out of 10 prints. It finally got to the point where it wouldn’t even pass the self test. I replaced it with an EXABL and haven’t had a failure yet, knock on wood.

Wow, what a great set of responses.
I will try all things mentioned here and report back today. :slight_smile:

[B]Geit, The connectors are seated well and all of the wire is in perfect condition. I even went so far as to test conductivity with my Fluke. The RPI is being powered via the power supply that came in the CanaKit with the RPI 4.

Gramps, I may end up going with some sort of setup like the EXABL I suppose. I did not try the shielding idea as of this message.

All of the suggestions, outside of the EXABLE and Shielding having been done… I decided to try a print and got the same failure. Then I remembered having read about issues with the screen firmware. So, I decided to disconnect it at the connection on the back of the screen. This amazingly allowed OctoPrint to function for a quick print and all was well. Then I decide to try a much longer print which is currently about 5 hours into a 7 hour print. Now I cannot get octopi to even load but the printer is printing just fine LOL…No screen, No Octoprint GUI … Crazy. Crossing my fingers it will finish as normal.

Now I am left with the same or maybe even worse problems. So the question I have is this:

If money is no object, What motherboard, screen, and firmware, and ABL combination for the Ender 3 V2 would you guys/gals buy to make sure you had the most reliable yet versatile setup?

Also, thanks again for taking time out to help me out![/B]

You cannot see a broken wire in the same way you cannot see if the sensor is damaged on the inside.

I’m glad I stayed simple but why not if I only have one printer. Every time we add complication the possibility of failure greatly increases.

I totally agree and I would suspect the wires or the bltouch itself if it did not work when I use it without OctoPrint. After the long print completed last night, I started another and tried once again to use OctoPrint but the same old probing failed error came up and I had to restart the machine. I simply unplugged the RPI and went back to my sd card and all worked great. It is all very strange in my opinion.

It is my understanding that the LCD on the Ender 3 v2 has issues because the firmware on it is not open source and therefore Marlin has trouble talking to it. I ended up replacing the screen on mine with one from a Ender 3 Pro, $20. It’s not as fancy or as pretty as the v2 version but is sure more functional. With it you use firmware for a Ender 3. That is really odd the you are having issues printing from Octopi I have been using one since day 2 and have never had an issue with Octoprint or the Rasberry Pi, my Bltouch would throw a probing error which showed on Octopi but the message came from the printer. I would have to turn the printer off and back on then reconnect Octopi.

Have you tried a different usb cable? They are not all created equal. Guess it’s also possible that the USB connector on the board of the printer could be bad too or even the one on the Pi I suppose. To troubleshoot the RPI I would disconnect the Bltouch, flash the stock firmware and see if printing through the RPI woked okay. If you try this be sure to remove or comment out the G29 in your starting gcode. This will take the RPI out of the equation if it works this way.

The Bltouch and also be wired so the black and white wire go to the Z limit switch instead of the Bltouch connector on the motherboard, you’ll need firmware that knows it wired as such, Smith3d has this I believe. Personally I use Unified2 firmware from Th3dstudio but you have to compile it yourself which isn’t a big deal.

Much good information in your message. I am well aware of USB cables being far different from one to another but until you said it, it had not crossed my mind. I am positive that the issue is not OctoPrinf as the error says directly that the error came from the printer’s firmware. It is an easy item to replace and test the theory as I have an old shoebox full of USB cables I can try out. :slight_smile:

What you said here: " [/B] my Bltouch would throw a probing error which showed on Octopi but the message came from the printer. I would have to turn the printer off and back on then reconnect Octopi." is exactly what is happening with my rig. It is not consistent but it sure is an annoyance that I want to live without.

[B]I will give that as well as all of your other suggestions a shot today, with the exception of hardware that I don’t have on hand of course.

So let me make sure that I have this right and remember I am a noob when it comes to 3D printing and all associated hardware and firmware. I am having a fantastic time making things and learning all about the machines so a problem is really and truly an opportunity for me to learn more.

If I want to get rid of the issue I am having, I should probably replace the fancy screen that came with the E3V2 and replace it with the screen from a E3Pro. Then, on the new screen, I should use the firmware from the E3? Then, as far as the motherboard firmware, I should use TH3D’s Unified2 firmware? I am not afraid to compile on my own via their website as the website for doing so looks like it is fairly well laid out to make the compiling fairly easy.

Once again, I say thank you to you and all that have replied with some ideas![/B]

@omnimanx1 The screen from the Pro will give you more options like baby steps for the Z offset, baby step being .025mm. I don’t however that it will eliminate you probing errors from the Bltouch. I suggested the Pro screen because you said you could print if you unplugged your screen, plugged in your got errors, that is unless I read something wrong. The LCD screen for the Pro doesn’t have it’s own firmware the the v2 screen. You do have to use firmware for the motherboard that is for the Ender 3 and not the Ender 3 v2. Hope that clears it up some.

Does your cable for your Bltouch have to Dupont connectors on it? If so then take the one with the 2 wires on it and plug it into the slot on the motherboard where the Z limit switch is plugged in. You will then need firmware that knows it’s wired that way, I believe Smith3d has some compiled or you could download the Unified2 firmware from Th3dstudio and compile it yourself. They have good directions on their site on how to do it. Their online compiler is only for the firmware for their EZboard.

The printer is reporting the error because the probe is connected to your printer and is failing. I had the exact same error your having now and as @Gramps pointed out i shielded my bltouch cable with this metal sleeve then at the main board end i soldered a wire to the metal sleeve and grounded the other end of the wire to the frame of the printer. Remember to only ground the one end and NOT the other. This has fixed my problem with the bltouch completely and i have suggested this to others and it has fixed theirs as well. I’m not saying this is your problem but it does sound like it.

I found out the hard way that the shielding that i pointed you to was not the best one for this kind of EMF problem. I had some intermittent probe failures again and after a lot of research finally found this sleeve works a lot better…?ie=UTF8&psc=1 After replacing the old one with this new one i haven’t had a single probe failure. Just thought i’d update you on this.

Thanks for the update, my probe went south on me and I replaced it with a EZABL which come with a double shielded cable. It has been working well.