Ender 5 Pro (4.2.2) / BLTouch 3.1 / Marlin 2.0.x-bugfix


I know that this question has been asked before. I’m asking here, because none of the threads I read through, or videos I watched have worked for me.

I’m trying to get a BLTouch 3.1 to work with the newest Marlin 2.0.x-bugfix using VSCode, Auto Build Marlin, and PlatfomIO on my Ender 5 Pro with a 4.2.2 board. I’m compiling the firmware and flush it from the SD card. This has worked for turning on Mesh Bed Leveling and I know the firmware is uploaded properly.

The issue I’m having is that the probe does not deploy on Auto Home or Bed Leveling form the printer menu. G29 doesn’t deploy the probe either. The self test after turning the printer on, works. The probe works fine with Marlin 1.3.1. When I flush the firmware with the pre-compiled version I downloaded form the Creality website, everything works, except I cant set my probe offsets. So I don’t think it’s a wiring issue. Not to mention that I would prefer not to use an old firmware. All the articles and videos I can find on the topic are almost a year old or older, and are not specific to my printer. Is there any new development? Did anyone have the same issue with the Ender 5 pro (4.2.2 / BLT 3.1)?

Any help is greatly appreciated.

I’m going to assume your main concern is just getting the printer working. If, OTOH, 1 of your main goals is to learn VS Code & Marlin, then ignore this post.

To get the printer going I would recommend you try the TH3D Studio Unified Firmware. You can find it here: [U]https://support.th3dstudio.com/hc/en-us/articles/360049104812-Creality-Ender-3-3-Pro-Ender-5-5-Pro-Firmware-V4-2-X-Board[/U]