Ender 5 Pro: BLTouch leveling goes off bed

Ender 5 Pro
silent motherboard v4.2.2 (32-bit)
BLTouch v3.1
TMC2208 Drivers
Chip: STM32F103RET6

I am new to 3d printing with some technical knowledge on hardware and software. I got this printer 3 months ago and I am not able to level the bed, it gets off the table while doing the third point out of the 9 point leveling . I have sent several emails to creality support and they had provided two different firmwares but issue still not solved. I hope this forum helps me to resolve this issue



I’m not familiar with that printer, but if Creality has implemented Marlin 2.0 there should be an option under an advanced menu to change the X and Y offset of the probe. Alternatively, check out: M851 - XYZ Probe Offset (requires a USB connected to the printer and a terminal program like Pronterface).


P.S. – Looks like there is a slightly newer version of the firmware available too.

Thanks Alan for your answer. I have tried different options:

  1. M851 X-42 Y-6 using pronterface
  2. Three firmwares provided by creality support
  3. Setting the x-probe-offset and y-probe-offset using the LCD console
  4. I compiled latest version of Marlin 2.1.1 using Visual Studio Code
    #define NOZZLE_TO_PROBE_OFFSET { -40, -6,0 }

I have not found a way to measure exactly the distance between the probe and the nozzle, so those numbers are approximate, but they should have prevented the probe to go off bed

Ok, you are way ahead of me. At this point, I’d speculate that the motherboard is bad. I believe @Ender5r has a one of the variants of this printer and maybe has some ideas.


A means of measuring:
Use piece of paper, use a pen or pencil to mark a location to set nozzle on near center of bed. Twist paper for square alignment with bed.

Then mark position of probe. Use ruler to measure x, y offsets from points on paper.

In my experience, this is a matter of bed description, but it could be several things:

  1. is it possible you have the X axis endstop in the wrong position? If the endstop is too far left, and the bed is described as 220 x 220, then it’s possible the firmware is moving the printhead to the position it thinks is correct, but it’s starting point is too far left.

  2. you haven’t stated what dimensions are used for the bed in the firmware.

  3. I can’t remember if Marlin has it (I now use Klipper) but there may be parameters in the BL Touch section of the firmware that state what the safe probing area is. If those parameters exist, they may need adjustment.

  4. I’m hesitant to recommend it to someone who is still trying to get the printer to work initially, but you might want to explore Klipper firmware.