Ender 3pro Silent Board

I got the 1.1.5 silent board for my Ender 3 pro. When I installed it my extruded stopped going after a little while into the print. In the I could manually move it - it looked around and this seems to be a relatively common issue.

I tried flashing the firmware to Marlin 1.1.9 through the usb using Cura and the printer wouldn’t take it once I sent the update the machine restarts and the firmware never starts getting installed.

What could I be doing wrong. Every where I read this issue with this board is that it needs a firmware update to correct this issue, but I can’t get the firmware installed

I would check a couple of things. First try a different USB cable when flashing the board. If this does not work the best option might be to put your old board in and return the board to creality.

I am a big fan of the th3d ezboard because of the excellent support you get for a 32 bit board with quiet stepper drivers. Yes it is more expensive but worth it to have a company that will help you with issues.

As I mentioned in our private conversation, I flashed my 1.1.5 Silent board wth the TH3D Unified Firmware, because the 1.1.8 Marlin it shipped with was seriously flawed. That firmware is still running flawlessly. As Irv points out, there are advantages to the TH3D EZboard, so much so that I likely will upgrade to one in the next few months (if I don’t sell my Ender 5 Pro and go with another printer.
Which, BTW Irv, leads me to ask: do you have any experience/opinions on the ADIMlab gantry printer?

Small point, but Marlin 2.0.x is backward compatible to the 8 bit ATMega2560 Creality Silent Boards. Some folks think you have to hop up to 32bit for 2.0.x

I’m almost tempted to try flashing Marlin 2.0.x on my Ender 5 Pro, but I have to wonder what advantages/disadvantages it would have over TH3D Unified/

I can’t recall if Irv has done one, but Michael at Teaching Tech did a very fair comparison of vanilla Marlin configuration and TH3D Unified. I have stuck with Marlin but I visit TH3D site for their troubleshooting guides, which are very clear. Atom used to be my editor, but I have switched to VScode and PlatformIO recently and find it easy to use, as a non programmer. There are now lots of vids walking you through this. Worth watching, as the directory structure was changed for Marlin 2.0.

Funnily enough, given my history, I haven’t done any programming for 3D printing. I’ve tweaked a few gcode files to better suit my wants, but I hardly count that as programming. I’ll have to look up that comparison video. TH3D certainly have a leg up in my estimation, since their firmware basically saved my printer.

Ditto tweaking g-code! Funny how even after thirty years ppl still say " You use computers to make stuff…so you MUST know how to programme/code!" I reply, “Nope. I am a designer, not a software engineer.”

I started far enough back in the industry that I’ve worked in almost every category. One thing I’ve never done is actually design chips. I was almost involved in a new CPU design, but something else came up and I didn’t have time. But I have programmed in 1s and 0s to make an assembler program, written many device drivers, and done design on a bunch of systems and devices. 50+ years in the industry gives you time to be involved in a ton of stuff.

Myrddin-Wylitt. Just to get back on your topic. If you want “configuration.h” and “configuration_adv.h” info for Marlin I will put it up. One thing that caught me out was that the “configuration.h” board definition is for a “BOARD_RAMPS_CREALITY” rather than the “mega2560” board as specified in the “platformio.ini” file.

Hope this helps some.

@Mr_Doohickey Do you have any insight as to why it might be preferable to flash Marlin 2.x over TH3D Unified? It might be pertinent to @Myrddin-wylitt.

Me neither, Sir. I designed computer graphics (stills, 2D and 3D animation) ?

I am a big fan of the TH3d unified firmware. It is well documented and the support in the community is quite good. In addition, Tim at TH3d is working on upgrading to Marlin 2.0. The TH3d Ezboards (their proprietary control boards) already run on Marlin 2.0 and in addition, they have built an online build system. If Th3d makes this build system available for the unified firmware, even at a price, this will be a valuable addition for the community.

I first learned about the TH3d unified firmware when I purchase an EZABL kit. I made a video about installing the EZABL and building the firmware you can find here:

This was all done on a Mac.

I’m still waiting for a reply from TH3D about my Creality error message. (‘Creality’ does not name a type) I don’t really want to upgrade to TH3DUF because Marlin 1.1.8 would probably be still ok for my 8 bit board that has a boot loader flashed on it. I would just like to be able to implement the Prusa slicer M600 filament change command. But it seems like this Marlin 2.0 is backwardly compatible. It also looks like the filament change command is un-commented already.#define ADVANCED_PAUSE_FEATURE. I guess I will have to send them another help message.

Seems to me you could implement a filament change in gcode yourself. If you look at DrVax’s bed levelling gcode, you can see he puts a pause in the procedure, to allow people to check the level of their bed at that point. You have to click the button on the LCD to continue. Why couldn’t you use that pause as a way to change the filament? You would, of course, have to add the pause to the gcode, but that should be easy with Prusa Slicer’s abiility to add custom gcode at any layer.

I tried it in Prusa but I think the problem is that #define ADVANCED_PAUSE_FEATURE is probably not un commented in my Marlin 1.1.8.

I don’t believe I’m talking about the ADVANCED_PAUSE_FEATURE. I’m talking about this code:

M300 S440 P200
M300 S660 P250
M300 S880 P300
M117 DrVax Level then Click
M0 DrVax Level then Click ; Pause print

The first 3 lines play a tune on the LCD unit. The 4th line prints a message on the LCD: that is, “DrVax Level then Click”. The last line pauses the procedure, and it will not continue until the LCD button is clicked. You could use that pause to change filaments. Now, I suspect you would have to manually purge the filament to get to the correct color, but that shouldn’t be much of a hassle unless, of course, you want it all automated so you can leave the printer unattended. But, without an automated filament changer, you can’t do that anyway.

It seems that the code would have to be quite elaborate because the hot end has to be moved and parked, a beep to tell you it’s waiting and then wait till you push the resume command. I think Irv said that Cura has the long g code written out. I should just try Cura first and then copy the Gcode to Prusa and see if it would work there. I decided to just use Prusa instead of trying to use four or five slicers. It doesn’t make any sense to me. I have to tryout my new diluted uhu stic anyway.

I’m not sure it would have to be elaborate. What if you did this:

G28 ;go home
G1 Z100 ;lower the bed in my case, raise the printhead in yours
M300 S440 P200 ;play
M300 S660 P250 ;a
M300 S880 P300 ;tune
M117 Change filament ;display message
M0 ; Pause print

The only thing I’m not sure about is how Marlin will resume at the right spot, but I’m assuming the gcode will tell the printhead where to go.

Perhaps others with more gcode experience can chime in.

Multi-Color 3D Print in CURA 3 on Creality Ender 3 - YouTube This is Chep web site with I forget his name’s tutorial with Cura and ender s. He shows the G code that Cura writes. I am just getting it going now. We’ll see what happens. Maybe I could get to like Cura.