I think maybe my control board is dying

Been an interesting few days. I mentioned in another post that my printer has started doing a weirdness: every 2nd print, or nearly every 2nd one, instead of actually printing, it just sits at the home position and spits out filament as fast as it can, so fast the extruder chatters. If I power cycle the printer, or cause the controller to reset by unplugging the USB cable then plugging it back, the next print will virtually always work. Obviously though, it does mean something is off, but what?

Today I got to tracking it down. There were several candidates: [LIST=1]

  • the printer's controller (some of you may recall me mentioning how I accidentally let some of the magic smoke out a couple of months ago);
  • the Surface Pro I've been using to control the printing;
  • the installation of Cura (maybe something got corrupted?). [/LIST] To address item 2, I did a fresh install of Cura on another computer and tried test prints. Again, every couple of prints, or so, it would just spit out filament. Resetting would fix it, for a while.

    However, with the new computer, a new problem occurred: the printing would pause, for no known reason, for 3 or 4 seconds, then pick up again.

    In any case, it was clear that the Surface Pro is not the source of the problems. And, since it was a fresh install of Cura, with fresh profiles from CHEP, it wasn’t Cura either.

    Pehaps it printing over USB that’s the problem. Nope: reverting back to micro SD card has the same problem.

    So, I think that pretty much nails it: it’s the control board.

    I’m also wondering if this issue is responsible for some of the ugly prints I’ve been getting yesterday & today:


    The first 2 photos are the edge that was closest to the front of the printer. The 3rd photo is of the item opened up (it’s a wiring bracket for network cabling). Notice, in the 3rd photo, all the zits/bumps/blobs. I tried playing with the retraction. Turning it completely off was the best (the 3rd photo).

    Bottom line: I think I’m going to have to get a new control board. Obviously I want a 32-bit board, but which one. I know DrVAX likes the TH3D EZ Lite, and it isa robust board; the only 1 I know of that doesn’t have heat sinks on the TMC2208 drivers, because it doesn’t need them, the board is desgned that well.

    OTOH, as far as I can determine, it doesn’t support multiple extruders, something I would like to keep as an option for the future.

    Do I go for something like a Duet, which costs more, but does support multiple extruders?

    I see on Amazon that BTT 1.3 & 1.4 boards do support multiple extruders, but are they good?

    I’m looking for suggestions…

  • Looking at some of the replacement control board options, I’m leaning more & more toward the TH3D EZ Board Lite, mostly because it’s a direct replacement for Creality control boards, so the wiring & firmware configuration are minimal. What do you think?

    Maybe its the firmaware too. HAve you tried to replace the board with Duet?

    Duet firmware? Honestly, I didn’t know they have firmware. I’m currently running TH3D FW. Or are you talking about replacing the controller with a Duet? I haven’t, no. I don’t have any replacement boards yet. That’s why I’m asking for suggestions about which one I should get.

    I’m a little confused. What is the relationship between [U]https://duet3d.dozuki.com/[/U] and [U]Duet 3D? I’ve been looking at duet3d.com.

    On https://duet3d.dozuki.com/Wiki/Going…rmware_on_Duet the list of specs you need to know about your printer is pretty wild. I’m not sure where I would locate all that info for an Ender 5.

    Related to that, why would the firmware in my printer suddenly start messing up?

    Well, the Duzuki.com is the learning library of Duet3d mainborad ( https://www.duet3d.com/ ). Ender5 is CoreXY architecture that is pretty piece of cake for Duet to controll. check this https://duet3d.dozuki.com/Wiki/Confi…eCoreXYPrinter

    I think the Ender 5 is a Cartesian XY printer.

    Is Core XY, not Cartesian

    Cosmic rays. That’s your culprit. :eek: Seriously, have you considered re-installing the TH3D firmware? Just a thought.


    Edit: Could it be the STL? I have a temperature tower from Thingverse that slices great but I can’t print it successfully for some reason. I believe the STL used to make the base is corrupt.

    OK, but this site begs to differ: https://top3dshop.com/blog/creality-…printer-review

    No, I haven’t thought about re-flashing TH3D. Interesting idea. Nothing to lose I guess.

    I suspect it’s not the STL. I have had problems the past few days with other prints as well. However, I will print something else to check, but maybe try the re-flash first, cause the issue with not starting prints properly is still there.

    Oh! Yes you’re right! It’s cartesian. From a quick view, i missee it as a core xy. No problem with the Duet board at all

    LOL. No problem. I also thought it might not be Core XY because I suspect it’s a fancier system that makers of low end printers can’t afford to implement.

    Did you try to print via SD card. That would sort out windows, which I count a dangerous since it does its own thing and even reboots when writing CDs with its own desktop software.

    The BTT SKR boards are fantastic. I have the Pro version, which supports three extruders. The normal versions support only 2. I won´t go the Duet way. It is expensive and you basically get the same with the SKR boards. You can get a SKR board for around 15 euro in china or 30 euro in Europe.

    Also when installing RepRap you have only one binary for your board and configure all features using text files or the web interface. Firmware install is easy, too. Just copy the file to the included SD card, insert it, power it up and done.

    Unless you get the SKR Pro, the RepRap is the way to go.

    My GeitPrinter is a CoreYX :smiley:

    From my original post:

    Pehaps it printing over USB that’s the problem. Nope: reverting back to micro SD card has the same problem.

    I watched a couple of videos on YT about setting up SKR 1.4, one of them from Chris’ Basement. He recommends getting the pkg with the board and stepper drivers together, because some of the drivers use different circuit boards and have to be configured differently. Also, he talked about actually snipping off 1 of the pins on each stepper driver board. He also made a LOT of configuration changes to configuration.h and configuration.adv.h. My issue is I don’t know what all these changes really do, and Chris talks really quickly. The result is I’m not sure what settings would be correct for my printer. 'Course, maybe somebody has already created a firmware file for Ender 5’s (given its popularity, there must be plenty of people who’ve upgraded to SKE). All in all, it seems pretty kludgy, but I guess that’s the state of the industry today.

    With stepper drivers, an SKR 1.4 Turbo is around $80 for me.

    I like the idea of being able to upgrade just by inserting the SD card.

    I’m really not familiar with RepRap. I take it it’s a different ‘brand’ of firmware?

    OK @Geit, at least you’ve confirmed that RepRapFirmware is compatible with SKR boards. I say that because the RepRapFirmware site shows nothing but Duet boards when you click on Compatible Hardware.

    I presume that price is without the stepper drivers?

    And I take it that, since it’s based on Marlin (just tuned to only work on 32-bit boards) that RepRapFirmware will run just fine on the SKR 1.4 Turbo?

    Hey folks, guess what: I found part of the problem with those U-G-L-Y prints in the original post in this thread: the Print Speed.

    Being the ever-vigilant man that I am ??, I totally failed to notice that those ugly prints were done @ 80mm/sec. I have never had success printing PETG at that speed. Usually I use 50 or 60 I wouldn’t be at all surprised to find that the extra weight (i.e. mass) of the stepper motor on the hotend mounting plate is somewhat limiting the maximum viable speed at which I can print, but that’s a trade-off I’m prepared to make.

    To test the hypothesis, I dropped the speed to 40mm/sec. Here’s the result:

    [ATTACH=JSON]{“alt”:“Click image for larger version Name: _MG_3438.jpg Views: 0 Size: 728.8 KB ID: 2783”,“data-align”:“none”,“data-attachmentid”:“2783”,“data-size”:“medium”}[/ATTACH][ATTACH=JSON]{“alt”:“Click image for larger version Name: _MG_3437.jpg Views: 0 Size: 756.2 KB ID: 2784”,“data-align”:“none”,“data-attachmentid”:“2784”,“data-size”:“custom”,“height”:“270”,“width”:“329”}[/ATTACH][ATTACH=JSON]{“alt”:“Click image for larger version Name: _MG_3439.jpg Views: 0 Size: 1,010.2 KB ID: 2785”,“data-align”:“none”,“data-attachmentid”:“2785”,“data-size”:“medium”}[/ATTACH]

    No, they’re not perfect, but just compare them to the results I was getting: https://forum.drvax.com/forum/3d-pri…dying#post2718. I also dropped the hotend temp from 240C to 235C. I’m not sure if that’s helped or hurt; I’ll have to experiment more. Still, these results are worlds apart from before.

    And, I believe the issue of the printer just sitting at home position, spitting out melted filament, is still present. If I confirm that, then a new control board seems more and more like a no-brainer. And maybe an OmniaDrop extruder/hotend.

    I’ve done a couple more prints, this time of some lens cap holders to mount on the strap of my Canon T2i/550D. Here’s a couple of photos of the one for the 67mm cap (I’ve decided to color code the holders so I can more quickly identify which one to use at any particular time, so this one is yellow):


    Again, it’s not perfect. In the closeup you can see that the lines of filament that are supposed to form 'threads" for the lens cap to grip are not fully formed, showing some stringing/delamination (not sure which). There are also some very, very fine hairs on the print, but nothing to worry about. The holder will do its job just fine, and I don’t think it looks bad.

    When my orange PETG arrives I will print up a new one for my 87mm lens cap.

    I just looked at this subject and saw you are getting improvements. If you do need a new control board, I would recommend anything other than a Creality replacement. I have 5 TH3D ezboards and have been very pleased with their performance, ease of installation and the software. They do not support dual extruders so that would be a problem for you if you need that. There are a lot of you-tube videos on the Big Tree boards and they look good also, lots of choices Kersey Fabrications and Tripods Garage along with Chris’s Basement have good information.