Monoprice ultimate 2 & CURA 4.8.0 fan speed change no effect?


Just moved out first time from PLA to PETG and with my understanding the fan speed should be rather slow. Did set in on CURA 4.8.0 to 10% but based on the noise it’s still running 100%. The quality of the prints still is somewhat OK but obviously makes me wonder why fan speed did not change. Is printer default G-code somehow overriding it or any suggestions what could be wrong? Or is the fan as noisy with 10% than with 100%…

I have in CURA printer startup G-code as follows:

;(**** start.gcode for Ultimate2 (150S)****)
M140 S{material_bed_temperature}
G1 Z140 F300
G28 Z
M104 S{material_print_temperature}
G1 Z15 F100
M109 S{material_print_temperature}
M190 S{material_bed_temperature}
G92 E0
G1 X140 Y7 Z0.27 F4000
G1 X40 Y7 Z0.27 E23 F1000
G92 E0

thanks for help!

Most printers only have on or off as they are switched using a mosfet on the board.

The only way to make them spin slower would be to turn them of for a fraction of a second, but that would be bad for the fans. Fan used in 3d printers are usually just two wire fans, while in a PC you have a third wire for controlling the speed. With two wires speed control would be only possible by constantly turning it on/off.

Non of my printers dues other than 0 or 100%. Always wondered why people claim that 75% gives them better prints, when it usually is just 100% still.

Fan control commands are also not within the start code. They are usually located at layer changes, so before layer 0 and before layer 1, depending what your first layer settings are. In end gcode there is a “just in case” fan off command, AFAIR.

Try sending “M106 S200” (S255 for 100% speed) to the printer and then send “M106 S100” and see if you hear a change. (M107 turns off fans) Although I do not have the Monoprice U2, but both of my Monoprice printers (different models) can change fan speed. As noted above, also check the Cura-generated gcode. You should see an M106 command after Layer 1 or 2.

Sorry, had no time to response earlier. Havent gone to G-code yet but just tried if I can turn cooler off from CURA settings and apparently it has no control even that on-off. Not very pleased that such controls dont work (what else settings will not work?) throughout CURA, thus can be somehow also user issue…

Yep, seems that CURA will send M107 to ask cooler off, but seems that it’s ignored by printer. Tested with with M106 S1 by editing gcode but again same thing, not even slight difference in cooler noise. Then tried M106 S0, no help either. Giving up for the moment as PETG seems to be coming off quite well with the cooler on. Except the stringing which I’m now trying to fine tune with temperature first. Would have just tested if cooling will somehow affect.

testing testing… still fun.

I would try connecting my computer directly to the printer via USB & use Pronterface to send commands directly to the printer. This will let you know for sure if the printer’s firmware understands the commands.

That reminds me I never downloaded pronerface yet for this computer.