Warning: Updating to Cura 4.8 may result in failed prints!

I mentioned this at other locations, but Cura is converting the printer settings wrong and this may be a problem for you, too.

When updating to 4.8.0 the fan index of the part cooling fan gets altered to “1”. It got increased by one.

This results in disabled part cooling for any future sliced print.

To fix this open Cura settings, printer section, select your printer and use the settings button in the same row.

A new window opens with two pages. “Printer” and “Extruder #1” (more if you have more extruders). Enter the first extruder page and check the part cooling fan index. It is the last option in the nozzle settings on the left, below the nozzle offset settings.

For printers with only only one extruder this index value should be “0” as counting starts with 0.

If there is a “1” a non existing fan will be activated during prints and your prints will melt away like chocolate in the sun.

If you have more than one extruder you should check the rest, too. The second extruder should be “1” and the third “2” and so on unless you wired them differently.

I strongly recommend everyone to check this before slicing any new model, or you will have the most broken results you ever saw on your printer. :smiley:

At least one other user had the same issue and you don´t want a ten hour print to result in a pile of muddled plastic.

Thank you: a really good warning. One caveat. I just checked my 4.8 Cura and it already has the extruder fan set to 0. I suspect this might be a setting that was picked up from my Cura 4.7 installation.

It is not 100% clean when and why this happens. It is just the thing that I am not the only one, who has this issue.

I helped a guy in IRC having part cooling fan issues, which was exactly the same problem I had. It worked before and later it failed.

Definitely something to keep an eye on.

Yeah, people will think it is an hardware defect of the main board or the fan, which it clearly isn´t when you can turn on and off the fan using OctoPrint or other software.

Ghostkeeper points a finger at the user. Perhaps it is an artifact of skipping 4.5 (when it was “fixed”)!?

If this is not the issue, a bug report might be helpful.

4.8 is working like a champ for me, fwiw.


I used all versions with in days when they came out. With Appimages it is just a download, making it executable and run it. No deinstal/install or update process involved.

It worked perfect with 4.7.x. I keep all my gcodes and only the most recent had a P1 in the M106 command.

Weird. Maybe it was 4.7.1. Please submit a bug report!


Aha! M106. Could that be why I haven’t had issues: the version of Marlin on my printer doesn’t have M106 enabled?

Ugh. Cura problems again. What an s-show. The whole of 4.7 was bad. I’m still on 4.6.2, but I only really use it if I feel I need tree supports now. I’ve been using Superslicer these days, which is a better fork of Prusaslicer. I think people should seriously consider it, and if you’re already using Prusaslicer, it’s almost exactly the same but with some more refinements. You get a lot more options to refine individual filament profiles too. You can’t do custom gcode for filaments in Cura for example, which is pretty limiting.

Can SS print directly over USB, bypassing the SD card & not using OctoPrint?

Hm, not sure but I think that functionality was removed from Slic3r and Prusaslicer some time in 2019, so Superslicer inherited that. I think they said it was unstable for whatever reason, not sure.

But do you print over USB? Personally I don’t like that idea because it relies on the computer being connected and also completely stable. You wouldn’t want a windows 10 update to ruin a multi-day print for example. I would say that Octoprint would be more reliable for this because it’s running on a really simple linux install.

While I wouldn’t say I run the typical setup, I run Klipper on the pi and and front-end called fluidd. It’s a lot more lightweight than Octoprint, and it’s also running in virtual sd card mode, where the machine thinks it’s an sd card, but the gcode is stored on the pi. It’s essentially as fast as the USB connection between the pi and the printer allows. But I think a more typical setup with a 32-bit board and Octoprint should have no problems.

I print primarily over USB from a Win10 'puter. I have updates set to minimum, and restarts set to manual.

At some point I will probably move to a Pi, but I’m not ready at this point to spend the money on that. What I could have spent on a Pi I put toward a BL Touch & SKR 1.4 Turbo.

I use a PI 4 b with octoprint on it and have printed over 200 different prints (some over 50 hours) on my printer with it and have had 0 problems (well 0 problems related to the PI anyway) printing with it. It has 8 gig of memory and a 32 gig class 10 microSD card on it so is somewhat over powered if you ask most people but i have many plugin’s and record time lapses with the Pi camera so wanted it that way.

Yeah, using OctoPrint since day one here. Never did a single SD card or direct USB print from a PC on any of my printers.

I even turned SD card print off in Marlin during the recent firmware update, because the menu items where always in the way and did nothing usefull.

You don´t need a Pi4. Just get a seconds hand pi2 or 3. Those are fine. You get them for less than 20 euro sometimes.

The only time you see them slowing down is when uploading a file. This may take a second or two longer.
I have a Pi1 on my AnetA8, but I cannot recommend that. It is slow. Uploading or deleting a file may take 45 seconds and booting a few minutes. The log in is slow, too. But once it prints everything is fine. I just keep it, because it is inside the heating chamber and the faster versions would ether burn out or clock down. The Pi1 manages for 2 years now and the only thing I can see is the plastic melting on the display and camera ports cable connector.

The Pi4 is to expensive for a printer. There is nothing that pays back the additional costs. Use the Pi4 as a desktop system or a media centre, but not for a printer.

Its cheap enough so i don’t mind. I prefer my hardware to be over powered. I’m a computer tech and have learned the hard way many, many times that it’s better to have hardware that is over powered then under powered and for the cheap price for the PI’s it’s fine by me ?

I’m with you on the over-powered. I learned that lesson over 50 years ago. Besides, if things change and a better way to print comes around, say manufacturers including a Pi, or equivalent, with the printer, the Pi you were using for the printer could be viable for some other use more readily than a lower-powered one.

Truer words were never spoken ?

Fun part is that I am part of a group working on an alternative operations system for old PPC macs. With our operation systems the old G4 systems run circles around MacOS on the same system. Modern operation systems are so blown, that they waste so much CPU power on their own.

The common phrase “My computer to slow, I need a new one!” is all around. I am using a computer build in 2001 for most of my stuff with two displays connected.

So I really know what slow means. But I also know first hand why it is slow. :smiley:

You want to know slow??? I started out with a Timex Sinclair comp,well more like a calculator really. My first real computer was a radio shack TRS-80 model 1 with 4k memory, upper case only, monochrome monitor, and a tape drive for storage. Talk about slow. ? Have had a computer of one kind or another ever sense. Built most of them. Have been a computer tech for most of my life (about 45 years).Still am although i’m close to retirement. 64 years old here.