Marlin 2.0 Slide Deck and Configuration Files for Ender 3 v2 and ANET ET4/5

Folks, I recently completed the most complex video I have produced for the DrVax Channel. The material is tricky to get right, the 3d printer calibration steps are complex to do consistently, the storytelling is complicated to make clear and I wish I had the time to do it all over again because it is still too long and could be improved. In the past when I have cut the material into multiple videos people watched part two so I left this video as a massive 40-minute video. Feel free to watch it in multiple seatings.

[video=youtube_share;qPDBNBgdW6o]Marlin 2.0 Build and Install | ANET ET4/5 | Ender 3 V2 - YouTube

Here is an outline with approximate timestamps of everything you can find in the video:

00:00 Introduction
00:38 Ender 3 and Anet ET4/5 Limitations
02:02 Marlin Reference Material
03:15 Marlin 2.0
05:33 What is a Bootloader?
09:33 Marlin Source Code
10:05 Pre-Built Marlin 2.0 Releases
11:12 Tools Used to Configure Marlin 2.0
13:25 Steps in Building Marlin 2.0
14:18 Hards on Marlin Build and Install
28:33 Installing Bootloader on ANET E4/5
33:25 Calibrating PID (hot end/bed)
35:12 Calibrating ABL

Attached to this post you will find the updated slide deck used in the video and the configuration files I used for the ANET ET5 build I demonstrated in the video. In addition, you may find the following links helpful:

YouTube Channel - HL ModTech (…_8MpyVCVfdwYAw)

YouTube Channel - Teaching Tech (…ikmtoLqtpc59Bw)

David Teran - Marlin 2.0 Port
GitHub - davidtgbe/Marlin: Marlin for Anet ET4/5 series 3D printers

Facebook Groups I Referenced in the Video specifically for ANET ET4/5 Users

Facebook - Anet 3D Printer Spain
Facebook - Anet Mods & Upgrades
Facebook - Anet Official 3D Printer Support Group

Let’s keep learning together. Irv

***** The configuration files have extensions of “txt” since the forum does not permit uploading files with .h extensions. Rename them to .h and move them into your Marlin directory to use. All of my edits in the files are flagged with a DRVAX comment *****

Marlin 2-0 Build ET4-5 Ender 3 V2.pdf




image_1039.pdf (644 KB)

image_1040.txt (8.08 KB)

image_1041.txt (89.8 KB)

image_1042.txt (146 KB)

A massive effort Irv. Congrats, & I bet you’re glad it’s over :smiley:

Excellent presentation as always. I have recommended it to a friend who is trying to set up a new SKR board for the first time. He was able to get it done in a day. It took me several days of trial and error back when I first tried is many months ago!

Thanks for all your efforts.

Just exploring the Anet,
So I watched the whole thing. From a rank novice perspective; I found it interesting, yes complex, but well enough explained that I have confidence I could replicate your instructions. Thanks for your effort it’s much appreciated and helpful.

Love the upgrade vid, but have come across a problem (might be on my side, dunno)
Trying to load the bootloader with ST-Link and OpenBLT_ET4
Connect to board - no problem
Read current board FW - no problem
Target - Program - openblt_et4.bin - no problem
Start - cannot connect to target

Tells me to connect using three different methods and each fail tells me to use the previous failed method

Have followed the vid to the letter

Have attached the ST-Link log in case anyone knows what’s going on

12:09:23 : ST-LINK SN : Old ST-LINK firmware/ST-LINK already used
12:09:23 : V2J17S4
12:09:23 : Connected via SWD.
12:09:23 : Connection mode : Connect Under Reset.
12:09:23 : Can not connect to the target!
If you’re trying to connect to an STM32W1xx device, please select Normal or HotPlug mode from Target->Settings menu.
12:09:30 : Unexpected error
12:09:42 : ST-LINK SN : Old ST-LINK firmware/ST-LINK already used
12:09:42 : V2J17S4
12:09:42 : Connected via SWD.
12:09:42 : Connection mode : Connect Under Reset.
12:09:42 : Debug in Low Power mode enabled.
12:09:42 : Can not connect to the target!
If you’re trying to connect to an STM32W1xx device, please select Normal or HotPlug mode from Target->Settings menu.
12:09:45 : Unexpected error
12:09:52 : ST-LINK SN : Old ST-LINK firmware/ST-LINK already used
12:09:52 : V2J17S4
12:09:52 : Connected via SWD.
12:09:52 : Connection mode : HotPlug.
12:09:52 : Debug in Low Power mode enabled.
12:09:52 : Can not connect to the target!
Please select “Connect Under Reset” mode from Target->Settings menu and try again.
12:09:57 : Unexpected error
12:10:05 : Can not connect to target!
Please select “Connect Under Reset” mode from Target->Settings menu and try again.
If you’re trying to connect to a low frequency application , please select a lower SWD Frequency mode from Target->Settings menu.
12:10:12 : Internal command error
12:10:28 : Can not connect to target!
If you’re trying to connect to an STM32W1xx device, please select Normal or HotPlug mode from Target->Settings menu.
If you’re trying to connect to a Discovery board, please select SWD mode from Target->Settings menu.
12:10:30 : Unknown target connected

============== FIXED=============

ST-Link was using an old firmware as noted on the first line of the log
Tried for what seemed ages to get new FW but no joy
Kept asking for DFU status … no idea what that is

Switched everything off, rebooted PC and tried again
Turns out DFU (to me at least) means don’t connect to anything
Having powered down my ET5 the Link was not “ON” and FW updated

Now to continue with the Marlin Install

============= Addition ============

Woo Hoo …
5.5hrs from opening case.
Upgraded from ET5X to PRO (silent Drivers)
Upgrade Firmware to Marlin 2.0.xx
Configure Printer
Calibrate PID’s
Level Bed

This has had to have been my fastest build yet, even with the mess with the ST-Link

[SIZE=16px]Could not have done it without this great Video you have created[/SIZE]

Now to do my baby part and dial in my steppers

I BOW to your workmanship and patience

OK looks like everything has gone pear shaped

Got Printer set up as per the Vid and everything seemed alright

Bed is level and dialled in

Go to print Calibration Cube to start tuning in steppers
And it starts printing 3mm off the bed

I have gone back through the bed levelling section of the Vid and no matter what I do it wont print any lower

Am I missing something

Have you dialed in the Z Offset?

Yep, followed the vid to a T.
Gave me a Z offset of -0.36 in the centre of the bed

I have actually managed to get a Calib Cube printed

I simply ZERO’d the Probe Offset AND the Z offset

I set the home all to correct Z height via paper, set the sensor screw in place and re homed

And I can’t believe how quiet my printer is now that I upgraded to a 5PRO
If it wasn’t for the PSU Fan I wouldn’t know the printer was on

Did you store the settings in EEPROM after setting the Z Offset? I’ve had weird results sometimes after changing settings & not storing theml. I checked the Z Offset by power cycling the printer & then checking what it said the Z Offset is, to make sure it’s the same as it was before.

Yes, the TMC2208 drivers are very much quieter.

First off, thank you for all your efforts.

I managed to complete every step succsessfully for my Anet ET5, however the Z-Endstop does not work.
I’ve manually adjusted the sensor and leveled the bed, however the Z-Axis just runs into the bed without stopping (i then turn the power off in order to stop it and keep it from taking any damage)
I deactivated the Soft(ware) Endstop and made sure the probe offset etc. is correct, yet I could not get it to work properly.

I’m a little unclear on the details. When you say “probe offset”, are you referring to an ABL like a BL Touch or EZABL? Since I’m not familiar with the ET5, I’m not sure what a Soft Endstop is. It really does seem like there is a connectivity issue for the Z Endstop, as though a wire is not connected properly, or a switch is broken. But, like I said, I’m not familiar with your printer, so I’m not sure what it has.

The ABL is a capacitve sensor (sp)
I usually send the Z axis up about 100 - 150mm then Home Z. As it moves down pass a finger close to the sensor to interrupt it

I’m also having issues with the probe offsets
Using the Probe Offset Wizard, it states my probe is at 4.0mm and then to adjust +/- the offset.
I’m assuming this is the height of the Probe from the bed as the nozzle is touching the bed
I tweak down using the paper method, and it gives me an offset of 0.03 I click OK then Done

Then I home all, and it parks with nozzle touching bed, but screen saying -3.90
So when I start to print, it prints in mid air

And now on top of all this I am getting a knock on my Y axis at random points
My belt is as tight as I can get it without mechanical aid
I might have to check the concentric nuts see if they have slipped

When I set up my BL Touch I had to set it up, then Store Settings. Then, to be sure, I power cycled the printer and checked what it said for Z Offset. If I didn’t do the Store Settings & reboot it didn’t keep the value.

I finished flashing the new Marlin from the files DrVax uploaded.
It’s an odd problem which I do not understand:

I can see the Endstop Status in MatterControl with the M119 Command, which outputs, that Z is being triggered, so it’s not a connection problem.
It might be a problem in Marlin, I don’t know and I do not understand and I am really frustrated because I am working on it for about 8 hours by now.

I tried editing the Marlin Firmware to use the inductive Z-Endstop / Probe it’s using, without success.
The Z Axis even goes into negative digits, I did not want to try out how far it would go because I do not want to damage my ET5, the lowest value I got before turning off was -8.

Any suggestions?

Printer: Anet ET5 (ET4 Board)

Just had a look at the Marlin reference docs to check the M119 command. It says that a state of TRIGGERED for a BL Touch is an error, because it sends a pulse for too short a time. I wonder if this could be true for a capacitive/inductive sensor?

If you raise the head until the light goes off and issue M119, I assume it says “open”. Then, if you put your finder under the sensor & reissue the M119 it says “TRIGGERED”; is that correct?

If you raise the head until the light goes off and issue M119, I assume it says “open”. Then, if you put your finder under the sensor & reissue the M119 it says “TRIGGERED”; is that correct?

Jup, that’s correct.
When I tried to home Z and then try to trigger the Probe / Z-Endstop with my hand the LED of the Probe would light up (showing that it works), yet it still keeps going down.

EDIT: FYI: I do not use an Antclabs BLTouch, I use stock hardware.

Wait a sec. I was asking if M119 says TRIGGERED. I get that the probe’s light goes on, and that’s great, but it doesn’t mean the control board has recognized the triggering. It does say that the probe is working, in that it recognizes when your hand is close to the probe. It just doesn’t mean the signal is being picked up, so that the control board can stop the Z Axis stepper motor. It’s a small, but I think significant, distinction.

M119 says TRIGGERED.

Excellent. Well, sort of. Wouldn’t it be nice if it didn’t say TRIGGERED & you could look to fix the problem by simply fixing the connection? :slight_smile: Too bad it isn’t that easy.

Well, at least the hardware is OK.
Now i “just” need to figure out what is causing this problem.
Thanks Ender5r!

edit: typos & To-Do