MatterControl 2.0 BAUD Setting?

I just installed MaterControl 2.0 and am connecting it via USB to an ANET A8 running Marlin When I try to connect from MaterControl the printer reboots and MaterControl fails to connect. I thought the BAUD rate may need to be set inMaterControl, but I cannot find any way to do so. I liked at instructions on the MaterHackers site, but they are showing an older version. I looked for an older version, but all links lead to 2.0. Does anyone know how to set the BAUD rate in MaterControl 2.0? Or where to obtain an older version?


I do not have your printer, but 115k works on my printers. Also, use a quality USB cable.


Thank you for the response. I already tried every reasonable BAUD rate in the COM port. I think I need to change the BAUD rate setting in MatterControl. But I cannot find any way to do so. There are no baud, edit or settings I can find for the port in MaterControl

You set the baud rate on the “printer tab”. This tab is not displayed by default so click on the three-dot menu on the top right and select the printer option. In addition, I agree with the earlier comment that cables are often an issue. Many USB cables are only configured for charging and not for communicating data.

Here is a picture:

[ATTACH=JSON]{“data-align”:“none”,“data-size”:“custom”,“height”:“256”,“title”:“Screen Shot 2020-11-05 at 11.53.30 AM.png”,“width”:“500”,“data-attachmentid”:5730}[/ATTACH]

Usually printers use 500000 which is supid

Thank you Irv. I see it now, and will try it within a few hours and report back. I have confidence in the cable since I have used it before, but will switch if the BAUD change doesn’t resolve the issue.

BAUD rate set in configuration.h if the Marlin source is 115200. I need to match MatterControl to that.

And on a side note Irv, thank you for your work and time in producing the Chanel. I am nearing retirement, and your Chanel is an excellent inspiration. Only problem now is to narrow the number of activities to something reasonable. Thank You Irv!!!

Great news! I changed the BAUD and it connected.

But I tried to calibrate the bed and it keeps driving the Z axis down. I need to debug and fix the Z axis limit switch. In working on it, I don’t yet see how to step an axis from MatterControl, but I’ll keep looking when I get back to it.

Hey Irv, a session on using MatterControl 2.0 would be good. :). Everything I can find online seems to be an older version, which has changed significantly.

Is the Z axis actually driving into the bed?

Yes. But I noticed the same before updating to Marlin, when homing from the keypad. I need to check the switch and connections with an ohmmeter, which I’ll do within the next few hours (work has priority, this is limited to breaks).

For sure. A continuity check would be a good start.

Doing it now. Without spending any time on it, do you know how to manually step the motors from MatterControl?

Sorry, no. I only looked at MatterControl once, very briefly. If MC has a command window where you can issue gcode commands directly to the printer, you should be able to do it manually.

Great news. I found a faulty solder joint at the Z limit switch. Fixed it and it works fine now.

Also, I found a Terminal tab next to the Printer tab. It shows all G commands being sent to the printer, and allows manual entry. I was able to send G commands to position the axes and to home all axes.

thank you much for the assistance in a time of need. ?

I love it when a plan comes together. :slight_smile:

I’ll tell you something I now do before every print. I preheat the hotend to between 230C & 240C. While it’s heating I issue:

G1 X100 Y100 Z100

Once the hotend is up to temp, and after feeding the filament into the hotend I issue:

G1 E100 F150

I find that really helps ensure the filament is feeding cleanly & evenly.

I’m getting ready to level the bed and try a print. After leveling the bed, I’ll manually try

M140 S50
G1 X100 Y100 Z100
M104 S235
G1 E100 F150

Then start the print.

All seems to be working great, except that I’m getting the first 4 layers at less than paper thickness, barely enough to see. This is causing very thin parts.

in the Slicer Settings tab, I have Layer Thickness setti 0.2, which seems to kick in after the first 4 layers. I have First Layer set to 0.3, but it is not doing anything.

is there a setting I need to fix?

very thin 1st layers are normally an indication that the nozzle is too close to the print bed. As a test, you can change the Z Offset value to make the printer keep the nozzle a little higher,

I can’t remember if you have a BL Touch. If you do, I would think it would mean you need to adjust the height of the BL Touch sensor so it keeps the nozzle a little higher.

Wow! What a difference 2mm makes. Thank you!

Nope, no BL sensor here. Maybe a future upgrade. I’m just now making this thing a non fire starter.

BTW, I found a Control tab on the right side of MaterControl. It has a Home key, and a step key for each axis with step-size selections. Easier that using the Terminal to enter G1 commands. This is a cool program, once you learn your way around the GUI. The best part is that it is a completely self-contained and well integrated tool, including simple 3D design, slicer, and an interface to the printer which allows real-time control and automatic one-button printing.

I would be careful with the step-size items. If they’re what I think they are, they refer to the amount of distance the lead screws move the corresponding axis. So, for example, if you were to set the Z axis a tiny bit higher than the lead screw actually moves the axis, you would find that the gap between the nozzle and the model would gradually get larger & larger as the print gets taller, eventually leading to the nozzle extruding filament into thin air.

The 3 axes need to be calibrated carefully & accurately. This is part of dialing a printer in.

I had this issue with my printer right out of the box. The firmware came with the Z axis set to 400 steps/mm. In fact the Z lead screw is 800 steps/mm. The result is that my first 3D Benchy came out squished, like a TV that has its aspect ratio set incorrectly.