Ender 3 v2 BLtouch Bed Levelling issue

Hello, I read through the posts about installing the BL touch prior to actually doing it, so gained some good insights into potential watch out situations including making sure connections are solid, so I fitted a JST connector to the cables to get rid of that issue and I also watched Dr Vax’s video many, many times over to make sure I was doing it right and didn’t miss anything, once I had installed the BLtouch, all seemed to be going well, at least, for the first print. As far as I can tell, the Aux Level Settings and/or Z-Offset settings and /or Bed level settings don’t seem to be being saved, even though I save them at each stage under ‘control’ and ‘save settings’, because when I come to do another print, the nozzle is often too high and I just get a spiders web of a mess. Even though there is a G29 code telling it to re-do the bed level process before hand, I am finding that I have to go through the whole process of Aux Leveling, z-offset and Bed level again in between each print, sometimes it’s taking me 3 or 4 attempts before another print works, and sometimes the fix seems to be, switching it off and on again, is this normal? What else can I be doing wrong? Am I missing a step in saving the information somewhere other than under the control panel and save settings? Do I need to add any code other than the G29 in Cura to get the printer to remember it’s settings? Thanks for your patience in reading this novel!

Have you connected using Pronterface or something similar and issued an M500?

Thank you for your response, since posting that earlier today, I decided not to tell it to auto home after each print and it seems to have sorted itself out, whether it continues after I turn it off and on again, I will see.

Sorry, I also have no idea what you mean, my apologies, I’m not that technically minded but don’t mind trying, even if the learning curve is steep. So I looked it up. The printer isn’t connected to anything, and I haven’t added any M500 code into the g-code, if that’s what you mean? In fact, this is the Start g-code from Cura:

; Ender 3 Custom Start G-code

G92 E0 ; Reset Extruder

G28 ; Home all axes

G29 ; ABL - BLTouch

G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed

G1 X0.1 Y20 Z0.3 F5000.0 ; Move to start position

G1 X0.1 Y200.0 Z0.3 F1500.0 E15 ; Draw the first line

G1 X0.4 Y200.0 Z0.3 F5000.0 ; Move to side a little

G1 X0.4 Y20 Z0.3 F1500.0 E30 ; Draw the second line

G92 E0 ; Reset Extruder

G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed

G1 X5 Y20 Z0.3 F5000.0 ; Move over to prevent blob squish

This is the end g-code:

G91 ;Relative positioning

G1 E-2 F2700 ;Retract a bit

G1 E-2 Z0.2 F2400 ;Retract and raise Z

G1 X5 Y5 F3000 ;Wipe out

G1 Z10 ;Raise Z more

G90 ;Absolute positionning

G1 X0 Y{machine_depth} ;Present print

M106 S0 ;Turn-off fan

M104 S0 ;Turn-off hotend

M140 S0 ;Turn-off bed

M84 X Y E ;Disable all steppers but Z

Not to worry; I was brand new to 3D printing at the beginning of June.

Pronterface is a program that let’s you connect a computer to your printer via USB. You can do many things with it, but the 1 we’re interested in at the moment is the terminal pane (it’s on the right side of the Pronterface window. It let’s you send gcode commands to the printer directly. For instance, you tried to save settings but they don’t seem to have stuck. You could type M500 in the little text box at the bottom of the terminal pane and hit Enter, which is the command to tell the printer to save the current configuration settings. An M503 will list out the settings, so you can check what’s in memory.

Turning off the printer will almost certainly lose any settings that haven’t been saved. If you connect up again with Pronterface, you can issue the M503 again see what the settings in memory are now.

I recommend you go to YouTube and look up a few videos on Pronterface. They’ll do a better job than I can here with text.

Okay thank you, I was trying to avoid having to go though the upgrading process and additional cost of getting it connected to a computer and the wifi, but will take a look anyway, so thanks again.

You don’t need to spend anything to connect to a computer. All you need is a USB cable (and, of course, a computer, but I assume you already have 1).

It sounds like your doing the correct steps. You should only have to save your settings once. Did you use this mount? Ender 3 V2 3DTouch/BLTouch Mount by jkostenov - Thingiverse and did you use this firmware? https://smith3d.com/ender-3-v2-bltou…y-smith3d-com/ and are you using V2 of the mount like dr vax suggest and use the spacer at 50% of z as he suggested? I did what he suggested and is working fine for me. The JST connector is a little hard to get crimped but once done correctly it works well. When i crimped my JST connector i watch this guy’s video Creality Ender 3 V2 BLTouch Installation Guide - YouTube he seems to know what he’s doing.

The Aux leveling is just to get your bed leveled. Unless your printer is not trammed (square) or your z axes rod is bent you should not have to level the bed again for a while. Did you have printing problems like this before you installed the BL Touch?

LOL! Oh, then I really do need to do more research, I thought it could only be done using a Rasberry Pi, I’ll get on searching, who needs sleep anyway! Annoyingly, that seems like a basic lesson I missed at the very start!

LOL, yeah, a RasPi is a whole other subject. I don’t even have 1.

Since I posted this problem, it’s been behaving and working like a dream, I don’t want to switch it off!

Do you have a 4.2.2 version of the controller board or 4.2.7?

I hear you but, all joking aside, you’re going to have to shut it off at some point :smiley:

Yea i love my PI got a mount for it recently from one of the board members and love that

I’ve seen you ask that a couple of times now. Is there some critical factor between to 2 you’re looking for?

there are 2 controller boards that came out with the ender 3 v2’s 4.2.2 and 4.2.7 i have one of the first ender 3 v2’s and it has a 4.2.2 controller board the newer ones have the 4.2.7. Have noticed that they use different firmware and sometimes when people change firmware they use the wrong version. They will work if you get the wrong version but you get weird problems that show up.

Ah, that’s what I was getting at. So, the 2 boards require different firmware. That’s interesting, and something to make note of. I have been thinking of upgrading my Ender 5 Pro to the 4.2.7 board. Everything I’ve seen seems to indicate it will work. And, it’s not expensive at all.

Yea i’ve heard that the stepper drivers run cooler on the 4.2.7 board.

I think the 4.2.7 uses the latest: TMC2225. That alone might account for the different firmware.

That would be an excellent time to connect to a computer.

Yes i agree i made the mistake once of downloading the wrong firmware (4.2.7) and my printer worked but would do weird things at time. Almost pulled what hair i have left out trying to figure out what was going on. Would work fine at times but not at other times.