Anet ET4, latest version?

Just received the ET4. It has no Z stop micro switch therefore leaving an empty SZ socket. Has anyone any knowledge of this design change?

I have no knowledge, but I wonder if you have any idea how it detects the Z home position?

Perhaps it doesn’t. I don’t think the A8 has an upper Z detector? Presumably a deliberate alteration as no holes are drilled in the steel bracket to accommodate a switch. Thanks for taking an interest.

Sounds a little dangerous in the sense that the machine could damage itself. OTOH, maybe they’re using moths to detect the Z axis. I noticed on the ET4 web page that Anet is offering a 12 Moth Warranty: [U][/U]. That’s 1 moth per month. Maybe the moths get tired and have to be replacee once a month :smiley: :smiley:

Yea - why didn’t I think of that. The ET4 gets moth-eaten.

See your picking up the Chinese lingo already: “and have to be replacee once a month”. :wink:

Will try Gearbest, the vendor. Thanks Ender5r.

I think there is supposed to be a switch on top of the carriage. There is nothing at the arrow in the picture below?? RMA time!



Nope, no switch Alan, unlike all other models seen yet. Am waiting for a comment from Gearbest.

Just thought: the A8 has only one switch hence also lacks an “upper/end” switch on each of the 3 axes. No problems reported, as far as I know.


GEARBEST. After a dozen or so emails and photos am unable to get a relevant reply to my question re the missing switch.

They seem to have little understanding of English and of the Et4. Eg ‘‘please send us a picture of the missing part.’’!

I get the impression that this is a new model. It has an inbuilt sensor next to the extruder which works well with automatic bed levelling but fails when levelling manually. Wrong software perhaps.

Surely I’m not the only bloke with this model? What about Irv Shapiro? You seem to have some influence. Maybe you speak Mandarin. :smiley:

Out of curiosity, and assuming the ET4 runs Marlin, have you tried using Pronterface of Cura to send a G28 command? If not, you might want to try it. But, I would have my finger on the power switch as it moves to the home position. Any sign of problems, hit that switch super quick.

Another thought: is it possible the switch is hidden. Seems unlikely, since you mentioned the SZ socket is empty.

No it doesn’t run marlin and there is no switch.
But have discovered that this printer is the ET4 PLUS with original Version of software V1.0.0.
Can’t find any upgrade info for Anet ‘‘ET 4 Plus’’ to Version V5.
It’s smacking into the build plate and the power off function doesn’t work…
The supplier Gearbest is unable to help. Can find only software for ET4 and ET4 Pro.
I believe it’s simply involves loading machine from an SD card?

I went to this page: [U][/U]. There, I checked both the “Firmware of ET4 Pro” and “Firmware of ET4+” subfolders. They appear to be the same firmware: ET4X.bin. And, it’s from this July, like right now.

Thanks again Ender. Unlike other files tried this one was accepted.

Unfortunately it has not cured the printer infra red Z sensor which consistently ‘sees’ the bed for certain operations but not others.

Time not wasted however as presumably we can discount the need for updating.

If the company won’t accept a return will no doubt one day find a solution. Meanwhile the Anet A8 has never let me down.

Sorta good to hear it at least accepted the file. And you believe it uses IR to sense the Z axis? That’s interesting. I’m not sure why a company would go that route instead of an good old micro switch. Is there any possibility you can install a micro switch in place of the IR sensor?

I tend to not buy directly from China, except for items less than $50; an amount I won’t be too upset about if it all goes wrong. For one thing, most of the companies insist you pay for return shipping if something’s defective. I’m sure they use that to get out of a lot of warranty replacements.

The IR sensor does work well when automatic bed levelling which suggests it’s not the switch itself.
Have learnt that running into the bed is a common fault that can, Anet say, be rectified with firmware update.
I don’t usually use China for larger items either but many you-toobers seem to use Gearbest.
Have exchanged 19 messages with Gearbest now and they have actually managed to identify the model I bought from them!
Either they don’t understand English or they pretend not to or they’ve all got covid.
Perhaps I should ask Dr Vax who sold me on the idea of buying an ET4.

The ANET XT4 senses the top of the Z-axis, not the bottom. There is a sensor on the carriage that holds the extruder and X-axis that is triggered when the axis reaches the top position. Then the firmware calculates the distance from the top down to the build plate.


If the nozzle is hitting the build plate then tighten up the screws under the build plate to pull the build plate down as far as it will go. Then home the printer. Then heat up the build plate. Then adjust the build plate level manually. I do not recommend using the semi-auto bed leveling on the entry-level ET4 as I have not personally found it reliable.

As I reported in my review the ET4 hardware is quite good but the firmware is poor. But there is hope since a number of third parties are working on a full marlin port for the ET4 which has a 32-bit control board.

Finally, I have been using an ET4 for a couple of months now with ANET firmware and seeing no issues if you manually level the print surface.

It is unfortunate but no one is making a perfect printer low cost. I just reviewed the new Ender 3 V2. This is an excellent printer but the new display and the Creality supplied firmware do not support the M117 command which makes a number of Octoprint plugins ineffective. It also does not support the M600 filament change command. I expect Creality will correct this in the future but it seems many low-cost 3d printers are shipped with firmware that is not fully cooked. The advantage of Creality printers is that it is easier to upgrade to a full version of marlin. The advantage of the ET4 is you get more features for the price and the assembly is much easier than the Ender 3 V2.

Hi Irv. If you look at this photo, [U][/U], you can see that, unlike the photo you posted, there are no holes near the QR Code where the limit switch should be mounted. Is there more than 1 QR Code sticker on the printer cause, if not, it would appear Pedrx’s printer skipped the step where the holes for the switch would be drilled & tapped, and the switch mounted.

Thank you Irv but as Ender indicates there is no upper z switch.
There is however what appears to be an IR sensor next to the extruder which senses the bed and works as described above.
I believe, though it’s not what I ordered and Gearbest, the supplier, appear completely ignorant about, the ET4 + model.
I was born before televisions and land telephones were generally available in the UK so am a bit thick about computers.

I think I would be looking at replacing that IR sensor, or whatever it is, with an actual switch.

Would you mind posting a picture of this IR sensor to include its wiring? I really think you should RMA the printer, but maybe the fix is easy.


Ok, the plot thickens. I stumbled across a Reddit thread which in turns quotes from the ANET Facebook page:

“S-Z” is originally linked to the Z-axis limit switch on the version of ET4 with a filmy leveling sensor. But new ET4, ET4 Pro and other ET series printer using the ABL sensor can independently carry out the task that detects the distance of the nozzle to the build plate. So we canceled the installation of Z limit switch on these printers. So don’t need to be bothered by the empty S-Z connector on your printer. It doesn’t affect normal use."

So, it seems like printer needs the ABL sensor attached and the ABL routine run in order for the machine to know where to home. (Am I missing something?)


P.S. – Also found an ANET ET4 Wiki.