Z axis won't go down

What would cause a z axis stepper motor stop moving down? My MP10 mini lost the home position. Ran autolevel and the carriage ran up while trying to autolevel. The motor will not drop the carriage. This is a new printer and I’ve had nothing but problems with it.

It’s a bad autolevel (induction) sensor. Apparently, this is a not uncommon problem with the MP10s. (Mine has had no issues.) Unplug the sensor and manually level until you get a new one.

If not under warranty, Monoprice.com might have one in stock, but I know GigDigit does. I’ve interacted with the owner (Matt) both via e-mails and Facebook. He’s great guy and buys directly from Malyan (the builder of the MP10 models). (Disclaimer: Just a satisfied customer.)

With the exception of this sensor and the Bowden tube connector attached to the extruder, I think this is a solid machine–at least for me.


[ATTACH=JSON]{“alt”:“Click image for larger version Name: MP10mini-hatchbox.jpg Views: 0 Size: 118.0 KB ID: 6813”,“data-align”:“none”,“data-attachmentid”:“6813”,“data-size”:“thumb”}[/ATTACH]

OK, I unplugged the sensor and tried to level the bed with the carriage against the stop switch. The z works in both directions with the sensor unplugged. But when I tried a test print, the hot end went down it was digging into the blue tape on my build plate and then rose so high the filament wouldn’t come close to sticking, then it went back down, and up again…My leveling screws are bottomed out to level the bed. Any additional clues to help?

OK, you unplugged the ABL sensor. Where did you plug that wire into. I hope it was to a Z Axis limit switch. Unless the printer is using Sensorless Homing, it needs a limit switch so it can figure out where the end of the Z Axis travel is located.

Guys, please chime in. Am I on target here?

Sorry, I am away on business or I would post a video. But, yes @Ender5r is right. Check you z-axis limit switch. It should stop the nozzle from hitting the bed. You may need to adjust its position. Leave the induction sensor unplugged until you get a replacement.


[ATTACH=JSON]{“data-align”:“none”,“data-size”:“small”,“data-attachmentid”:6901}[/ATTACH] [ATTACH=JSON]{“data-align”:“none”,“data-size”:“small”,“data-attachmentid”:6902}[/ATTACH] [ATTACH=JSON]{“data-align”:“none”,“data-size”:“small”,“data-attachmentid”:6905}[/ATTACH]
There is already a z limit switch. The inductive sensor wire is just there, not plugged into anything.

Alan, how does one adjust a switch that is screwed into place.
The pictures show what is going on. Pic 1 is the home position. I leveled the bed from this position. Two and three show how the z carriage is moving UP while trying a test print. You can also see in the first picture where the hotend was driven so deep that it dug into the build plate. I apologize for the questions, but I’m new to 3d printing and this machine is just a piece of garbage in my opinion.

No worries on the questions! I apologize for the slow responses as I am traveling. I won’t have much time for a few days. That said, People run the printer without the auto level (e.g. using a glass bed) so it can be done.

Dumb questions: has the printer been power cycled? What’s the z-offset set at?

What do you mean by power cycled? Z offset is at 0 right now. Everything worked great until the sensor went bad.

Power cycle, a reboot…yes, the printer has been power cycled several times since this issue arose.

@landrus60, my own experience has been that the printers are not garbage, but it does take some learning, experience, & practice to get printers that cost less than $500 to work properly. I have never tried 1, but I’ve read & seen that multi-thousand $ printers take a lot less end user knowledge.

While I, too, am wondering about the Z Offset value, I’m also very curious why the hotend seems to be increasing its height as it moves to the right. It’s almost as if it’s trying to use an auto-level mesh that’s way off. I’m not sure, but I am wondering if unplugging the ABL sensor is not a way to disable the ABL Mesh code in the firmware. What if the firmware is trying to use the ABL Mesh, but the mesh is very incorrect?

What happens when the sensor is plugged in and you trigger an Auto Bed Leveling? As the sensor is moved around the bed to probe, does it move up & down to approximately the same height?

Ender5, when the ABL sensor is plugged in, the carriage move UP while trying to autolevel. I’m guessing it does that because the sensor is bad and the stepper won’t go down. I contacted MP and they are sending a new sensor. But in the mean time my printer is dead in the water since I’m not sure how to address firmware issues.

Monoprice firmware for the MP10 mini is v71 which is what my printer shows.

I am currently running through the steps on this Teaching Tech calibration site: [U]https://teachingtechyt.github.io/calibration.html#intro[/U]. I recommend it.

Yup, v71 is the current firmware.

I don’t understand how the z-axis limit switch isn’t activating. Here is a picture of my machine in the home position. Even though I’m using the autoleveling sensor, I have my bed almost all the way up (something I should fix).


If you gently push in the z-axis limit switch, do you see a red “Z” on the LCD (upper left hand corner)?


[ATTACH=JSON]{“data-align”:“none”,“data-size”:“small”,“data-attachmentid”:6968}[/ATTACH] My limit switch in the home position looks like yours. The red z does come on if I push the switch.

I’m still confused why the z carraige goes up and leaves a string of filament when attempting to print. Not sure how to rectify that particular problem.

My understanding is that oozing is just part of 3D printing. There are things that can be done to reduce it though. For instance, I often manually pull the filament back from the extruder about 10mm while the hotend & bed are heating up. I also recently added some post g-code that pulls the filament back 50mm after a print is finished, so it’s easier to pack up the filament for storage.

Has anyone figured this one out? I’ve gone through three induction sensors and my Z-axis still just keeps going up when auto-leveling until it hits the top cross brace.

@CKMG we need a lot more info: printer make & model, firmware type & version, start and end g-code. Some photos would be helpful.

Did you try disconnecting the induction sensor and manually leveling? Hopefully, @landrus60 can weigh in with what worked on his machine.

Some folks have re-soldered their induction sensor (NFI).

Another person has this recommendation: "You can also try removing the leveling sensor and adjust the trimmer pot back and forth. I’ve used carbon element cleaner on those and it seems to work great. https://caig.com/fader-f-series/ I spray some in a small container and use a small dropper to apply it to the pot. they also sell a version with a needle dropper - https://caig.com/product/deoxit-fader-f100l-l25c/

Then adjust the pot back and forth a bit and set it back to close to where it was."

Yet another person has replaced the OEM sensor with a PINDA probe Here is the new mount on Thingiverse (Amazon link for the probe in description.)

Hope this helps


Hi, Alan, thanks! Yeah, I tried leveling with the sensor disconnected but as soon as I started printing, the head raised too far above the bed to make anything work. Doesn’t seem like other options are worth the effort and cost especially if it doesn’t fix it. Wish there was a way to factor reset everything.

  • Monoprice MP10