BLTOUCH upgrade and Nozzle crashes into bed during Auto Home on Ender 3 Pro Upgrade

Upgrading my Ender 3 Pro to a V2 with V2 screen, 4.2.7 silent board, BLTOUCH 3.1 and Filament Runout Sensor.

After watching numerous You Tube videos and googling.

Installed 4.2.7 board and BLTOUCH Connecting 3 pin and 2 pin to the BLTOUCH connector on board following color code Brown, Red, Yellow, Black and White

Complied Marlin with the following BLTOUCH definitions:


#define BLTOUCH
#define NOZZLE_TO_PROBE_OFFSET { -41.5, -7, 0 }
#define XY_PROBE_SPEED (10060)
// Feedrate (mm/min) for the “accurate” probe of each point

#define BLTOUCH_DELAY 250

After flashing firmware. Power on test shows BLTOUCH red and 2 strokes on pin. When Auto Home is performed the X and Y axis works fine. The BLTOUCH fails to extend the pin and the print head wont stop in the Z axis. Even tried to manually pull the pin and the red light went off. When the pin is pushed up the red light comes on but the head is still traveling down.

Any suggestions,

hmmmmm, really smells like a wiring issue. Did you try an M48 command?

When homing the pin should be down, I’m thinking the Z-stop wires are reversed.

First trouble installing the sensor, then trouble getting the software operating it properly, then it works for a specific amount of time, then the first print fails, then another one, then homing fails and the sensor needs to be replaced.

ABL is just causing trouble and the basic switch simply always wins and fails just after 60 millions of homes or so. :smiley:

Get a flat print surface, do proper bed levelling and you are good for months or even years.

ABL is just a waste of time, money, plastic and only calls for trouble.

The only ABL sensor that works without maintenance is an inductive sensor, but if fails when changing the bed surface e.g. to glass. The poking stick type BLTouch scream for failure in the long run.

The pressure sensitive kind of sensor is an option, too, but I have no clue about the durability in the long run. If the nozzle is heated homing and sensing should be very precise.

@Geit, your prejudice is showing. If it wasn’t ABL you’d be talking about how it’s a learning experience, how you get to know your machine from the ground up, how it’s a good thing in the long run [SIZE=22px]??[/SIZE]

I always agree with @Geit when he says that about bed levelling. Manual levelling is fine for me and much less hassle.

I would download the firmware for the Ender 3 v2 from Smith3d. I used it on my Ender 3 v2 with a Bltouch and it worked fine. If it works then you can assume that the Bltouch is working correctly and the issue is in the firmware you comiled.

Thanks for the responses. It was the wiring harness. Had it installed correctly, but had a high resistance on 2 wires. I just replaced the harness with a new one that I built. Works great.


there ya go! Well done. What’s that? Oh, that fishy wiring smell is gone :wink:

I’m still staring at my printer and waiting for it to miraculously fix fix itself. My get up and go got up and left.

Your printer isn’t going to fix itself. It will be a paper weight until you pickup some tools and fix it, so quit dreaming.

My brain has gone on vacation and I’m not sure when it will get back,

You are right but I do have a condition that flairs up from time to time and when I feel like crap I can’t do work like that.

I had this same problem and I spent many dozens of hours researching and troubleshooting. I tried EVERYTHING I saw mentioned and nothing helped. Then, FINALLY, I stumbled upon THIS post, which suggested turning the adjustment screw that runs down the top and connects to the tip. I turned mine clockwise about 360* and I have had almost no issues whatsoever since. I can’t believe how much stress and trouble I went through when the solution was so, sooo simple. So, see if it works for you and if it does, post about it wherever you can! I registered here just to post this because I happened to see the question at random.
Good Luck!