Ender 3 V2 BLTouch Problem

I am having a problem getting a BLTouch to work on my Ender 3 V2. When I try to Autohome it to start setting it up the Z axis will not travel in the down direction. It will travel up fine and the X & Y axis’ work fine but it won’t go down. It’s as if the BLTouch thinks it’s triggered.

I have triple checked the wiring and have tried multiple firmware variations with the same results. I have compiled the latest version of Marlin bugfix myself, and tried the Creality and Smith3d versions. All behave the same.

When I turn on the printer the red light on the BLTouch comes on and it extends and retracts the probe a couple times. The red light stays on. When I hit the autohome icon it goes to the Z and X axis switches and then centers on the build area. It then cycles the extend/retract bit a couple times ending with the red light off and the probe extended but it doesn’t do anything after that. There’s a little blue light flashing rapidly inside the BLTouch housing while it’s just sitting there.

Is there something I may have missed or could it be a bad sensor?

Mine has the little blue light, but I’ve never noticed it flashing. Every time I’ve looked it has been on constantly.

What color are the 5 wires on your cable the manual https://5020dafe-17d8-4c4c-bf3b-914a…524f649f11.pdf says that the blue light monitors the PWM signal and the Zmin signal. Do you have the 4.2.2 or the 4.2.7 board? Also there web site (https://www.antclabs.com/bltouch-v3) says the blue and red leds detect wiring defects.

This is how it should be wired and make sure the wires are plugged in firmly as the DuPont cables aren’t what should be plugged into that connector. It should be a 5 pin JST connector which is what i put on mine.


My wires are Brown, Red, Orange (Yellow), Black & White. My board is the 4.2.2. I have checked the firmness of the connector a couple times. The first time I tried it I had actually put a dab of hot glue to hold them securely but have since removed that for troubleshooting purposes.

Then maybe you have a bad bl touch. Only other thing i can think of

Well $40 later for another BLTouch and the problem is still there. No down travel on the Z axis. What could possibly be causing this? I have searched the interwebs and it doesn’t seem to be a problem for anyone else because I can’t find any other cases of it. Pulling my hair out.

That’s how you know you’ve taken up a hobby! I had my own bout of hair-pulling when we had a power outage 17 hours into a 21 hour print. Not only did I lose the print, but I could not make contact with my Octopi after the event. Even after re-flashing, it kept giving me the silent treatment. Finally discovered that for no good reason my router no longer lets my Pi connect via 5GHz wifi. I had to switch over to 2.4GHz to get it to connect.

You can find the manual for the BL-Touch here if that helps: https://www.antclabs.com/manual

A thought occurred to me. I ordered the USB power block device that DrVAX mentioned in his video, but I’m still waiting to receive it. I’ve noticed the phenomenon DrVAX mentioned in his Octopi upgrade video that if you have a normal USB cable connected to the printer, the controller draws power from the USB when the printer power is off. In my case, I notice the BL-Touch is even illuminated red even with the printer power off–it’s drawing current from the USB cable. If you have a USB cable connected to your printer without the power blocker device, try disconnecting the USB cable whenever the printer is off and only reconnect it once the printer power is on. Essentially, the hypothesis is that maybe the weak amount of power being supplied by the USB when the printer PS is off is putting the Ender controller in some kind of funk that affects your BL-Touch. Just an idea.

  1. I take it the BL Touch did not come with the printer: i.e. it’s an aftermarket item you’re adding?
  2. have you reconnected the Z Axis Limit Switch to see if the Z axis works that way?
  3. it really sounds like a wiring issue, as though 1 of the sensor wires in incorrect or something.

Thanks for the link to the BL-Touch manual. I’ll check that out.

I do not have any usb cables connected to the printer. This is a completely stock Ender 3 V2 with the exception of a Capricorn bowden tube and a SeeMeCNC EZ-Struder. But thanks for the suggestion

I’ve been trying to locate a photo of a Creality 4.2.2 board. They’re hard to find. I located 4.2.7 photos alright, but no 4.2.2.

  1. Yes, it’s a genuine BL-Touch but it does not come on the Ender 3 V2.
  2. Yes, if I reconnect the Z axis limit switch and flash back to the non-BL-Touch firmware it behaves normally.
  3. I’m thinking wiring too. I am going to try it with the BL-Touch connected without the extension cable and see if that makes a difference.

Now that’s a good thought. Do you have a multimeter that you can use to check continuity of the extension cable?

Well, it appears to be a problem with the extension cable. If I plug the sensor into the board with the short cable it works correctly. Now to figure out what’s wrong with the cable. Wish I tried this before I bought another BL-Touch. Fortunately I have another Ender 3. I’ll put it on that one.

Well, this is another example to prove my 3 rules of troubleshooting electronics of any kind:

  • rule 1: connections
  • rule 2: connections
  • rule 3: (bet you can guess)..... yep, connections!
I have drummed this into almost everyone in my family and they repeat it every time I start to say it.... and, they agree it's true more than 90% of the time.

Time to get that multimeter out.


Yeah, I know. It’s one of my rules too. I thought about trying that a couple days ago and just got lazy.

Along the lines with connections, I was having these same issues and the problem was the extension cable has different colors so i rearranged them to kinda match the picture posted earlier in this thread. Attached image shows how i arranged the wires
[ATTACH=JSON]{“alt”:“Click image for larger version Name: EECE1949-E98F-4472-AACC-CEEFC986703F.jpeg Views: 0 Size: 3.20 MB ID: 7687”,“data-align”:“none”,“data-attachmentid”:“7687”,“data-size”:“small”,“title”:“EECE1949-E98F-4472-AACC-CEEFC986703F.jpeg”}[/ATTACH]

Here’s the wiring for the cable that came with my Bltouch, I soldered on the 5 wire plug. This worked on my Ender 3 v2 but was a tad short. I have a v4.2.2 board and used Smith3d firmware

Pinout on the 4.2.2 board

And really take the time & car to get the wiring 100% correct. You can burn up your control board if it’s mis-wired.