Sovol SV02 IDEX

After watching a ton of videos and reading post on the inter web I decided to order a Sovol SV04. Appears that the issues it was having have been fixed with the latest firmware release dated 01/10/2022. When it get here and I get it setup I’ll have more details to post. In the mean time if interested here is a nice review by beginer3d

Congratulations! I was hoping you would have ordered the Artist-D. I would have had more minds to draw on. But, I did take a long look at the SV04. Decided to put that off for a few months. Maybe, you can advise me at that time. I really hope you enjoy the printer.

The UPS man dropped off the SV04 about noon today. It was packed very well all nestled down in some nice foam. Got it unboxed and put the base on the desk where it was going to live and discovered that the desk was. to narrow for the printer, whoops. Luckily I had a pice of 3/4 MDF that was big enough to cut a base to set on the desk to extend it.

The printer is pretty easy to put together but in my opinion the instructions though nicely done are a little lacking in certain areas, for example it didn’t mention making sure the gantry was square with the base when you tighten it up. Next when you look at their direction for making sure the X axis is level the show putting the 2 included plexiglass pieces on the table to level it. An experienced 3Der knows that it has to be level with the frame so that is the way I did it. Plugging in the wires would be really hard to mess up. Speaking of wires they are all in nice looms with a protective sleeve on them. The only issue I see is the extruder wires, looks to me they way they have down it would be possible for them to knock a print loose. I twisted them around some and think I may have that issue solved, if not I got another idea. I went over all the bolts and did find some loose ones, not real loose but not tight either.

My next issue was bed leveling their instructions assume you know how to level a bed, even their videos leave much to be desired. After messing with it this afternoon and evening I still don’t have a good level. I do however believe I have found the problem. After many attempts I discovered that the bed rollers were loose. I know I checked them during assembly but I shook the bed sideways. Come to find out the bed was moving up and down. The adjustment rollers are really hard to get to especially the back one so I found it easier to take the bed plate off. I did discover doing that that the underside of the bed is insulated with that foil insulation like is used on heating ducts, nice touch. It did help with the bed heating up and swear it heats faster than my Ender 3 v2.

When trying to set the Z offset I did have some issues with the Z axis not moving down when I pressed the button on the touch screen, couldn’t move it down using Octoprint either so it wasn’t really the touch screen. The touch screen is nice and well laid out but I would have preferred it to have a screen like the Ender 3 with the scroll knob, I put one of those on my Ender 3 v2 much easier to use in my opinion

Over all I would say the build quality is very good, the Z hight of the 2nd extruder is easy to set once you get the 1st one tramed. I think once I get the bed all level and I learn how to use the different function it’s going to be a nice printer.

Congrats. Look forward to seeing some photos of prints.

I am glad you have your new printer. Hope you will be very happy after you Lear some of its idiosyncrasies. Good Luck, and keep me informed on using it. Come summer, it may be my new printer. I was thinking about the Pursa VX, but having 5 add on extruders does not make it an IDEX, so I dropped that printer option along way back. I am really happy with my Artist-D and it works great for me but I will always look for better and I like the auto-leveling option which the Artist-D does not have.

@Lowteck, do you mean the Prusa XL, because it is an IDEX printer as far as I can see, except with up to 5 extruders?

The tightening of the rollers on the build plate didn’t help with the bed leveling at all. I leveled the bed using the normal method sliding the paper under the nozzle. When finished I took a caliber and measured the distance of all 4 corners from the frame. Even tried adjusting the bed using the caliber. With all the corners within .005mm the bed still didn’t show level using Virtualizer in Octoprint. WTF so I decided to check and see if the bed was warped, yes it was I could slide a piece of A4 paper under it, same with several straight edges. Took the build plate off with the same results. There isn’t much tension on the springs so I don’t thing that it a factor. I did do this with the bed cold but don’t think that will have any effect on it. Took a video and sent to Sovol, we’ll see how good their customer service is.

Can’'t find any forums with other owners to see if this is a common problem. They have a group on fakebook but I don’t have an account nor do I want one.

Seems like a pretty definitive demo.

Did a search on warped bed and low and behold one of the 1st that popped up was from Irv about the same problem on his Ender 3 Pro, same style bed. He put a post-it note in the middle between the magnet & build plate. What the heck might work so I put 2 post-it notes in line, put the build plate back on laid the flat edge on it and it was much better.

3D printers remind me of computers, fix one thing and something else go south.

Previously when I was leveling the bed the bed & hot end were cold Bl-Touch probing worked 99% of the time. Now I’m trying to print a bed level test print and the probe kept failing, just like the one I had on the Ender 3 v2. I’m thinking instead of pulling out what little hair I have left I might just wait till tomorrow and update the firmware when the 8 GB micro sd card arrives so I can update the screen firmware too. The current firmware is 1.09 mine has 1.04

I watched a Nero 3D live YT session. He’s building a Voron Trident printer review kit in multiple sessions. In 1 of the sessions he showed the buildplate, which is made from a special alloy of cast aluminum and is ground to be very, very flat (I believe the standard is MIC6). It’s also thick; at least 5/16". I would think it would not warp.

Updated the firmware on the SV04 today which did help with some of the issues. I was able to get the bed leveled. Now getting a decent mesh was another issue. There a menu item for reading the mesh, using that the 3D Touch (Bl Touch knock off) would drop and retract the probe without the probe touching the bed. The messes with the mesh. After sever tries I finally got a decent mesh. Printed a bed level print from Teaching Tech Came out pretty good not perfect, made a couple of adjustments and it printed much better. So I decided to print the XY offset print to align the 2 print heads. Took a couple of tries to get the bed to home because of the probe. The print prints combs that should have the teeth lined up if correct. Made some measurements put the offset in and went to print another set of combs. Now it homes with the probe in the air do it tried to print in the air. Guess I’ll open another case with Sovol.

After updating the firmware Octoprint tells me that Marlin isn’t sending it the commands such as pause, stop, etc. The fix is as simple as uncommenting a Define in Marlin, never got the message until I did the firmware update so I guessing they missed it with the last update.

Hmmm, sounds like that knock-off probe may not be such a good deal.

The probe isn’t perfect but it is working better now. In my infinite wisdom I used double sided tape to hold the ribbon cable to the side of the Z steppers in an attempt to clean things up. Last night after the old brain had a break and was rested the light bulb came on, the wires from the 3D Touch go through those ribbon cables, could be getting noise probably could also mess with the extruder too. After removing the ribbon cables from the stepper I was able to get a mesh to use. The ABL still errors from time to time but I was able to print.

I printed 2 calibration cubes that were on the SD card with came out pretty nice. The top layer wasn’t that impressive but it was okay. Probably the slicing not the printer. All 3 sides were pretty much the same size with maybe a .2mm tolerance. Took a picture but it’s blurry.

I’m trying to learn Ideamaker, it appears to be more 2 extruder friendly and is very powerful. When you use to another slicer like PrusaSlicer there’s a learning curve. So far I can’t get anything to print that I slice with it. Think I figures out the issue but I won’t know until tomorrow. Ideamaker puts M1001, M1002, & M2000 gcodes in the saved code file, their printers understand the codes, 3rd party printers don’t. There.s a couple of ways of removing them without editing each gcode. Finally took a print that I sliced for the Ender 3 v2 and loaded it to the SV04 via the sd card. It’s printing now and so far looks good.

Always thought I wanted on of those magnetic flexible build plates but after using this one I am not sure any more. It’s has a textured surface and it’s a pain to get parts loose even when the bed it cool. Might need to try the freezer trick. If I use glue stick it does help. If it doesn’t get better with age I’ll probably get a glass bed for it. I have pretty good luck with glass as long as I keep it clean.

Actually managed to print something useful on the SV04 last night, today nothing as overtime I tried starting a print the BLT would error. I contacted Solol about it waiting to hear back from them.


The black one on the left is from the Ender 3 v2 and the white one is from the Sv04. Can’t really see it in the picture but you can see the dividers on the outside on the black on but not on the white. The were both printed from the same gcode file.

They both look very good. Not sure I would have any luck printing something with that large a surface area. Will try some day!

They do look good. @Gramps, what filament and bed surface?

The black one was Hatchbox PLA on the Ender 3 v2 glass bed. The white one was the filament that came with the printer on the magnetic flex bed it came with

Almost certainly, the filament that came with the printer was PLA.

Moved the laptop to the other side of the room and the SV04 would home without erroring out, yippie. Tested both cold and hot so I decided to try printing. All went well and the print came out better than it did when I printed it on the Ender 3 v2 a while back. The big difference was the threads which on the ED3v2 I had to do some filling to get the nut to start on screw on. This one I haven’t tried but just from looking at it I think the nut will screw on fine. There is a micrometer holder for the SV04 on it now printing.


I’m really wanting to like the Sovol SV04 IDEX printer I bought but it is really starting to piss me off. I finally go it setup where it would print pretty good using the left extruder. This was after finally getting a mess that doesn’t error in the process. So today I decided to calibrate the right extruder so when in the Dual mode it was printing on top of the left extruder. Wasn’t real impressed with the finger dealies they have you print to line the up so I used a calibration cube from Raised3D. The first one printed very nice but the 2 extruder’s offsets needed adjusted. I made the required adjustments when to print another tower and the printer wants to print in the air a little like the Z-offset is off. Cheke that and it’s okay but I notice that my mess is gone, I have all 0’s for the mess table. WTF where did that go? so I struggled and got another mess except for one point which errored. Okay I’ll cheat and change the bad one using M421 Ix Jx Zx did this using the terminal in Octoprint. We should be good to go, nope still printing in the air. Checked the z_offset again was all good. Noticed that the mesh that shows on the screen was different, in fact ti had 2 spots where the probe errored. What the heck so I did a M501 and retrieved the setting, reading through it I see that the mess it reads is different than the mess on the screen. Power cycle the printer the screen mess is still different than what the screen reads. Somebody here is lying and I’m kind of guessing the screen. I looked and it isn’t storing setting on the SD card like some Creality firmware does. It’s hard to print with Octoprint on the SV04 because a define inMarlin is commented out so Marlin doesn’t report errors to Octoprint nor does pause and stop work right. If you send the print with Octoprint you can’t stop it using the screen the only way is to power off.

The print tower take about an hour to print. I find on the SD card that came with the printer a real quick an easy XY calibration test. It prints a 20x20 square 2 layers high then switches colors and prints a 10mm border around it. I’ll try that iss quicker and easier to read, just measure how much it’s off. Load the pre sliced file off the SD card and start the print. It prints the 20x20 square switches extruders and starts on the border. All is going well until suddenly the extruder takes off to the rear of the bed and tries to print them the bed moves to the rear and keeps bumping the end stops, the left extruder is over it spit tray doing a dance. Finally had to power off. It’s a shame when the files on the SD card that they sliced won’t print on their printer.

I emailed the last Friday about the warped bed, I sent a video and the order number. Monday I get a reply saying the video wasn’t viewable and actually sent it back and it was 0 bites. Okay so I uploaded the video to Rumble and sent them the link along with the order number and the serial number as they requested. This is Thursday and I.haven’t heard squat from them. I have sent at least 3 emails about the ABL not working and haven’t even gotten a reply at all. If I don’t hear from the tomorrow I’m going to file a PayPal dispute for a none working printer.

Sorry for the long post I needed to vent.