Printing from STL to Gcode

I am a new user and have tried to set up a MP10 printer with the Gcode and start and end coding that you have put out there for the best match but still having problems. prints great with the couple of files that come on the SD card but when I go out into the world and download a STL and convert it then go to print it dose not seem to want to print right at all. very confuse as a new user. can anyone help or possible video chat with me on what I might be doing wrong. I have Cura 4.6.1 and setup for Ultimaker S5 and also setting for a MP10 Printer.

If it is printing the default files ok, then your hardware seems to be setup in working order.
You may need to look at what you are doing in your Slicer. Before modifiying the gcode, make sure you can slice a STL file with the default gcode for your printer. Add a New printer (same one) but use its default settings. Make sure the Nozzle size is set correctly and your filament type and size is set correctly. Do a test print (calibration cube, Temperture tower, retraction tower etc…)

I know i tried to jump in to much to fast when i started. Some STL files you download are Works in Progress, and dont have good mesh and have issues. Try downloading and printing files which have a large number of likes/ makes. Eg. #3DBenchy - The jolly 3D printing torture-test by by CreativeTools - Thingiverse

Always good to start with Dr. Vax’s videos on Slicers

Also then start using the default Cura profiles, but then you may want to use others profiles that are fine tuned, and over time you will make your own adjustments.

Yes when I use the couple of default files on the SD card with the exception of one of them for a half cat and face sheild masks it seems to be okay it is when I try and print items that I download and bring into cura. when you say mesh am I missing s step after slicing I save it right to the SD card and put it into the printer to print. Am I surpose to do some sort of mesh first.

From my admittedly limited experience, I agree with Maximo101 that your slicer settings are a bit off. Now, one thing you could try is to open the gcode for the cat in something like Notepad++ and look in there to see what it sets the temperatures of the extruder & bed to (both for the 1st layer and then the subsequent layers). I would also check the layer height, print speed, and extruder speed. You likely will have to look up the codes on the Internet, but it can be done.

I’ve been using to view the code, and it shows you the 2d and 3d views.

@shocky47 im still new to 3d printing too, try downloading this cube i had previously sliced and see if it prints on your 3d printer.

@shocky47 Sorry, I just noticed this thread. The Monoprice MP10 is a Creality CR-10 clone, so I used that profile initially (I have an MP10 Mini). Make sure the printer settings match what is in the manual and use DrVax’s Start G-code found here in the comments of his YouTube video, “Monoprice MP10 3d Printer the Good and the Bad.”

That said, did you check to make sure the nozzle is not clogged? I added a bit of extra filament retraction to the End G-code because of clogging.


P.S. – I’d be careful of using g-code not customized for your printer. @Maximo101 has an Ender 3, which has a smaller build volume (so that’s ok) but I know Monoprice has done some tweaking to their flavor of Marlin.
P.P.S. – @Maximo101 Why two wipe lines in your Start g-code? Just curious. :slight_smile:

OKay I will try that and see if that works with the files once I transfer them over to the SD card and try to print and if that works then I will hook it up directly to the computer. is there any suggestion if I hook it up directly to the computer through the repitor program that cam with it.

Sorry, I do not have much experience with Repetier-Host. I was able to get Cura to talk to the printer via USB first and moved on from there. It’s on my To Do list, however.

Let us know how it goes!


Hello Alan,

I can get the repetier to talk with the printer as well in moving the plate around and the head but what I seem to have is a problem when I tell it to print the 3d print it will not do that just seems to say print finish before it even gets started, him him

@shocky47 Hmmm. Can you post the Start G-code that you are using?


Progress! 3D printing is certainly not plug-and-play. In case it helps, below are DRVAX’s recommendations for the MP10 Start and End g-codes.

I’m not sure what is going on regarding the message “G-code file can not be modified.” I think I saw it once when I opened the manufacturer’s Cat g-code in Repetier-Host to look at the Start g-code they used. My typical work flow is:

Download STL (from Thingverse or elsewhere)
Open in Cura
Save G-code to SD card.
Put SD card in printer
Using the printers LCD interface, select the file and print

Sorry if this is a bit pedantic but I am not clear the issue with the first layer test circle.


;----- Start G-Code -----
G21;(metric values)
G90;(absolute positioning)
M82;(set extruder to absolute mode)
M107;(start with the fan off)
G28;(Home the printer)
G92 E0;(Reset the extruder to 0)
G0 Z5 E5 F500;(Move up and prime the nozzle) G0 X-1 Z0;(Move outside the printable area)
G1 Y60 E8 F500;(Draw a priming/wiping line to . . .) G1 X-1;(Move a little closer to the print area) G1 Y10 E16 F500;(draw more priming/wiping)
G1 E15 F250;(Small retract)
G92 E0;(Zero the extruder)

;----- End G-Code -----
G0 X0 Y150;(Stick out the part)
M190 S0;(Turn off heat bed, don’t wait
G92 E10;(Set extruder to 10)
G1 E7 F200; (retract 3 mm)
M104 S0;(Turn off nozzle, don’t wait)
G4 S300;(Delay 5 minutes)
M107;(Turn off part fan)
M84;(Turn off stepper motors.)

;-------- DrVax End -------

I just posted above and saw your pictures. Looks like my first test print! Now lower the Z-offset!

okay will try that one next thank you and am trying to do something else as a test as well.

question for anyone if the cura dose not show the slice option can anyone tell me why that might be

Can you post a screen shot? How odd! Below is what Cura for Mac looks like once an STL file is loaded.


[ATTACH=JSON]{“alt”:“Click image for larger version Name: Slice_button.jpeg Views: 0 Size: 135.0 KB ID: 727”,“data-align”:“none”,“data-attachmentid”:“727”,“data-size”:“medium”}[/ATTACH]

@shocky47 Is it possible Cura isn’t showing the slice option because there’s one or more errors in the STL?

I just tried loading a plain text file with an STL extension into Cura and a window popped up saying “Invalid File. Failed to load Bad.STL”

Interesting way to test. I would not have thought of it. I would have made sure I had an STL file that has a hole in the mesh that prevents it from slicing. I had one recently. I created a test object in Sketchup Make and saved it as a .OBJ file. I then tried importing and slicing it in Prusa Slicer. It said it couldn’t be sliced.

That’s actually what I suggest you try: IOW, install Prusa Slicer and use it to try to slice the file you’re having trouble with.

Hah! That’s why I asked for a screenshot to understand what’s being asked. Shocky47 could try slice it in Repetier-Host which has Slic3r.