Arguments in Easy Print

With little luck, I have been attempting to push out my first print with my Geeetech A30 Pro. As I try to slice the file I repeatedly get a “The arguments had been set but not used in slicing!” OR “The arguments had been applied!​” message. I have Googled this issue to death without success and have also searched the forum to no avail. As you might gather it’s becoming just a BIT frustrating! Any suggestion to point me in the right direction would be appreciated, thanks!

Not familiar with Easy Print is it a slicer? Have you looked at either Cura or Prusa Slicer? Might be a better choice with lots of support

FWIW, the latest version of Ultimaker’s Cura has a profile for the “Geeetech A30.” I’d give that a go as many Chinese slicers are re-skinned Cura. No idea about Easy Print as there is only a Windows version.


Edit: Geeetch has some YouTube tutorials.

I appreciate your rapid response to the possibility of solving my issue. Easy Print is the slicer recommended by Geeetech. I had already tried Cura AND Prusa with the same end result - I was unable to print from either! Considering I purchased it on Dec. 27, I felt it necessary to get my first printout prior to Christmas - even if it was only for my own sanity! I’ll try them both again I’ll report back with the results after I try this again later tonight, hopefully with positive results

As for my follow-up attempt, using Cura 4.13.1 I sliced my build and then tried to print. With the printer connected I selected “Monitor”. I could then pre-heat my build plate and Hotend. It also moved the build plate to the far side of the printer. Then, with the SD card inserted, I pressed “Print” on the printer and waited. And waited for a bit more. Then I gave up after 15 minutes or so.
Tomorrow IS another day.

When you put the SD card in the printer did you choose the file you wanted to print from menu on the screen?

Progress! We know the printer and the computer can talk to each other. To trouble shoot this, I have a couple questions:

  1. After you clicked on “Print”, did the printer bed heat up? (Front panel should show the temperature rising. On some printers, this can take a while.)
  2. Did you use “Add Printer” to install the “Geeetech A30” configuration?
  3. Try saving the sliced file to an SD card and print directly from there. If this fails, please post the sliced file here so we can look at the gcode.
  4. Have you tried printing any of the pre-sliced files on the manufacturer’s SD card?


To answer each question;

  1. Yes, Both bed AND extruder heated up. I confirmed this by touch as well as software on the printer and in Cura.
  2. Yes, I use “Add Printer” to install the “Geeetech A30” configuration.
  3. After I saved the sliced file to an SD card, I clicked on “Print”. This was after the two heaters were brought up to temp. My hope was it would print directly from there. The print file is the saved gcode from the slicing. I’m certain it has a few issues as well as it appears to lack the starting coordinates (OR is that in the firmware - OR BOTH?)
  4. I really don’t remember such an SD card is included, regardless, I know that I DONT have any such card now. I can certainly see how it could help.

I have attached the gcode used for my print trials.
I truly appreciate your aid and assistance with this. Hindsight says I should have dealt with this upon delivery

I attempted posting my gcode file twice, both times blocked with a message claiming such files WEREN’T allowed! Perhaps tomorrow.

Either ZIP the file, or change its extension to something like .txt and try uploading again.

Great idea - first I tried using “.temp” - well, THAT didn’t work! I’m certain if this is renamed “.gcode”, it SHOULD work - guess we’ll know soon. Thank’s

1_Print Test Cube_25x25x25 G-code.pdf (805 KB)

Thanks for answering all the questions!

  1. Ok, the printer hotend and bed were both heated/ing. Did the front panel display indicate what the respective temperatures were? Did you see “Printing…” on the printer’s LCD display? (Line 30 of the gcode is: “M117 Printing…”)
  2. Good! Can you post the start g-code that you are using (just double checking)?
  3. Ok, after inserting an SD card with a gcode file into the printer, you were able to hit print from the front panel screen and select the .gcode file. Try renaming the file something short with only letters in the name, like “TestCube.gcode”
  4. Too bad. According to the manual, the printer does come with an SD card (they call it TF card"). Try e-mailing support and ask them to e-mail you the files that come on the card (or a link to download site).

I loaded the gcode into Repetier-Host and it shows the cube off the corner of the print surface (see image) and not in the center of the print surface. Seems like the printer is not setup incorrectly (or there is a problem with the firmware). Can you post a screen shot of the printer settings in Cura?



Try loading this file into your slicer and see if it will print:


30x30x0.20.stl (684 Bytes)

I feel destined not ever to be able to 3D print! Upon receiving your file and loading it into Cura, the games began AGAIN! Of course, it wasn’t simple - the latest message is “Cannot slice in Cura due to zhop speed setting” Considering that at one time I worked in tech support, providing solutions for Apple owners regarding their vintage Mac, THIS new world of tech is somewhat intimidating! I’m currently working on this issue as I also work doing domestic chores, trying to pull my weight

Except for the printer definition, I would start by having the Cura settings at defaults. That’s usually a good place to start.

Thanks for the suggestion, as per my tech support days I would be certain to retain the original settings. I admit to being one of “THOSE” guys who always worked things out on his own. BUT, as much as I detest admitting so, THIS time I need to reach out and am grateful for your response. I honestly have no idea as to if these are “typical, newbie blunders” OR is this some kind of “fluke”?
I’m also a model railroaded, one of the reasons for purchasing the printer. Indoors I woke on my “H.O.” layout. My wife is working on an “N” scale, During summer both of us work on the “G” layout (1/24) in the garden, thus the reason for the printer.

Zhop speed setting issue continues. Even though I simply open Cura and open the file, I receive this error.

Just tried loading another image - this time it sliced properly. NOW to see IF it will print!

Progress! Attempted yet another print. This time I was able to control the printhead from Cura, moving it in whatever direction I desired. I selected both bed and extruder Pre-Heat temperatures Once up to desired temperatures and with the SD card inserted with the print file downloaded onto it, I pressed “Print” on the printer The print head moved to the front, left corner as its “0 - 0” point and worked as if it were printing. As it was barely printing on the bed I shut the print job down as it appeared to be a waste of filament. My guess is if the “gcode” was changed to have the origin 0 - 0 as the center of the bed.

In Cura, under Machine Settings (manage printers –> machine settings), is “Origin at center” checked?


P.S. – Do you know of any good sites for O-scale models?

Hi Alan,
Thanks for the suggestion, however upon checking my “Machine Settings” it seems"Origin at center" HAS been checked
Regarding O - scale, I’m sorry to say I have no idea about an actual site BUT I did find this “conversion” site. Looks relatively simple - put in the original scale and the output scale and get a scale percentage and scale factor for your slicer. Hope it helps!
Site is called Digital Taxidermy Online Scale Calculator - Scale Convert, Scale Ratio, Scale Dimensions