Bed adhesion issues with new MP10 mini

Recently got a Donors Choose grant to purchase printers for my school. Was recommended to get the MP Select mini and the MP10 mini. No issues with the select mini as I have one at home. However, using the Dr. Vax Cura setup for the MP10 is leaving me with adhesion issues, read that to mean nothing is adhering to the bed. I set the initial level using a post it note paper and then auto level, but still nothing is sticking. I could really use some tips to get this figured out.


First, get some Magigoo. I bought the 1.5oz size and it’s hardly been touched, despite being used for virtually every print. Start with that, and see what happens.

The other thing is (and Magigoo requires it) is the bed heating. I run the bed at 60C for PLA and 80C for PETG. Combined with Magigoo I just don’t have adhesion issues.

I have an MP10 Mini and there is a bug where the printer forgets that you have already set the Z-offset. The auto level routine can add that distance to the home position resulting in the printer homing further and further from the bed. The procedure that has worked for me is to first set the z-offset to zero, heat the bed, run auto-level, then set the z-offset to -0.35 (the probe offset is about -0.40 but I’m paranoid about making grooves in the bed), and then run a first-layer test print while adjusting the z-offset live. Once I am satisfied with the adhesion of the first layer, I don’t run the auto level routine again unless I change something like replacing the nozzle.

Also, be sure to buy replacements for the Bowden connector on the extruder or print some of these: Monoprice Bowden Adapter by sukrutikves - Thingiverse as the interior teeth of the connector fail easily.


P.S. – Here is a more detailed explanation of the Z-offset issue: Bed probing and Z-offset basics for MP10 (Mini) - YouTube

Multiple edits for clarity

I look for the magigoo. Currently I use elmers white or purple glue sticks. They work ok on my select mini.

Thanks for the advice Alan. I followed your instructions and finally have a decent first layer sticking.

Just keep in mind that the model you chose has a very small foot print. There is not much on the bed to hold the model and the slightest bump will knock it off.

Using a glue stick is helping if you want to avoid a brim or you cannot use a brim (print in place stuff). Especially when printing small parts. I use “UHU Stic” on my glass bed when needed. It seems to hold up quite well, as I did not reapply it for weeks and it still seems to be a solid plane of glue on the plate.

I personally tend to add a brim, when printing such tiny parts. I also would increase the number of models to at least four. That way you create a bigger print area and the brim is covering the small objects quite well. If one object still gets loose in the process it does not matter as you have backup. I recently printed a 7 hour print with a gigantic footprint and still used a 1cm brim around it. Not for general bed adhesion, but to make the bottom look nice as even a 0.01mm lift in a corner is visible and you don´t want that on a show case.

[ATTACH=JSON]{“data-align”:“none”,“data-size”:“medium”,“data-attachmentid”:3655}[/ATTACH][ATTACH=JSON]{“data-align”:“none”,“data-size”:“medium”,“data-attachmentid”:3656}[/ATTACH] OK gents, Was finally able to get a first layer to stick. Tried to print a benchie. You see the results of the failed print. What steps should I take not to clean this up? Also, the bottom layer of the benchie did not stick to the model. It pulled off and remained stuck to the brim.

I like Magigoo because it makes it easier to get part’s off this printer’s PEI bed.

I’m assuming this is PLA. Did you calibrate the extruder and the filament? It looks like the printer is under extruding. Also, you shouldn’t need a brim for benchy. I use a purge line and skirt. The bottom layer not adhering to the part suggests to me the first layer needs some further tuning. For a 0.2 mm layer height, I like an initial layer height of 0.3 mm. Also, try slowing down the printer (say 40 mm/s speed so 20 mm/s first layer)–the universal fix for diagnosing problems.


P.S. – Does the extruder skip? I followed DRVAX’s recommendation and replaced the stock extruder with an all metal one after the stock skipped on me.

Yes indeed; many FDM issues can be resolved just by slowing down.

I think you a) have a big under extrusion or b) your slicer is set up to a wrong filament.

I would from the look assume it is the latter. If you use cura it may be that your profile is set to a 3mm filament, while you are using a 1,75mm filament. So first check what is used in your cura profile. Curas default is unfortunately wrong in the most cases.

If your printers profile is set to 1.75mm, then check if a 100mm extrude moves 100mm of filament into the extruder.

Thanks guys, I’ll check those things tomorrow. I’ll also start looking for the correct metal extruder and Bowden tube.

All of my generic filament diameters are 2.85mm and I can’t change them…HELP

Ouch. Not good given the MP10 mini uses 1.75 mm filament. Are you saying the 2.85 mm filament is stuck in the hotend? If so, you are going to have to take the heating element out, heat it up (say 220), remove the nozzle, and use pliers to remove the filament. Becareful!


Using a 3 mm filament on a 1.74 printer sounds like a recipe for trouble.

You would need to replace the hot-end, the extruder, and the Bowden tube if it is a Bowden style printer. Then you would have to change these parameters in your slicer.

Last time I had the issue I created a new printer profile.

You need to setup the diameter during the setup process. You somehow cannot change it later unless you open the printer profile with an editor and patch it by hand to the right diameter.

I had that when printing a single wall test print box. The PLA handled like TPU and the box was squishy :smiley:

In Cura you can change it on this tab:

[ATTACH=JSON]{“data-align”:“none”,“data-size”:“custom”,“height”:“424”,“title”:“Screen Shot 2020-09-10 at 3.18.51 PM.png”,“width”:“600”,“data-attachmentid”:3704}[/ATTACH]

Nice. Thanks Irv.

The problem wasn’t actual filament, but the filament diameter settings in Cura. I asked the same question in the Cura forums and was given the same information regarding where to set filament diameter in cura. Fixed. Now I just need to do the extruder and bowden tube upgrades and I think I’ll have my issues fixed. Slowing down the print speed to 40 mm/sec also helped.

It is somewhat amazing how much prints can be improved by slowing down.

So, are you converting to 2.85mm? Permanently or just until you’ve used up the filament you have on hand? I do look forward to hearing about your experiences using larger filament, and to see photos of you setup and prints of course.