Material missed at a specific place

Hi guys,

I have a weird problem with my Tronxy X5SA Pro Directdrive. I print the part (see photo) with a wall of 1.8mm (3 X 0.6mm) and it is missing a piece of filament either at the beginning or at the end of the printing of a layer. I print ABS at 245 deg for nozzle and 100 deg for the bed. The print is done from the outside to inside. I’m using Cura 5.0 and cannot find a parameter who can cause this.

Can you help me please ? Thanks and have a great day !

I’m wondering about the retract and linear advance settings. Have you modified these?

Thamks for your fast response :slight_smile: Wuere can I modify it in Cura 5 please ?

In Cura, you can search for settings. There’s a search box on the upper right when you open the print settings just under the word “Profile”. Search for “retraction” and you should find that easily. There are many settings for retraction, but the main ones are retraction distance and speed. For a direct drive extruder, the distance is pretty short - about 1mm or less.

As for linear advance, it’s a feature that may not be enabled in the Marlin firmware that the printer uses. (I’m presuming that’s what you are using on your printer). The linear advance setting isn’t in Cura by default, though there is a plugin that allows you to tune it. Ultimaker Cura Marketplace

Mainly though, I was wondering if you had enabled linear advance and then changed the setting. If not, you can ignore this question, because adding linear advance to your firmware and then calibrating it can take a lot of time, especially if you’ve never built and flashed firmware into a printer before.

Hopefully someone else with more experience in this area will recognize what’s going on.

I did a K factor pattern to see what is the best K factor for my printer and it seems to have no difference on the differnet lines. I added a 900 command to the start g-code in Cura, this command is 900 k2.6. I printed my object again with no difference than before.

It’s wierd because it’s only at the start of of the inner shell of the wall. No problem at all, for example, at the start or the end of a support lines or external shell. I tried others objects and it,s the same situation

I will try with Ideamaker

thanks again !

If linear advance isn’t enabled in the firmware, M900 will be igrnored and only show a warning on the serial port of the printer. So if you don’t have anything connected to the serial port, you won’t see it.

However it seems unlikely that this is the problem.

Keep us posted on what you find to be the solution!

I’m printing the same object with an Ideamaker gcode file and it’s already looks good :slight_smile:

I’ll keep you inform when the printing will be fishish !

1 Like

A quick note to tell you that I think it’s a problem between Cura and the Tronxy Marlin firmware because with Ideamaker the object prints perfectly :slight_smile:

Thanks a lot for your help and have a nice day !

1 Like

Have you tried Cura 5.3? Maybe there was a bug fix that addressed the issue.


Not yet but I will try in the next days !