IDEX Mirrow prints not same size

I am doing another chess set. Got a crush on chess sets! Anyway, I have noticed that the sizes seem to be different between the hotend 1 and hotend 2. Since I am using PLA+ on extruder 2, I thought that it was the difference between PLA and PLA+. I have cut back a lot on the flow on extruder 2 between what I was using and what the PLA+ seemed to be happy with. Looks look better (smoother), but still over sized like it was swelling. I cut back on the temperature. Cura is forcing me to use the same temperature on both hot ends even though it should be independent between the two. I sit there and cut the temperature down twice, once for initial layer and after first layer. It makes the surface more smooth, but still larger, like filament swells after extrusion.
My next thought I have a question about. Is there a setting in the firmware that tells the X axis how many steps there is to move so many mm? If so, how do you identify and set?

Yes in Marlin config.h. I believe this is the setting you want to edit

#define DEFAULT_AXIS_STEPS_PER_UNIT { 80, 80, 400, 97.3

Thanks! @Dcey. I gave the questions I asked some more thought and if I am getting a complete circle with both extruder 1 and extruder 2, then it cannot be the x axis alone, but it cannot have anything to do with the Y axis either or I could not get good results with extruder 1. Therefore, my belief at this point has to be the PLA+ filament expanding after extrusion. I have it down to flow rate of 105 with the flow rate for the PLA being 115. Using an Artist-D and it only having one memory location for both extruder steps, and I am using the two G code start tabs for extruder 1 and extruder 2 in the machine settings, and the extruder 2 being acted on last the two extruder steps being equal. Therefore, the only thing I can think of is the PLA+ is expanding after extrusion. If you or anyone else can suggest something else please state so. One more thing I have dropped the start and run temperature down to 205 from PLA temperature of 230 and 220. I would sure love to solve this. I used a caliper to measure between the same pieces between the two filaments as 2 to 3 mm more for the PLA+ in sizes.

Cura will not let me have two different temperatures between the two extruder hot ends. Therefore, I am having to do the temperature change in the firmware after heatup. I thought that Cura would let you have two temperature settings in duplication or mirror modes, but not letting me.

Hi Low-tech,
Well, personally I have never run flow rate at more then 100%. I usually run flow rate at 95%. That’s even what I run it at on the artist d pro. I mostly use simplify3d for my slicer. Default setting on S3D is 95%. Always worked well for me. And 205 is a much better temp than 220-230. I have always had problems running pla at those high temps. As far as the pla+ goes…I’ve never printed with it so I can’t say if it expands or not. Just at of curiosity what is your layer height and line thickness in cura?

@Dicey I have been using layer height of .16 with first layer of .2. The line width of .4. I watched an interesting video last night in search of informaton on how to convert a single color print to a duel color print. He said to use .44 as layer width.!!!

I presume you mean 0.44mm line width. I’ve never tried that. Who knows, it might work.

This is true…In S3D if you switch from manual to auto it will change the line width from .4 to .48. I find that when you do this it sometimes doesn’t fill in small gaps between walls. If that’s the case I will manually adjust line width and check use single line extrusion fill in advanced settings. Cura has the same thing. The only time I’ve noticed a problem like you’re having is from drag on the extruder. Looked just like your pictures.

Funny you mention rafts. I used 1 yesterday to print a roller holder for filament spools, because it has a cylindrical bottom. 1 thing I’ve noticed about rafts with supports is the supports peel off the model very easily.

I had it happen once when i forgot to change the mode to auto-park. I still had it on full control. Not sure if that’s the case for you. That’s just what happened to me.

Regarding the original issue: “I have noticed that the sizes seem to be different between the hotend 1 and hotend 2.”
This could come down to nozzle diameter, couldn’t it? If one has a little more wear than the other, the pressure will be lower, flow higher, etc.
I’m a single nozzle guy, so I’ve never experienced this, but if you’re using inexpensive nozzles, tooling accuracy could be the issue.

Yes, what @Dicey said. Be very careful to reset the system to auto park after doing mirroring or duplication.

If I had been in duplication or mirror mode, it would have tried to tie with extruder 1 before the print had started. I did do that once.