I want to activate the M600 command.

My printer is working nicely with Marlin version 1.1.6 and I really feel daunted about using the arduino ide. I have a bootloader installed by my friend who is not available because of this “Plandemic” so I’m looking for the easiest way to activate the M600 command. I just have a little 8 bit board and am wondering if I can just activate my version 1.1.6 Marlin without trying to install a new version. I tried to do it following a video which took me to configuration_adv.h and advanced_pause_feature then to the the configuration h file to do something else. When I tried to compile it I got an error message that said “Error compiling for board Sanguino 1284P boards”. I of course have no clue what that means. My 75 y/o brain is not as good at learning things as it was before I got hit by lightning 20 years ago. I really would like to print with 2 colors on my ender 3 pro.

I don’t know if you can activate M600 but, since you do have a bootloader, you might want to look at the firmware provided free of charge by TH3D. I installed it on my Ender 5 Pro and it has been working beautifully. It does require the use of the Arduino IDE, but you won’t have to compile anything; TH3D has already done that for you. You basically make a few changes to the files, and use the IDE to flash the firmware to your printer. They include complete instructions in the package. The only point of uncertainty was when they said the click the arrow in the top left corner of the Arduino window – there were 3 arrows :(. On arrow pointed up, one down, and the 3rd to the right. I clicked the arrow pointing right and it worked.

BTW, getting struck by lightning; shouldn’t that have revved up your brain to superhero status? ?

Lightning strikes are definitely not good for your brain. Even though it may be hard to believe I was hit twice in my life but the first one didn’t seem to do any damage. The first time was 1972 in St. Lucia. Both times I was inside a building.

I think I will try to see if someone un derstands the error code. I’m not in a hurry, my printer is working fine.

I was, of course, kidding. I have come close to getting hit a couple of times, but they missed thank goodness.

When I was a teenager a million years ago I was just playing the 18th hole at the Regina golf club in Saskatchewan and this cloud came rushing in over us and our hair (Iwas with two others) stood on end like you would see in a catoon and we just ran for the clubhouse and happily were not hit.

You played golf in Regina? You grew up there I take it?

Yeah that;s where I grew up.