Cr-10s pro v2

I bought one from Walmart that was sold by a Canadian “Electronicstore” that ended at $352 after taxes and a 0.80 donation to the Red Cross.

Unfortunately the left Z post makes an awful grinding noise, thinking that the stepper motor was bad, I replaced it with a new Creality one from Amazon and the problem persisted.

I contacted Walmart and the reseller and have not heard anything after sending a video they requested.

I don’t want to return it, just fix it…

What can I do to troubleshoot the issue and fix it? The right side by itself is as quiet as anybody can expect.

Thanks for any help! (the mp4 file is too large to attach)

Maybe this is an alignment issue, or perhaps the left lead screw isn’t straight. If it was me I would move the Z axis up & down, putting my ear close to different parts of the left Z axis to hear if I can isolate the source of the noise. If that doesn’t work, I would then look at removing the lead screw & roll it on a table to check its straightness. I would also check all the nuts to see if any are binding. If the axis has an anti-backlash nut I would make sure it’s not ‘frozen’ at a kilter.

Problem solved!

A Google search took me to Reddit, there were cases of switched wires in the Z cables.

I took the cover apart, followed the cable and there was a loose jst connector, pushed it in, turned on and the stepper was as quiet as possible!

Makes me wonder about the quality checks… Obviously nobody had turned it on at the factory.

I fear that there was a batch of defective printers and were dumped as “bargains”

I think it’s quite possible the JST connector worked loose in transit. These things are coming from China: trucked from the factory to the dock, shipped to the US, trucked to a rail yard possibly, transported to a destination city, trucked to a warehouse, inventoried, then shipped to the user. At every step there is handling, fork lifting, shaking, bouncing, possibly dropping, etc., etc. It all adds up to many possibilities for something like a JST connector to come loose.

So, in the end, I guess the problem is that 1 stepper motor was working, but the other was not, leading to serious racking of the frame.

Glad to hear you figured it out. Good detective work.

Should I apply hot glue to all the terminals?

Any comments on the tiny-machines-3d firmware? The printer has the v1.70

There would be nothing wrong with hot gluing the terminals, but I suspect it’s not as important once the printer is in its final location.

I’ve never heard of tiny-machines-3d firmware.