center the print

[ATTACH=JSON]{“alt”:“Click image for larger version Name: Benchy.jpg Views: 0 Size: 1.67 MB ID: 9986”,“data-align”:“none”,“data-attachmentid”:“9986”,“data-size”:“medium”}[/ATTACH]
Hallo all you 3d gurus I got a little problem I don’t get my prints centered
my setup Ender 3 v2 Microswiss direct drive dual z axis antlabs bltouch firmware from smith3d version 1.3.2 jyers build
my start code in Cura look like this

G28 ; home all axes

G29 ;

G1 X0 Y0 Z0.2 F3000 ; get ready to prime

G92 E0 ; reset extrusion distance

G1 X160 E15 F600 ; prime nozzle

G1 X180 F5000 ; quick wipe

is there some code I can use to centered the print
best regard Rikard

Your firmware probably needs a change. If you home the printer and then move the head to 0/0 the nozzle should be right on the corner of your print bed.

When for example 0/0 is outside the print bed, and 12/15 is the real print bed corner point. You center will be off by this value.
The real issue is that your bed for example is 220/220 BUT the slicer will allow 232/335 as max, which may cause a crash. Instances like OctoPrint will notice that and spit warnings. So tweaking the slicer is not a good way to center the print.

Better fix it the right way. This is nothing you should set up inside the slicer config in the first place, as you will run into issues. Printing the full print bed size is also impossible and when switching the slicer you need to remember the limitations or you may cause a tool head crash again.

You need to set the X and Y offset within the firmware, so after homing the printer is showing -12/-15 (in this example). Then your print will be centered, as 110/110 is the center point.

The values can be found in configuration.h:
#define X_MIN_POS 0
#define Y_MIN_POS 0

MIN_POS is the distance between home position and build plate corner and can be negative, when the nozzle is outside the bed. If it is not correctly set inside your printers firmware, the printer uses the home position as 0/0 and therefor you cannot print in that area. You are loosing build volume and the prints are not centered.

There is one and probably very rare reason that everything is fine and the print is non centered. This happens when the nozzle is not able to reach the corner of the print bed due to hardware limitations. My TronXY X5 is loosing 20mm on X and 8mm on Y that way. The prints are not centered, but since 0/0 is the only position the printer can reach, that is ok. I had to reduce the print bed size, as the 220x220 on the package was kind of a lie.The bed size was correct, but the usable print surface is only 200x212.

Compiling Marlin is easy like hell these days and Marlin comes with all sorts of default printer profiles. Once you get this compiled for your printer just a few changes to the firmware configuration files will adapt to your hardware. As a bonus you are able to enable additional features or disable stuff you don’t want.

Just experiment with it. When something goes wrong, you can always go back to the firmware you have.

Of course it is easier to download a compiled version somewhere, but you get what someone hacked together for his printer and his liking.

first thank you for your answer
I should try to compile my own firmware I see your point here
but before I attach the bltouch I use a row like this to fix the problem [IMG2=JSON]{“data-align”:“none”,“data-size”:“full”,“src”:“”}[/IMG2]

G92 X-10 Y-10.0 ; set home offsets

but the firmware I download don’t like that command it start extrude on the side of the bed so I delete that row

I think Drvax have some tutorial of howto compile firmware

thanks !!

Because X_MIN_POS and Y_MIN_POS are set to zero in firmware. That is why you cannot move/use values below zero.

thanks again it works I compile a new firmware with the settings and it works perfectly now I should just learn howto add bltouch but I’m learning ?