new topic/ not a new topic PETG profile DrVax video

sorry guys, I’m a total noob, who has an Eryone er20 3d printer,since April this year, I’ve had some issues, that i have been able, with help from my son, to fix, but my BIGGEST issue so far has been PETG profile in Cura ! I have Cura 4.10 installed and have to ask, in Irvs’ amended Gcode from the video, can i just copy and paste into my Cura settings profile ??? ? Thanks in advance

No worries. What’s wrong with the PETG profile in Cura and why would this gcode fix it (I do not have an ER20)? DRVAX has a number of videos with gcode. Can you post the gcode or a link to it?

In case it helps, this is a very useful site:


Yeah, in my opinion profiles are in general to hyped up all over the net. At least in Cura the basic profiles for materials work just fine.

Copying some profile does not magically make your printer problem go away. All you need to change in those profiles are probably retract length values as this depends on Bowden/Direct extruder. You try out new features as you need them. No fixed profile will help you to get all prints done perfect.

I never used any profile and just grabbed the defaults. I tweak here and there depending on the print I need to do. Like disabling z-hop or changing the support type and the bed adhesion support from brim to skirt or raft.

Those are things you learn from doing and unless you are tangled into an fixed environment where printer, slicer and filament come from the same company, you always need to tweak here and there. 3D printing is not just inserting filament, loading a file and go, like with a washing machine. You need to lean the stuff anyway. Even if you get lucky now, you will need to estimate what is wrong and how to get it fixed.

thanks for your input guys, I am trying to use ‘Overture PETG’ which has a nozzle 240, bed 80, i have modified a PLA gcode, now when i start a print, the gcode seems to still be using the PLA temp settings of 215 & 65 !! the ER20 has a tune function so, if i set the nozzle to 240 and the bed to 80, my prints are fine.could you guys advise me as to which line in the Cura gcod would have to amend to correct the temperature difference. thanks again. william

Don’t set this in the beginning gcode section in Printer Settings – set it in the Cura Print Settings panel (printer vs print).


Just search for “temperature” in the search box (as shown), then set the desired temperatures. BTW, 240C seems a little high to me, but it may be OK if you’re printing fast enough. I use 220C to 230C when printing at 50mm/sec.

thanks Ender5r, ? have done, thanks again, watch this space ??

Sorted, thanks Ender5r ? works a dream. thanks Alan & Geit too cheers guys ?

good to hear you got it working. Look forward to seeing your future posts.

thanks Ender5r hope to post asap ?