Need Help sorting out upgraded Ender 3 Pro with dual Z and CR Touch

Hello Everyone, 3d printer newb here and I’m hoping to get some help from my seniors in this field so here goes…

Thanks for taking the time to read this and, if so inclined, offer assistance with my first steps into 3d printing. Please bear with a bit of long winded explanation it will be easier to understand my current problems. here are a couple of pics of my rig in its current state.

[ATTACH=JSON]{“data-align”:“none”,“data-size”:“medium”,“data-attachmentid”:16418}[/ATTACH] [ATTACH=JSON]{“data-align”:“none”,“data-size”:“medium”,“data-attachmentid”:16419}[/ATTACH]

As you can see I recently purchased an Ender 3 Pro, at the time it was the most affordable printer in the price range I could afford and had the best of the mixed reviews of all the other printers in the same range. It worked reasonably well in spite of some issues that, in one case was never explained and seemed wrong but was actually a nice feature . The reason for the hot end moving off the bed should have been explained in the docs but meh compared to other issues that is a minor one that was made clear in the time searching for other answers to other issues that began after running a sliced file that was apparently sliced for a different machine [prusa I think] and the hot end ran straight across the clips holding the flex plate to the bed. From there it was nothing but problems.

I ran a few of the prints off the m-sd card that came with the printer, the lucky cat and tiny dog printed spectacularly so I printed the heart box and lid, the box came loose at the point and curled up but somehow the print finished, the lid had no issues so it took me a bit to realize the problem with the box. I tried running a print in place water sprinkler for a soda bottle which was wear the real problems started showing. The pint failed and what did print was a mess. I don’t think the settings in the g-code were right, probably meant for a different plastic. I had noticed some issues with the way the spool was feeding the extruder and thought that the constant drag and slip might have been the problem so I set to look for a solution. Having found a lot of vids indicating this could cause problems and links to sharing sites with printable solutions. Most of them required good bearing sets so I found a print in place spool roller with internal printed bearings. I sliced the file with what I thought were the default settings for pla in cura and the print stated off well so I let it print overnight only to find a rather messed up failed print. The sprinkler and bearing set both happened after the cross bed nozzle/clip incident.


The pic of the lucky cat shows how well the 1st print turned out. Below is a failed print in place spool bearing print.


Trying to figure out what was going on I searched for some good slicer settings for Cura, being rather new I followed a vid that tried to recreate the settings the lucky cat used and tried to print a benchy boat, the print finished but was obviously not a good clean print. My last print was an extension for mounting the spool off to the side making it easier for the extruder. The first/second tries didn’t stick to the bed, the very first try came off before the brim was finished and the second got a few layers done before it too came off the build plate. I put a raft under the third attempt and it finished, it had some issues but it worked so I tried 1 more print and it failed leaving a bit of a mess but since I was keeping an eye on it as I was working on other things I stopped it before it got too far and wasted more pla.

After some effort and not making much headway I decided to give the machine a few upgrades to help which is where the next problems started and in spite of my best efforts I have only a rough idea how to fix 1 of them and no idea how to resolve the other issues.

I installed the dual z drive a direct drive extruder kit the cr touch bed leveler and an optional glass plate to use. I got the dual z installed trammed in the z risers and gantry installed the direct drive and cr touch and when I updated the firmware the machine apparently decided it was a much bigger machine because it will try to go well above the z height and off the x by a considerable degree. Also the auto home works mostly right with the exception that instead of going to the center, as the new firmware seems set to do, it ends up noticeably off in both y/x, more so in x than y but both are off. The last problem is with the steps per mm for the extruder. With the direct drive it was initially under extruding by a considerable margin. I figured out how to set it and after a bit of trial and error I finally got it to the exact spmm to extrude exactly 100mm. I saved the new setting, or so I thought, and shut down for the day only to find the new spmm gone and set back to the 93 spmm of the default. I don’t mind editing the firmware to change it and to correct the x-y-z issues but I want to know if I’m missingthe right firmware or if I will have to manually edit the file to fix these issues.

Here is an illustration to show what is happening with the x-y-z


The X (yellow) wants to keep going off the side indicated, the Z (red)wants to go above the top of the frame and the CR Touch is not centered as indicated. Out of curiosity I ran the bed mapping and much to my lack of surprise it started well onto the build plate and ended very near the back edge. I figure it is a firmware problem but im not sure where to get the right firmware considering Creality has 2 sites offering it, being new to all this I have no idea which is legit and am reaching out for more experienced/interactive help than youtube provides.

In hindsight I probably could have fixed the problems I was having without going through the hassle of the upgrades but being new to actually having one of these machines, not knowing where to go for help, youtube not being much help and having the funds to do the upgrades I wanted anyway i opted to kit it out a bit better only to have that fail rather annoyingly in actually helping. I really need help sorting this out, I want to get this machine working right so I can stat doing the things I got it for. As I said at the beginning I have pictures to show how it started and how downhill it went after that errant start with incorrect g-code, I have other pics of the assorted failures and successes but until I get the firmware created problems sorted i cant do anything else and i really need to get this working asap.

Any Help would be greatly appreciated and is desperately needed.