My Latest Experience with my Soval SV04

Scaled a rock bridge to use on my 1/24 scale crawling course. It was a big print that fills the build plate on the SV04 was a 32 hour print. Normally don’t use the filament sensor because it hangs some and causes under extrusion but the spool looked a little sketchy if there was enough filament on the spool. Figured if it ran out I’d switch colors and go on. So I started the print and it was underway it had printed for better than a hour so I went to bed. When I got up this morning and checked on it the printhead was printing away but the filament had run out. Stopped the printer from the screen (printing through octoprint) the printer lifted went and parked. No were not done the printhead move back over the build plate and continued printing still will no filament. It was too many layers above the print job to add more filament. Add this to the reason I hate this printer. Maybe the filament sensor would have worked if I was printing off the SD card maybe not.

oof, that sux. At the other end of the scale, I have used the filament sensor on my MK3S+ several times and it has worked every time. In fact, since I started enclosing the printer I’ve had a few times when blobs have been created on the print and the printer has stopped with a “crash detected” error. It parked the toolhead and waited. I chipped the blob off, clicked “Yes” to the “Continue print?” prompt and it carried on flawlessly.

I don’t say this to make you feel bad. I just want to point out for anyone reading this that there are reasons people pay extra to get something like a Prusa MK3S+. They may cost a fair bit more than many printers but, as is often said about Prusas in particular, “they just work”.

The filament sensor on my Ender S1 Pro works fine, it goes and parks away from the print. You replenish the filament press continue and it goes to the corner and purges some filament and resumes printing. Don’t have Creality firmware on it so it and octoprint share information very well.

You didn’t make me fell bad but you did make me want to buy a MK3S+ but I’m guessing it isn’t in my budget.

How is the filaments sensor of the SV04 connected to Octoprint? I’ve been meaning to try this.


It’s not connected to Octoprint, it’s actually part of Marlin. Octoprint doesn’t work as expected when connected to the SV04 the 2 don’t communicate correctly. On my Ender 3 S1 Pro it works just fine.