Monoprice Ultimate 2 Comments and Bed Leveling

I am a big fan of the Monoprice Ultimate 2 3d printer. As a fully enclosed and fast 3d printer with a direct extruder, I believe it is a good value for the price. This is not a printer you are going to modify or upgrade, it is more of an appliance. The auto bed leveling works quite well and the printer performance and quality are excellent. The printer speed is similar to my Prusa i3 Mk3 and much faster than my Creality Ender 3 or 5.

I started by using the Monoprice supplied version of Cura which I believe was version 3.3 but soon moved to the current version of Cura by manually copying the settings into Cura version 4.4.

The primary limitations of the printer are a relatively small print volume at 200 mm x 150 mm x 150 mm, a print head temperature limitation of 235c, and proprietary firmware. The printer does include support for firmware upgrades and I have done this twice successfully.

The strong advantages of the printer are ease of use, speed, and quality when printing with support filament types.

While the auto bed leveling on the printer has worked perfectly, printing directly on the glass with a bit of MagiGoo, some of my viewers have had difficulties. The ABL requires a properly adjusted print bed and if your printer came from the factory with a print bed that was not aligned properly it will fail. Here is a link to a tutorial on manually adjusting the print bed and then for setting the Z offset.

Please leave your comments below.


DrVax - I did purchase a Monoprice Ultimate 2 printers and had nothing but problems with it. I finally returned it to Amazon. Just a bad experience.

@jackhaen Would you mind listing what some of those problems were? I read a review of a Monoprice printer (forget which one) and the review commented as an aside that Monoprice is known for its quality control problems.


Hi Mr. Shapiro, i just got my Ultimate 2. thank you recommending it. has anyone identified the brand of filament it came with? it prints so well and the off-white color is beautiful.

@Josh_B Congratulations on your purchase! I’m pretty sure Monoprice only ships their name brand filament. The spool that came with my Monoprice printer is labeled “MP Select Premium Plus+ Premium.”


@Alan mine didn’t have a label. i’ve noticed that Monoprice uses different brands and puts a label on them. some are from raise 3D. i have tried 2 colors of the basic filament that monoprice supplies and it was not very good. but whatever Weedo supplied is where i want to purchase from. i contacted Weedo to find out what brands they use.

@Josh_B Interesting. Let us know what they say, and did you try Wiibuilder?


hi @Alan, i did try Wiibuilder and i like it! my prints have come out really good, and i don’t know whether to contribute that to the slicer or the printer. i would like to try Cura because im more familiar with the settings. has anyone preferred one for the other? i will let you know if i hear back from Weedo. but here’s something interesting, if you install wiibuilder from the Weedo website there is a link to buy more filament on Amazon. however, it’s not stocked.

My impression is that Monoprice uses a variety of private label filament manufacturers. This is a bit of an issue because Monoprice PLA may not always be identical. I use Hatchbox PLA and MaterHacker Build PLA as my go-to filaments on the Ultimate 2.

@Josh_B I was not a fan of the Weedo slicer and have been using the latest version of Cura with my printer. Attached is a zip file with my profile exported from Cura 4.6.1. Unfortunately, Cura is very particular about importing profiles between versions. I named my printer MP Maker Ultimate2. Here is a screenshot of the definition:

[ATTACH=JSON]{“data-align”:“none”,“data-size”:“custom”,“height”:“449”,“title”:“Screen Shot 2020-07-06 at 4.57.12 PM.png”,“width”:“800”,“data-attachmentid”:1583}[/ATTACH]

You will have to manually define the printer first and then you can import the profile. First, unzip it and then import the .curaprofile file into Cura. This profile WILL NOT work with Cura earlier than 4.0 and may require the same version I used.

Enjoy. While I find the fans a bit underpowered and the print area size is a bit on the small size, in all other ways I really like this printer.


MP Maker Ultimate2 20 (996 Bytes)

@Irv_Shapiro thank you, i will definitely try it. i actually really wanted to use Cura. you are the first person to ever send me a Cura profile lol.

@Alan i heard back from Weedo. They are very coy about revealing their brands. they gave me a link to a brand called Sunlu on Amazon. i asked if this was the same that supplied your printer with the sample spool. they said: “Yes, we tested Sunlu Pla filament on our printer.” i asked Monoprice and they had no idea. at first they said it was their brand, but i said it was a .5 kg spool in white and they don’t carry that. Actually, Monoprice is currently out of stock of PLA. they said they would get back with me regarding the information.

This is my current set up of the Ultimate 2. i got really frustrated with the door when i was trying to remove the packaging foam inside so i removed it. i felt it was too awkward to install the filament inside so i grabbed some spare parts and made my own spool holder. i had to turn off the filament sensor but its ok. it still prints great. @Irv_Shapiro thanks for recommending opening the doors for PLA prints.

Does anyone know how the leveling actually work? I thought that it give me a digital read-out but apparently the bed adjusts it’s proximity to the nozzle. I manually raised the bed to the highest point and it doesn’t even touch the nozzle. So how would I know if it works?

My understanding is that bed leveling determines the flattest plane parallel (stored in the printer) to the bed, close to the Z-offset of the sensor. What you are experiencing sounds like the same, occasional, “bug” (feature?) in the autoleveling system of Monoprice’s MP10 Mini. The printer sometimes forgets that you have already set a non-zero Z-offset. So, for that printer, one has to first set the Z-offset to zero, then autolevel, and lastly reset the Z-offset (it’s value may have changed from before so start small to avoid hitting the bed like I have!). If you can’t manually level the printer, I’d back off the max height a bit and give that procedure a go. (Be sure to record your current Z-offset.) Maybe Monoprice carried over that ‘feature.’


@irvshapiro1 Hey Dr. Vax. I just recently purchased this printer to give 3d printing a try and I’ve found your videos very informative and helpful, thank you. I was looking to import your customized cura profile for the mpmu 2 but I don’t see the zip here. If you don’t mind sharing the profile again for me to test it out I would be very interested.

I can confirm this. I purchased Fluorescent Yellow PLA a few months ago. Loved the color. So, I purchased another Kg recently when it was back in stock. Same part number, but different packaging, different spool holder, and most importantly–a different yellow! Much darker. It prints fine, but I’ll be searching for another source of fluorescent yellow filament.


Hi all! Many thanks for the excellent tutorial! Might I ask for help with an especially uncooperative Z-axis?

Setup: I’m running an Ultimate 2 with firmware v2.2.8


No matter how I set the Z-axis offset, the build plate stops about 10-15 mm from the extruder nozzle when I try to print or level the bed.

I can use the z-axis offset setting to move the build plate into the appropriate position. If I exit and reenter the menu, the setting will be as I left it, but the build plate will once again stop short by ~1 cm.

I tried zeroing the Z-axis offset, and the build plate plowed into the extruder head before stopping and backing away.

After setting the Z-axis offset (before and after I zeroed the setting), I see the message “probing failed” on the info screen.


  • What does the "Probing Failed" error mean?
  • What's going on with the Z axis?
  • Is what I'm seeing fixable?
Many thanks!

I got probing failed when 1 wire on my BL Touch became disconnected at the sensor – the Z Axis Minimum wire as it turns out. When I reseated the connector, probing started working again. I assume this issue could apply to any Automatic Bed Leveling probe.

i have also Problems for probing.

I did levelling my bed with V1(=165mm). After i did this i go to the Z-Offset. The bed will drive upwards and it will crash into the noozle then it will drive into the middle of the bed and i put a Post IT between bed and noozle (my value is -10mm). The same will happen when i will using V2 (=170mm) but here it will not crash into the noozle but the bed will not go further upwards. When i print something it will do the probing before right. But it will crash again again but it will print my stuff correctly.
I don’t know what happend but two days before it was perfect. The levelling of bed and the Z-Offset Option worked. And before printing he did his Probe testing on three diffent points like what read here.
which wire you mean because the sensor have only one grey cable?
Can you send a picture
maybe same Problem

Best Felix