G-Code USB/Serial Terminal not working with MP Mini Delta V2

When I send a Common Gcode Command, M115, the log displays SENT M115, but that is all. Thank you for your help.

Yes. Unfortunately, the Delta V2 seems to use a nonstandard variation of the marlin serial protocol requiring a handshake that the serial terminal does not supply.

What can be done to solve the problem?

Thank you, Irv.

I am not sure about G-Code USB/Serial Terminal app, or communication connection to Delta V2 being used.

I just tried a USB connection with Pronterface app and it worked. I used a W10 notebook and USB A to microUSB cable to connect to Delta V2. I powered up Delta V2 and used Device Manager in W10 to view COM ports. See COM3 as example, port number is dynamic. The Delta V2 uses a CH340 USB interface chip, and most likely a driver will need to be installed. It seems drivers may be on SD card, but need to be installed on PC.

[ATTACH=JSON]{“alt”:“Click image for larger version Name: comPort.png Views: 2 Size: 113.6 KB ID: 15139”,“data-align”:“none”,“data-attachmentid”:“15139”,“data-size”:“medium”}[/ATTACH]

Attached pictures show using Pronterface. The printer needs to be connected, note baud setting, and use COM# as viewed on your PC. To enable Terminal, click < in blue box.

[ATTACH=JSON]{“alt”:“Click image for larger version Name: pronterface0.png Views: 2 Size: 299.1 KB ID: 15140”,“data-align”:“none”,“data-attachmentid”:“15140”,“data-size”:“full”}[/ATTACH]

Here is M115 command and result.

[ATTACH=JSON]{“alt”:“Click image for larger version Name: pronterface.png Views: 2 Size: 172.0 KB ID: 15141”,“data-align”:“none”,“data-attachmentid”:“15141”,“data-size”:“full”}[/ATTACH]

The CH340 is the most common chip used in 3D printers that I’ve seen, at least in the consumer grade printer.

I checked your original post and you didn’t say what you used to send the M115 command. You mention G-Code USB/Serial Terminal in the title, but I don’t know what that is.

1 thing I can mention: if you’re connecting from a PC of some kind, be sure to not have any other 3D printer-related app running. For example, don’t have Cura and Pronterface running simultaneously. Each will try to lock up the COM port, so only 1 will work.


Our similar thoughts, perhaps suggests there is cosmic consciousness. I was thinking about it earlier today, but had to get my notebook and Delta V2 in same space time, to test and report. :slight_smile:

Another communication issue might involve USB cable, some USB charge cables are not Data cables.

Using Pronterface on Linux, I was initially unable to connect to this printer via USB.

Collectively, these resources led me to a solution:

  • https://mpminideltav2.com/doku.php?id=octoprint:updatech340
  • https://learn.sparkfun.com/tutorials/how-to-install-ch340-drivers/linux
  • https://github.com/juliagoda/CH341SER
Essentially, I followed the 'Other Linux Distributions' instructions from the SparkFun tutorial, which involved downloading the source code for a patched version of the CH340 driver from GitHub, compiling it, installing it and removing the original (broken) driver.

After that, connecting to the printer using Pronterface worked without any problems.

Great work! I hope you have plans to make a compiled version of that driver available for others to take advantage of. Annnnnnd, welcome to the forum.

Thanks Ender5r,

With regards to making a compiled version of the Linux driver available, I do not believe it is trivial. As I understand it, with Linux there is no guarantee that drivers will work between kernel versions, hence, it would be necessary to recompile the driver for each kernel version. If interested, this article explains why: https://www.xmodulo.com/linux-vs-win…ver-model.html

It should be possible for users to automate recompilation for themselves whenever the kernel is updated through DKMS. This isn’t something I have familiarity with, but it is discussed in another article: https://www.xmodulo.com/build-kernel…kms-linux.html