FreeCAD designed part printing over sized.

I am new to 3d printing and FreeCad and as a first project have just had a try at designing a part for my cnc machine in FreeCad and printing it with my Neptuune3.
The shape is simply a rectangle 20x40mm padded to 2mm with two holes for m5 bolts. There is a small raised hollow rectangle along one side of the top surface, that a reed switch sits in.

I have a usable part but have found that I need to specify the diameter of the circles that become my bolt holes as being 8mm as even at 5.5 or 6mm they are too small when printed and the main part has actually printed as 2mm over size in all axis 22x 42x4

Having just had another look at Cura I can see that it does show the size of the object to be printed and it is 2mm greater than what I drew in FreeCAD. There must be something I have not understood or overlooked? Can anyone help with this? Thanks

It sounds like Cura might be set to scale up slightly. You could try using the scaling feature of Cura to size it down by 2mm in each direction.

When you look at the model in Cura, and click on the sizing button (2nd from the top on the left), what does it say for %?

A 2mm bias does not seem scale related. Scale would be different for each axis, that is unlikely.
My guess would be, digital caliper has 2mm offset, due to not zeroed.

Hole size specified might have been for number 8 screw, that is small. I typically use pocket and define hole about 0.2mm larger, in your case 8.2mm diameter.

There is a measure tool in FreeCad, and Cura shows approximate size, lower left corner by title. Gcode can be viewed to check number of layers, and layer height for Z dimensions. Multiply for height.

I’m not sure where a digital caliper comes in. He’s saying he draws it in FreeCAD at Xmm, and Cura tells him it’s X+2mm.

Here is example 20mm is 22mm that’s 1.1 scale factor ; 40mm to 42mm is 1.05 scale factor ; 2mm to 4mm is 2.0 scale factor. Those scales seem unlikely to happen without intention. Turning on caliper and making measurements without zeroing, would be a realistic way of generating same 2mm bias for all subsequent measures.

What do you mean by “turning on caliper”? Are you referring to a physical caliper? Or is there some add-in for Cura called Caliper?Mind you, I still don’t see how it applies, since he’s talking only about FreeCAD & Cura. How it’s adding 2mm in all axes, I’m not sure.

@Looking_out_to_sea, holes printing smaller than specified in CAD programs is normal. Mostly, increasing the hole diameter by 0.2mm is enough to compensate, but it does depend on the printer and how well it’s tuned. I don’t remember if Cura has it, or if there’s an add-in that adds it, but Prusa Slicer and Super Slicer have a feature to increase hole diameters by X amount, specifically to compensate for the normal shrinkage from FDM printing.

Hole Horizontal Expansion in Cura will expand a hole. I’ve used that and it worked quite well. But it bit me in the butt on some other models (which to me were not holes, but interior features) that produced an odd result.

Thx. I didn’t know the name of the feature. And the fact that the feature exists in many slicers goes to show that the problem is very commonplace.

This is a digital caliper. They make measurements with encoder. Before starting measurements, jaws are closed, reset at bottom right is pressed. If that step is skipped, measurements may be incorrect. Similar to home all, on printer. [ATTACH=JSON]{“data-align”:“none”,“data-size”:“medium”,“data-attachmentid”:16121}[/ATTACH]


LOL, I am familiar with digital calipers. I own one. That still doesn’t answer the question about how it is that he creates a model in FreeCAD that’s 20mm wide and Cura says it’s 22mm wide. Physical calipers don’t even come into it at all. How could they: nothing has even been printed yet.

@Looking_out_to_sea I would check your FreeCAD drawing again, very carefully. I have never heard of this behavior from FreeCAD before. Perhaps you should create several models in FreeCAD and import them one at a time into Cura and check the dimensions. To me, something is off.

OP says when printed.

I think this is the critical sentence:

Having just had another look at Cura I can see that it does show the size of the object to be printed and it is 2mm greater than what I drew in FreeCAD.

If the part is 20mm x 40mm x 2mm in FreeCAD it should be the same size when printed. If not the printer needs calibration.

Calibration should be done without printing. Just measuring the axis movement and setting the esteps.

I designed and use this for calibration: 3D Printer XYZ Step Calibration Tool (Customizable) by geit_de - Thingiverse

@Geit, ordinarily I would completely agree with you. The issue here, and I don’t know why it seem so hard to get people to understand, is that Cura says the model is 2mm bigger than FreeCAD. I don’t know how that is possible, but that is what the OP states. So FreeCAD says the part is 20mm wide but, when it’s brought into the slicer, Cura says the part is 22mm wide. I can’t explain that.

As I understand the problem the part is one size in Freecad and Cura is showing it as being 2mm larger. My 1st reaction would be to open the .stl file into a different slicer and see if the dimensions are.correct. You can download PrusaSlicer here In the right hand panel towards the bottom you will see the dimensions of the object once the .stl is loaded.

Agreed. I use Super Slicer, but it’s a fork of Prusa Slicer so, for this purpose, I don’t see any difference.

Well, I guess there is some setting wrong or just showing a wrong value.

I design in FreeCAD using real world dimensions. I calibrated my printer using a caliper and simply load stuff and slice stuff within the slicer it comes out of the printer fine, so there is no problem with the overall sizing.

Maybe some unit issues. e.g. imperial vs metric. No clue. Maybe it is just the size display which is wrong, but I never noticed or experienced a problem with created and sliced files.

HOWEVER: When you download stuff from thingiverse and load it into FreeCAD/Slicer I often noticed that models are off by a factor of 100 or even 1000 in all dimensions. No clue how that uploaders managed to get it that wrong when designing. It simply makes no sense.