Day 2 with new printer and I think I bricked it

I’ve been lurking on several of the YouTube sites for weeks and thought I was ready. So, I’ve got my Ender 3 v2 all set up and started the calibration steps. Got through PID and was trying to do a bed leveling test print. Long story short, my x, y, z servos are all locked up. I can’t switch power wires because none of them work. Any print job fails as soon as it zeros the print head. I have zeroed it out before the PID test, so it must be something I introduced. I’m not sure where to go from here. Any suggestions?
Send: N9 M8216
Recv: ok N9 P15 B3
Send: N10 G92 E0
Recv: X:0.00 Y:0.00 Z:0.00 E:0.00 Count X:0 Y:0 Z:0
Recv: ok N10 P15 B3
Send: N11 G2835
Recv: Error:Printer halted. kill() called!
Changing monitoring state from “Printing” to “Error: Printer halted. kill() called!”
Send: M112
Send: N12 M112
Send: N13 M104 T0 S019
Send: N14 M140 S0
Changing monitoring state from “Error: Printer halted. kill() called!” to “Offline (Error: Printer halted. kill() called!)”
Connection closed, closing down monitor

Well, the good news is the printer protected itself :slight_smile:

Now, how about a really basic test: manually move the printhead a few inches above the printbed & toward the center of the bed. Next use the LCD to try to preheat the bed & hotend for PLA. The idea is to see if the printer will get up to temps without generating any errors.

If that works OK, try and Autohome. Make sure you have your finger on the power switch, in case.

Thanks you your help. I have done that already. The print head is not damaged, it and the bed do come up to temp. And then I did the auto home from the display, I even sent a g code over from octoprint. I can hear the servo just quiver a little, buts that all I get, the display is locked on the auto home page and I can’t clear it until I power down.

I assume you did a G28 from OctoPrint? And, you can move the printhead manually when the power’s off?

Yes all the axis move freely with the power off.

To me, it’s looking like your controller board has some sort of issue. Not sure if it’s hardware or firmware. The fact that all 3 motors died at the same time would tend to indicate a firmware issue. But, if you haven’t upgraded or otherwise altered the firmware, it would tend to indicate a hardware problem. Is there a Reset Settings option in the menues?

There is a Restore Settings, but that doesn’t work. I thought of the firmware also and tried a newer version of Marlin for the stock 4.2.7 board and that didn’t help. I’m thinking hardware too.

So the issue occurred with the stock firmware. In that case, a new board seems like a good idea. Fortunately, 4.2.7 boards are actually quite cheap. That said, you could always try to get your provider to replace it under warranty.

OK, thanks for the help!

Just curious. Can you print from an SD card? It sounds like the printer works using the LCD interface.


No it won’t load from SD. It gets to 18% then the machine freezes up, the LCD is frozen and I have to power down to clear it. It looks like the same from loading from octo pi, it heats everything up but when it starts to move anything it craps out. I didn’t have octo pi running right now, but I’ll bet it generated a kill message and froze.

Did you try printing one of the files that came on the SD card? If they won’t print I would guess the main board is defective. Printer is only 2 days old I would go for a warranty exchange.

I emailed this weekend with my problems, haven’t heard anything yet.

Well, I’m stupid… I was told by the sales dept. this printer ships with the 4.2.7 board. So I had updated the firmware accordingly. I just now double checked my board and it is 4.2.2, downloaded the appropriate FW, and now it is working. And banggood did email yesterday. Just to let you all know, and learn from my mistakes…

Well, that would do it. See, there was some sort of issue with the control board :smiley: Glad you got it worked out.

Thanks for the help