What causes layer shifts?

Can anyone tell me what causes layer shifts? This doesn’t happen every time, but it’s annoying and I’d like to get to the bottom of this issue. Photos are attached. Thank you.

There is no single cause. It could be due to loose belts. Or it might be that a belt pulley is faulty. This could happen if a grub screw that holds a pulley in place has come loose. It can also be because the hotend has run into the print.

The 1st step is to check the printer over: ensure everything is tight and secure. Check that all 3 axes move smoothly, with minimal resistance. Also, make sure there aren’t any missing teeth from any of the belts.

I will try to elaborate on Ender5r 1st step, for the, “why”. A printing starts with “Home”, where limit switches provide starting “Origin”. Then print heads moves to position based on G-code instructions, that involve motor steps, where each step is a x-number of degrees motor rotation. The step is an electrical pulse by motor driver, and that pulse has a limited current, for safety and reliability reasons. If something jams, or provides significant friction, motor is unable to rotate, and steps are lost. Lost steps results in shift, and is not recoverable without intervention. There are closed loop systems, where motor rotation is measured, to insure steps and motor rotation are in sync. They are not typically found in low end printers.

Close observation while printing, with help of camera, may provide clues.

Here is a handy list of causes/fixes from a reference guide I have:

Clear the printing path of your carriages from any obstructions. – Zip tie all wires and loose cords, and maintain a clean printing area.

  • Confirm end stops are in the correct spots and that the frame is built correctly so that when you home the nozzle it is in the furthest part of the corner that it can be.
  • Check for errors in model or reslice if G-code is corrupted.
  • Increase z-hop, turn off combing, use lines for infill to prevent nozzle from hitting the print on large layer heights.
  • Make sure belts are tight enough (but not too tight).
  • Do not over tighten bed corners.
  • Make sure the rods are not dry or that any bearings are broken.
  • Replace any bent rods.
  • Reduce your acceleration and/or speed.
  • Increase or decrease the current going to your stepper drivers (if you are confident the stepper is underpowered).
  • Check to see if your stepper or drivers are malfunctioning or overheating.
  • Make sure your pulleys are attached tight to your stepper motor shaft and cannot spin freely.
  • Replace or upgrade your pulleys.

@Eric_N good points by @KitCarlson. If, for example, the current to the stepper motors is too low (there’s normally a setting in the firmware that specifies the upper limit) the steppers will behave as @KitCarlson described.

Increasing the stepper current only helps with “normal” issues. However it can get dangerous when you make your printer stronger than needed.

Just yesterday I got a new spool of Sunlu TPU. TPU is lightweight and therefor comes on smaller or slimmer spools.

When printing with it, I heard a noice, but did not react instantly. Five minutes later I walked over and I noticed that the entire spool with its spool mount was pulled from its socket and nearly crashed into my glass bed. This was totally my fault, as I did not mount the slim spool centered and the printer pulled through an PFTE Tube at an angle to derail the spool.The spool managed to lock itself within the printers frame, not turning anymore. The direct drive tried its best to get filament and the Y Axis tried to help.

This could have ended very bad, but the Y Asis performed a layer shift and reduced the force on the filament. With stronger motor settings the printer would probably caused damage on itself. At least it would have broken the filament mount tower to untangle the spool and the metal spool axle would have been fallen directly onto the glass bed.

Also keep in mind that more strong steppers mean more wear as the steppers are constantly on fire to keep the positions. If the printer is able to move freely and easy by hand, the default settings are fine. If not use grease or replace bearings. Not work around by using more force on already broken parts. This won´t fix anything.

I checked everything and the gear, belt and everything is tight. I printed another object to make sure or wasn’t the gcode file. I sat by the printer, and I think that the magnetic build sheet is shifting during the print. Has anyone run into this issue?

Cheap magnets loose magnetism when being heated and your bed gets really hot, so yeah it can happen.

Those metal plates are cheap and some are expensive. In the end it depends on what quality you get.

It is only shifting, just get a paper clamp and fix it on one side as a work around. Or print a frame for your printer, so the magnetic bed resides inside.

Yes, some binder clips around the edge of the bed will at least let you know if it’s the bed magnets.

After using some binder clips, I still had some layer shift. Come to find out it wasn’t a belt issue, but it appears that the eccentric nut for the “Y” axis was the issue. There was some play in the bed, so I adjusted the the nut until the play was gone and ran some test prints without and issue.

Goes back to my 1st post: The 1st step is to check the printer over: ensure everything is tight and secure.
Glad you found it. And, now you know to make eccentric nut adjustment part of your regular maintenance. Happy printing :smiley: