Question - Re: Updating Marlin 2.0 on ET5 Pro

OK, as most know, I upgraded my ET5 Pro to Marlin 2.0 via DV’s video … excellent vid
I upgraded using the defaults given during the video and everything works fine

Now I want to add Linear Advance to my system along with a cpl of other small changes
I have all that I need to do in VS Code done and it compiles without errors

I tried to upload to my ET5 and it failed
I copied the srec file to SD Card and tried to update … failed

Do I have to take the back off and use the ST-Link? or is there another way?

Well, to be honest I have no idea, which board you have and what it supports, but AFAIR printers that support flashing from SD card need a “bin” file.

I used AVR dude, from the raspberry pi running OctoPrint as my printer had a boot loader. Here is what I did:…rmware-in-2020

Maybe it works for you, too.

What is an srec file? I agree, updating from the SD card requires a BIN file.

srec is just another .HEX format type.

Thx. Never heard of it. And, yeah, HEX format is great for uploading from Arduino IDE, but not from SD card.

The BIN file is the 1 I always use on my 4.2.7 board. Is the board in the ET5 8 bit or 32?

The Board on the ET5 is 32bit

[ATTACH=JSON]{“alt”:“Click image for larger version Name: 20210131_032343.jpg Views: 0 Size: 2.44 MB ID: 8161”,“data-align”:“none”,“data-attachmentid”:“8161”,“data-size”:“small”}[/ATTACH]

This is what I am getting when I try to update

Trying with the .bin files just gives me … SD Card Init Failed … on power up

Updating is not important, I can live with what is currently on there
Just that I would have liked to add Linear Advance

That sequence is with the srec file? It seems like it’s starting the update but finds something it doesn’t like. You’ve tried another SD card?

The problem is not the card (probably) it seems to be the format. By default e.g. Windows is using a format that suits the size. FAT32 is the most waste full format, here, but this is what you want. Don´t mix it with xFAT.

That is something completely different and specifically made for USB sticks and SD cards, but the printer cannot handle it and they probably never will be as Microsoft wants money if you use a version that is able to write to cards.

FAT16 is also an option, but tricky as well. You need special tools to format them. I remember Fat32Formatter on Windows was a thing.

Just a side note. The type of sd card is also important. They may look similar, but they are completely different devices.

Currently there are four different types available SD 2MB to 2GB of size. SDHC 4GB to 32GB in size. SDXC 32GB to 2TB and the SDUC version which is up to 128TB. Since these cards usually are connected to chips, they are not future compatible. That is why old cameras don´t work with bigger cards. It got designed that way.

A 3d printer may work that way, if the SD cards is connected directly to the CPU, but then all standards must be handled by the firmware, which is unlikely.

To make this even more complicated. It is even possible to create SDXC cards with 128MB of total size. It makes no sense, but some Chinese companies create those.

Thats why you should not mix the cards and always use the card which came with the printer. And it is the only reason all boards get delivered with a card. SKR boards for example come with a funny 128MB card, which is just enough to store firmware and a hand full of sliced STL files, but it guarantees the user gets it up and running without getting into the SD card compatibly trap in the first place.

I agree with @Geit about SD cards. FAT32 is, by far, the most compatible, which is no doubt why it seems to be the most used. exFAT is the least compatible, at least in my experience. NTFS is also not used much, although I’ve found it is1 of the best for reliability & performance.

@Geit, do you know what format the SKR card is? More importantly, do you know what format(s) SKR boards will accept?

I’m not against the idea of sticking to the card that came with the printer/control board, but, SD cards do fail (more than most other forms of storage I’ve used). I’ve recently done a number of firmware flashes to my Ender 5, most of them to upgrade to Marlin 2.x & BL Touch support. To format the cards, I took the advice on the OctoPrint web site & used balenaEtcher. So far, It is pretty quick, easy to run, annnnnnd, it works: [U][/U]. I have an SKR board sitting on the shelf (ready to install once I’ve printed the Ender 5 replacement electronics cabinet designed by Michael Laws @ Teaching Tech). I will have to see if SD cards formatted by balenaEtcher will work in the SKR.

Just check with mounter on MorphOS: It seems to be a MBR layout with FAT16 the fat code is 6.

But I think it does not really matter as the file system itself is most likely compatible. FAT32 is just an extension of the original FAT. Since arduino and stuff use the same formats for ages, I think it is save to say it just needs to be any FAT file system. Maybe it does not like the non MBR format often used by usb sticks as they don´t need multiple partitions.

FAT16 isn’t bad per se. The 2GB limit isn’t all that onerous. If it takes FAT32 it should take care of just about any situation related to 3D printing.

OK so I am going to have to start afresh with this Marlin Build
I ran into a small issue yesterday as I ended up with a clogged nozzle
Went to do my usual Heat to Max and push thru

I have always believed, when installing new firmware, to load the defaults. So I know it works, at least
I followed DV’s vid, but after these issues, I realise the defaults in that vid are for the ET4 … my bad for not looking deeper

I found this out when I tried to unblock the clog.
My hot end won’t go above 240 C
I also found that the clog had backed up into the heat break as well.
I managed to clear it out. Luckily I was using PLA so at 240C I was able to push thru the break with a 2mm x 100mm allen key.
Having removed the PTFE tube and nozzle

This gave me the opportunity to change out the nozzle for a better one
I now have a E3D NozzleX 0.4mm fitted snug and tight

Once I have flashed Marlin again, I just need to work on the Y axis.
Still getting a shift, even with new belt fitted

I am determined to get this printer working properly


I have found out why it wouldn’t update as shown in the previous photo
The “At location 080000 …error” Message

When following DV’s Video
There is a piece about Platformio.ini
And a line that needs the “REM” removed …

#board_build.offset = 0x10000

GUESS who forgot to remove it (the #)

My printer has now updated and, so far, looks to be working as normal
And YES, I now have Linear Advance available

This is getting weird …
ABL Sensor isn’t triggering on Bed Level
It triggers at Home and on the 4 corners
But when I run level bed with the mesh, it still triggers at home and 4 corners, but doesn’t trigger at any of the other points (5 x 5 mesh)
Instead it pushes bed down, until it reaches the reset point