Problems to follow a step in lesson 2 in DrVax channel

Hello, my first post here!

I have completed lesson 1 in DrVax youtube channel, but when I tried to complete lesson 2. I got stuck 10:22 in the video. Here is a link to it.


I got the error message “Pad: Result has multiple solids. This is not supported at this time” I am using 0.19 beta version on a 64-bit Windows 10 machine, Ryzen 3700x, 32 GB RAM, a hundred gig of free disk drive space. I do not know what is wrong? I have tried to follow the steps 5-6 times without making the second part solid.

What could be wrong?

Here is my report view log.

14:19:38 TempoVis.restore: failed to restore detail (‘SDVProperty’, ‘Namnl__s’, ‘Sketch001.LinkVisibility’): ‘NoneType’ object has no attribute ‘ViewObject’

I just ran across that error message yesterday when I was working on one of my designs. Sometimes FreeCAD’s error messages are misleading, but I think that error message describes exactly what is going on. The pad you create needs to touch the active body. The problem is probably that you neglected to add the body at the 10:02 mark in the video.

Hello, I am not sure what you mean “The pad you create needs to touch the active body” I did create a new body in 10:02 mark in the video. In the XY-plane as the video described and it looks exaclty the same in my program as in the video.

The active body is the body that is shaded in the model panel view. If you look at the 10:43 mark, you will see that Body001 is shaded.

Here is a quick illustration. If I create a body and pad it, then create a second body and immediately pad it, everything works correctly:

[ATTACH=JSON]{“alt”:“Click image for larger version Name: Screen Shot 2020-12-31 at 2.40.16 PM.png Views: 0 Size: 127.1 KB ID: 7445”,“data-align”:“none”,“data-attachmentid”:“7445”,“data-size”:“medium”}[/ATTACH]

Note that Body001 is shaded, meaning it is the active body.

However, if Body is somehow the active body at the time that I press the pad button in the toolbar…

[ATTACH=JSON]{“alt”:“Click image for larger version Name: Screen Shot 2020-12-31 at 2.41.10 PM.png Views: 0 Size: 152.5 KB ID: 7443”,“data-align”:“none”,“data-attachmentid”:“7443”,“data-size”:“medium”}[/ATTACH]

… then I get the error you described:

[ATTACH=JSON]{“alt”:“Click image for larger version Name: Screen Shot 2020-12-31 at 2.40.48 PM.png Views: 0 Size: 182.1 KB ID: 7444”,“data-align”:“none”,“data-attachmentid”:“7444”,“data-size”:“medium”}[/ATTACH]

Note that Body is shaded rather than Body001.

Perhaps you accidentally made Body active by double-clicking it. If so, double-click Body001 to make it active then try doing the pad.

Another possibility is that you closed the document and reopened it just before doing the padding. When you open the document, no body is active. Again, the solution would be to double-click Body001 before trying to pad.

Hello, I have selected the wrong body in the treeview instead of the modelview. So that was the problem, many thanks for helping me with very good illustrations!!

Happy new year :slight_smile:

I’m going to have to learn some Freecad one of these days. Tinkercad is fun but very basic.