Totally frustrated by Freecad

I am flummoxed. I have been working on this design when i must have done something to upset Freecad. I can’t get the part to display. Everything was fine, then poof! Moving the mouse wheel, along with everything else i can think of is not working and i am at my wits end. Other files seem fine. I cannot figure this out. I attached the freecad file. I am sure it is something obvious.
RPI Dac rev11.FCStd (169.9 KB)

As a neophyte in Freecad, tried the following.
I loaded it and in the ‘labels and attributes’ box started clicking on the lables and hitting the space bar. For no particular reason started at the bottom and worked up. Got to the top and all of a sudden the case appeared. clicked on the ‘fits all’ icon in the top bar and there is your model!
Hope this helps as I also learned something.


Learning Freecad has a definite steep learning curve. Once I got some of the basics down I really like it. It provides everything I need a cad program to do to build 3D models. I have learned a lot from a Freecad YouTube channel called MangoJelly. I suggest you browse his beginner videos he has and 'play around.

Thank you all. I knew it was somthing obvious. I must of hit the spacebar unwittingly at the wrong to make it disappear. I will take a look at MangoJelly. I have tried other cad programs, such as OnShape, but keep coming back to Freecad. It can be frustrating ot learn its quirks, and the occasional bug that you run into.

You Body ( Case001) was hidden as stated above highlight and press the spacebar. Hiding it can come in handy too if you want to for example start another body for another part and don’t want the original one in the way.

Just remember we all learn from our mistakes, that’s part of the learning curve. MangoJelly is a great channel to help with the Freecad learning process. Also a great reference when trying to figure out how to do something.