Printer not recognizing finished print.

I am having a problem with my Artist-D pro. When I finish a print and am finished for day or night or for a short period, I turn the printer off like manufacturer recommends, but when I turn it back on it thinks that there was a power failure and wants to resume the print. At the first couple times, I just canceled and choose the new print and resumed with the new print. This began to aggravate me and I first did a reset. This did not help, so I told it to resume like it wanted to do. It warmed the table and nozzle and then started a new print. I mostly did not want this so I had to cancel. I tried a reset again and still it wants to resume then start new the last print. Has anyone experienced this and how did they resolve. The only other option I can think of is to re-load the last marlin file. I do not have a problem but I really do not want to do this and not have it work.

I’m just guessing, but perhaps the printer is expecting some GCode at the end of the file to tell it it finished successfully.
You can add GCode for start and finish in the slicer. By any chance did you make any changes in this area?
If not, perhaps adding “M413 S1 ; enable power loss recovery” to your start gcode and “M413 S0 ; disable power loss recovery” to your end gcode would do the trick.

@vankichline Thanks for the imput! I have tried several things except the Gcodes you listed, and I know just where to put them. I did find out that if I turned the printer on withe the SD card out of the slot, when turned on it did not do the resume message. With this in mind I shut the printer down, added the card and turned back on. It repeated the same thing.
One more thing, when the print finishes, I have to press a button that tells the printer I acknowledge it has finished before I can do another print. I also read in your statement that you are suggesting that my slicer (Cura) has been glitched. I am using 4.11.0 where there is 4.12.1 and 4.13.0 beta is available. Maybe I should update.

From my experiencr, 4.11 had issues. So far, 4.12.1 has been good for me. And, yes, I have the same acknowledgement message on my Artist D when a print job is finished.

I have 4.12.1 downloaded, just have not set it as default, so when I choose a stl it goes to 4.11.0. I will put the suggested Gcode start/finish first and see what happens.

Well it seems, even though I have put the Gcodes that @vankichlineoffered, it still gives the message resume last print. The printer has had several models with the new coeds in Cura at the machine settings start Gcodes and end Gcodes. Apparently it is a glitch in the machine memory and will need to be re flashed. Not sure about doing that until I finish some projects.

Sorry I steered you wrong last time, but I’ll offer one more wild guess (since no reasonable plans have emerged.)
You discovered that the trigger is on the SD card; my guess is that there’s a file containing the last known print state and that file needs to be deleted to avoid the power failure behavior. Either your printer doesn’t try to delete the file, or it expects to delete it but fails for some reason.
Have you tried another SD card? Try a smaller rather than larger card, and make sure it is formatted FAT32.
If you are hooked up so that you can see the serial output from the printer (Pronterface of Octoprint or such) does it display any errors at the end of the print? If so, they may provide useful into.

It sure sounds like there’s a firmware issue.

The file on the SD card may be hidden so check for hidden files

We can call this problem solved, thanks to @Gramps
It was not a hidden file but a file named PLR. It would not let me delete the file so I had to remove all gcodes to a temporary file on desktop and format SD Card. I replaced the filers and tested. Good to go!!! ! ! ! ! !
I will watch to see if file returns in future.

Well! I was wrong, the problem is not solved. Twice now after turning the printer off it has replaced the PLR file and it cannot be deleted. I have pulled saved files and active files off into a temp folder and re-formatted the SD card.

The last time I locked the SD card so the printer cannot write to the card. After thinking about the possibility of power loss, I think I will after the current print, I will unlock and try to remember to pull the SD card before turning the printer off.

Another think to remember is that the printer does not remember where it was and starts the print over. No filament or time saver!
I keep procrastinating about re-flashing the firmware. I guess I need to do that!

Just finished a print with the SD Card locked and it (printer) still placed the PLR file onto the card. Printer was not turned off.

Have you tried printing over USB from a computer, with the SD card removed?

With a file appearing on a locked SD card, that sounds diagnostic. The SD card has to be damaged. I would say both its lock and delete functions are failing. Reformatting won’t help at this point.
Try another card, if not now, eventually. Stick to no larger than 8GB and make sure its formatted FAT32.

maybe the printer needs some insulin :wink:

I often have trouble when I need to abort a print and it keeps trying to print the last print. I could usualy get back to normal by doing a CHEP bed level g code and then I could continue.

@Ender5r I really wish I could remember the plugin. If I could I would have mentioned it in the previous comment. All I remember was that it worked with “robin” motherboards which the Artist-D pro has. @Irv_Shapiro mentioned the plugin in one of his videos on Cura.

I wonder if it only works on Artist D. Three times faster?

@Ender5r That appears to be the plugin. I have it on my Cura 4.11
@roon4660 I do not know what to tell you, I do not think @Irv_Shapiro would address this plugin if it was only for the Artist-D. He stated that it worked with MKS Robin TFT35 or MKS TFT35 LCD. I think that covers a large number of motherboards. As to being three times faster, I think my first flash of the firmware had some problems, one was the finish print every time the printer was off and turned back on. The slow update of the picture of print on LCD screen. There was another interment problem which has not shown up since the last flash. Something to put in the back of my mind. DO TWO FLASHES!

Yes, I believe that plugin is only for MKS boards. That does limit its applicability but it’s still something MKS owners can use. I’m not sure I would find it all that useful 'cause I’m not normall at the printer where I could see the LCD screen.