Artist D nightmare with dual color

Been trying for two days to get any dual color print to work on my new Artist D Standard. I am using Idea Maker for the slicer.

Either E1 or E2 at any given time will just stop when it gets to the end of its turn printing its layer and instead of returning to its home position and it will just sit there till the other extruder comes and collides with it.
Last print I did E1 layer 1 printed fine, it moved back to home and a second or two later E2 moves into position and starts its layer all goes well till its done with its layer and instead of moving to home so E1 can do its next layer E1 just crashes into E2 and starts grinding, at which point I quickly turn the printer off.

I am using a Full Control profile I got from the JG Artist FB group and everything seems to be ok with it,except when it comes time to print and the extruders will not home correctly between layers/colors.

Here is my Extruder Switch Code, and the firmware version I am using is Twinkie.2022.2.2.

Any help would be greatly appreciated.


G0 Z2 F1200


[if {new_extruder}=1] G1 X-62 F{travel_xy_speed}

[if {new_extruder}=0] G1 X373F{travel_xy_speed}

[if {new_extruder}=1] T1

[if {new_extruder}=0] T0

G1 E2 F120

;[if {new_extruder}=1] G0 X363 F1000

;[if {new_extruder}=0] G0 X-52 F1000

G92 E0

G1 E-{extruder_switch_retraction_amount1} F{extruder_switch_retraction_speed2}

I don’t have time to dive into the issue deeply, but my own 1st thought would be to revert the printer to its original firmware and try again. I would also raise it as an issue with Twinkie. He may well respond.

Ok, I will give that a try. But should I go back to the first version 1.1.2 or the one they released in April of 2021?

If you had success with the apr2021 version, I would try that. Heck, try them both. Do it on a small test piece. The idea isn’t to get a perfect print – not at this point. The idea is to identify where the issue lies. Is it firmware, or not? If it is, then which version or versions? Finding which version(s) are causing problems would greatly help Twinkie find the issue and resolve it.

Same issue with either of the other two original firmware’s. So it has to be an Idea Maker issue or I guess possible a hardware issue of some kind.

That makes sense. The slicer is the easiest to check. Why not try printing the duplication mode gcode file that comes with the printer, see if the heads behave properly for that?

I will try those but it’s basically a very similar thing I am trying to print.

Tried to print this, did the same thing once the white finished on E2 and it should have moved away and then E1 finish the last orange layer it just sat there till E1 crashed into it.

Hmmm, seems like there is something wrong with the printer. Can’t help beyond that.

Did the printer come with any 2 color presliced models? If so try printing one of those. That will take the slicer out of the picture.

Only two color is the T shaped one in the image above, you basically set each part for a specific extruder, do a “Align Selected Models” and then slice.

@Gramps, the T shaped model in post 8 above is 1 provided with the printer. It’s a gcode of a 2-color model designed for aligning the 2 extruders.

The picture above looks as though it was in a slicer so that was the reason for the suggestion.

Glad you talked me out of buying an Artist D Index.

I sorted it out. It was a slicer issues, but only because I used some templates provided by other owners and for whatever reason it caused issues.

Good to hear. Your experience might help someone else who reads this thread.

I just removed all the Extruder Switch code, and in my start GCode at the very top I put M605 S1. problem solved.