Pesky Extruder skipping...

I have a question I’ve not seen on here yet. I have a relatively new Ender 3 pro that came with a Creality all metal extruder upgrade. I have printed a bunch on it over the past few weeks printing storage drawers for the printer and a new spool holder as well as some other accessories and then started printing out some lithophanes and holder boxes as gifts for Christmas. While I was printing those, I started to notice that the Extruder was starting to skip steps, making that dreaded clicking noise. I thought I had a clog, so I ran through the procedure to clear the clog. I removed the hot end and disassembled it. I ran the bowden tube all the way through it to make sure no clogs in side the cold side and then after making sure the hot end was clear, I put it back together with a new nozzle to eliminate any clogs in the nozzle. I made sure the bowden tube was cut square and seated firmly both in the hot end and also the extruder. After all that, I tried printing again. It was printing, but I still heard the extruder skipping. This was not only on the first layer which would indicate the nozzle was too close to the bed, but also on subseqent layers. It did not skip all the time, but only some of the time. I also tried moving the extruder gear a little on the shaft in case the teeth were worn. The prints actually came out fine and I figured I’d live with it till after Christmas when I was planning to install direct drive and a new Capricorn Bowden tube, thinking that would fix it. Today, I did all that. With the hot end disconnected, I calibrated my esteps. That worked fine. With that done, I added the hot end, made sure the tube was seated firmly on both ends and loaded the filament. If I use the control panel and extrude 10mm at a time, it comes out of the nozzle in a nice stream and it works fine as long as I wait a second between 10mm bursts. However, if I try to extrude 100mm at a time, it will start skipping and under extrude. I’m not sure where to go here. I was going to upgrade to a dual gear extruder as well, but the coupler where the filament comes out of the extruder was offset compared to the original metal extruder that my printer came with and as such, it would not work since it would not line up with the hot end coupler. I was bummed. Any ideas where to go from here to get my extruder to quit skipping? Thanks in advance, and sorry for the long post, but I wanted to make sure you knew what I had already tried.

I had my own run-in with a skipping extruder a couple of weeks ago: Ender 3 V2 has started under-extruding on me - MakeWithTech Community Forum

In my case, it was a clog that finally freed itself randomly after a filament change. I changed the Bowden tube to new Capricorn tubing and when I had the Bowden tube removed I did the best I could to clean the hotend with the wire tool that came with the printer. After sticking the tool all the way through the nozzle and hotend several times cleaning the wire between each pass, I still had the clog. I don’t know why it cleared when it finally did, but it was an immediate change.

The other thing I found that I needed to fix is the screw on my extruder that compresses the spring. It had come loose. I screwed that back in to restore the full pinch force on the filament. You might check that on yours.

I feel your troubleshooting pain. I’m certainly not an expert on removing clogs, but my printer was as good a new once I finally cleared mine.

Yeah, there is probably a gap between nozzle and heatbreak within the heater block.

Filament is burning and slowly shrinking the diameter the filament can flow though. In the end you will get a clog and prints will fail.

This usually happens when the assembly was done cold or was done the wrong way.

I am about to change my Bowden tube to the Capricorn tube.
So do I make sure the hotend is hot before I begin?

I have checked the gap when I put it all back together. There is no gap at the hot end or the extruder end. I had to cut my bowden tube about 4 times to get it exactly right. I cleaned out the entire path and put in a new nozzle. It almost seems as if it is trying to extrude too fast? As I said, I can extrude 10mm at a time all day and it works fine. It’s only when I try to extrude larger quantities as in when you are setting the esteps. I’m stumped at the moment as to what is causing the skipping. And to answer the previous question from another poster, yes, it is always better to make sure the hot end is at temp before assembling it. Must be careful, as you can get a nasty burn, but that’s the best way to assemble it all together.

The gab is inside the heater block and not visible. The nozzle needs to be screwed fully in, loosen a little, then the rest needs to be assembled, tighened and heated up and the last step is to tighten the nozzle.

Depending on the printer you are using this may be a little different, but fact is the nozzle is always last and need to be tightened in hot state. This way the nozzle pushes against the other parts of the hotend closing the gap and fixating the heat break, which usually cannot be tightened without damaging it.

Hot assembly is required to compensate for thermal expansion. Doing it differently may work for a while, but causing trouble in the long run. Like skipping steps, clogging and leaking plastic.

Probably because it starts to clog and when you extrude larger quantities of filament the hotend gets cooler faster, the filament less viscose and has trouble to flow through the ring of ash already piling up inside the hotend. In the result the extruder must push harder to full fill its job and fails sometimes, which is the skipping you hear. 100mm of filament while estep extruding should go right through without any issues unless you have insane extruder speeds/steps set.

Thank you for your reply. My apologies. I should have worded that differently. The gap I was referring to is as you said. When I was putting it all back together, I checked to make sure the bowden tube was seated firmly against the hot end nozzle and also on the other end. I suppose it could possibly be another clog, but with a new bowden tube, and a new nozzle and after pushing the bowden tube all the way through the hot end during the cleaning process, I’m honestly not sure where the clog could be. I wondered about the extruder speed/steps setting. I have a bigtree tech 32 bit motherboard and the touch screen on my printer. Maybe I should check to see what the speed of the extruder is set to. I was thinking last night that if the extruder is trying to feed too fast, then even if the esteps are calibrated correctly, it would still jam up and try to overextrude. Are there any videos for making sure the extruder speed is calibrated to the print speed, etc? I know the print speed can be changed. If you change how fast the printer prints, it would stand to reason that the extruder would have to extrude faster to keep up, so there must be a setting for that somewhere.

The option you are searching is in the slicer and called “Flow rate”. The flow rate only can be correct, when the e-steps is correct of course.

@pyromelzar, what software are you using to conduct the tests? I recommend Pronterface, and I know quite a few other members use it. When I test filament extrusion with Pronterface I most often extrude 100mm of filament at a feed rate of 100 or 150 mm/min. If that doesn’t feed freely I know there is a problem. My last problem wasn’t truly a clog; it was a case where the heat of the hotend actually caused the Capricorn tubing to contract or shrink in diameter: [U][/U]

I was actually just using the control panel on the front of the printer. I just clicked the button several times to feed more than 10mm at a time. I also tried using Octoprint control to do the extruding. Same result both times. I’ll look at the extrusion speed and see if that does anything. Thank you all for your suggestions. It’s just puzzling since it was working so well for a while and then seemingly overnight it started messing up. Then it’s been nothing but a mess since.

Yeah, the point is it does change over night, when your hotend diameter is shrinking due to burned filament got stuck inside.

You may get away with it for a while, when you increase temperature, but in the end it gets worse. I was lazy with my TronXY and did this. It worked for around six month, when I ended up printing PLA at 235°C. Then from one day to another it finally was over. :smiley:

If you’re sure you’ve got the hot end done correctly: nozzle tightened at temp, and the clog cleared-out at temperature by flossing it out with your ptfe tube, then the next thing to check is the extruder. Make sure the spring has the right tension, the gear isn’t slipping on the shaft, and the idler isn’t too tight or loose, causing the filament to have more friction. You should actually try to do an e-step calibration with the bowden tube completely disconnected also (so the filament is just exiting the extruder). That’s actually a more ‘pure’ way to calibrate e-steps, since it takes out the hot end as a variable. If you’re still getting skips with this, then you know something is wrong with your extruder and not the hot end.

I can see the idea of doing an e-step test by disconnecting it from the Bowden tube & hotend. As @Zardozer says, if the extruder skips in that configuration, then there is a problem with the extruder. However, I would not use those values in production. The Bowden tube & hotend will almost certainly affect the extrusion of filament. After conducting the standalone test I would redo the e-step calibration with everything connected.