Odd under extrusion on left side of bed

Hey folks,

I have a strange situation and am wondering if others have encountered this.

I have an Ender 3 Pro running a BLTouch and a dual Z lead screws using a timing belt. I run a 25 point mesh bed level before each print after heating both the bed and hot end to operating temps. Lately I’ve been printing some larger models that have portions of the model along the left side of the build plate. When printing the walls and infill on the left side it is definite under extrusion. After a couple layers it’s all OK.

I looked for loose hardware on the left z screw, coupler, oldham bearing, but I feel no play in any of the components. The X Gantry, especially the left side, is not loose and the rollers are firm but not tight. I feel no wobble on the build plate either up or down or sideways. The hot end carriage has no play or wobble and those rollers are firm as well.

It’s been maybe about 4-5 months ago I started seeing this. My models generally are small and occupy the center of the build plate so it’s not been a big deal. I’d like to get to the bottom of it.

Anyone have an idea??

The only thing I can think of is the X gantry square with the printer frame. With twin lead screws it should be but you never know. Might be worth checking.

After years using an Anet A8 and wishing I could have auto leveling, I bought an Ender 5Pro.
I still do manual leveling because it’s not that difficult with the Ender 5.

I would suggest you check the bed manually after the auto level is finished. If the nozzel is too close to the bed it will under extrude. The left side might be too high.

I have seen the same problem when I skipped or too quickly leveled and started. I have no idea how you would correct the auto level if this is the answer.

Sorry, forgot to mention this can also happen to metal beds. Metal warps in subtle ways. Glass bed toppers are cheap and solve uneven serfaces.

I have a glass bed. I was thinking about trying it. The PEI I’m using has been wonderful.

I’ll give it a shot and get back.

OK glass bed make no difference.

It is interesting this ‘under extrusion’ only occurs on the left side of the bed in three places - towards the front, about the middle and towards the back. No place else on the bed shows this - at least from what I can tell. Spacing wise these ‘spots’ are about 70-ish mm apart - that is about the circumference of the Y-axis POM rollers. And I notice when I manually push/pull the bed I feel resistance that sort of corresponds with that observation. I’m wondering if one, or more, of the POM rollers has a flat spot that somehow manifests itself in this manner (ie moves the build plate further from the nozzle momentarily in those locations). I wiped the crude off the POM rollers and wiped out the V-groove on the extrusion with no change. I think I’ll replace the rollers and see what happens. For now I increased my Z Offset by .06mm and that helps.

I had a weird experience with under extrusion when using TPU but not with PLA. After sitting and watching the print for a while I discovered that the filament was hanging in the filament sensor. Bypassed the sensor when using TPU and it was fine. This happened on my Ender 3 S1 Plus.

With that said I would sit and watch the print and pay especial attention to the hotend and filament path when on the left side.

I had the same thought too. I print from a dry box to the left of the printer. The dry box uses a 6mm reverse Bowden tube to the top of the extruder. When the nozzle is to the far left there is a curve on the PTFE tube and I was thinking it was possibly to much drag. So as a test I took the filament out of the dry box and put it on the spool holder directly above the extruder and reran the gcode. Still had the same results. Darn

I should mention I run a Micro Swiss Direct Drive all metal hot end.

What happens if you put the hotend in the problem spot manually or using Ocotprint then extrude maybe 100mm of filament does it flow freely? What happens if you move the hotend left or right several mm while it’s extruding?

1 Like

Well, I might have found my problem…

The under extrusion (or I feel in this case the mesh bed leveling results for the left side) was from the nozzle being a tiny bit to high causing the issue.

It was interesting that it only seemed to occur on the left side generally directly above the two left side bed leveling screws and then at a point in the middle of the bed on the left edge (and in line with the bed leveling screws on the left side).

The spacing was around 70mm apart which roughly corresponds to the circumference of the Y axis POM wheels.

I replaced the POM wheels and while the bed was torn apart replaced the yellow bed springs with silicon spacers. Two POM wheels had a good deal of wear so I was hoping I found the issue.

Ran a test and no change. Bummer

So I thunk on it some more. There may have been margaritas involved too. I came up with an thought. I use a 5 point bed mesh level. The first point checked is the front left corner then the hot end moves to the right for the rest of the first row measurements returning to the left in the second row and moves back to the third row (now the middle of the bed) and moves left again. And same scenario on the fourth and fifth row.

Ahhhhhh, the BL Touch probe is mounted to the left side of the hotend and when the hotend is to the left side of the bed the BL Touch ribbon cable is real close to the extruder motor (I use a Micro Swiss NG direct drive extruder and the motor is directly above the BL Touch).

I digress. I remember a couple years ago I was getting random beeps from the printer during printing. This was at the time a stock Ender 3 Pro. Googling indicated that wrapping the ribbon cable going between the mother board and LCD board with aluminum foil can fixed it. Apparently it was some electrical interference. And it did.

So I thought maybe the BL Touch ribbon cable is picking up interference from the extruder motor even though it is not extruding, but perhaps the motors are energized??

So I wrapped the first six inches or so of the ribbon cable in aluminum foil and ran another test. And the under extrusion is gone!!

Bonkers huh?

This is the hotend of the Ender 3 Pro showing the Micro Swiss NG extruder. The BL Touch is on the left. I print through a reverse Bowden tube from a dry box. The grey gizmo in front of the hotend cooling fan is a bracket for a dial caliper to tram the bed. Notice the Rube Goldberg contraption that the BL Touch ribbon cable is suspended on. When installing the NG I found if I strapped the BL Touch ribbon cable to the same wiring loom as the extruder motor cable the BL Touch would not work. So I made the zip tie stand-offs to hold it away from the cables.

You can see how close the BL Touch ribbon cable is to the NG motor.

Here the tin foil shield is installed. I found I needed to remove my propeller before it got knocked off by the cable. But it appears my under extrusion issue has abated.

So that’s my story of a self inflicted wound…


Bl-Touch interference didn’t even cross my mind but now that you mentioned it, makes sense. I had all kinds of trouble with a BL-Touch on my Ender 3 v2 not like yours but the BLT would error out 4 out of 5 times. Tried 3 different units and finally gave up and bought an EasyABL and all the BLT issues went away. As I recall the startup GCode for it turned off the extruder heater to help with interference. Bottom line glad you got it figured out, I’m sure the margaritas help with the diagnose. :slight_smile: