Help. My printer just developed a mind of its own.

I’m doing a project right now with sunLU wood filament. I tried the temp @215C, which is right in the middle of the manufacturer’s range of 200C to 230C. It came out stringy. So, I printed a temperature-stringing test tower & found the ideal temperature on my setup is 180C.

That leads to my issue. When I tried changing the temperature to 180C and print my test model, I noticed that the printer suddenly changed the temperature to 230C. I don’t know why it’s doing this.

I tried 3 times in a row & it did the same thing each time. I looked at OctoPrint’s Terminal window & could not find only M104 S180 & M109 S180 command. I even copied the contents of the terminal window to Notepad++ and searched for other M104 or M109 commands. There were none.

Finally, I used the LCD screen to override the temperature & set it to 180C.

The real question is, what the heck could be causing this? My understanding is that the firmware only does what it’s told to do. How is the printer overriding the gcode commands?

Did you try printing the file from the Sd card taking Octoprint out of the picture? Did you search the gcode for M104 or M109?

No, and yes. I actually downloaded the gcode file from OP & searched it… nothing that changes the temp to 230C.

Stupid Question: Did it raise to 230°C or did the “should be” value go to 230°C?

I guess you mean the current temperature was that high, which indicates that your temperature sensor on the hotend is loose or not in contact with the heater block. There is an air cushion, which delays the reports. The printer things it is 205°C, so it turns on the heater. Then due to the rattle of the print head the thermistor gets in contact and reports the real temperature, which is 230°C, so the heater gets turned off again. This can give all sorts of random results.

With OctoPrint you usually see a visual wave instead of a temperature line with a pixel up or down, when the sensor is hovering in mid air.

The temperature set commands will not be set unless you have a Cura plugin or something left from creating a temperature tower or so. It is more the opposite that when connecting with OctoPrint it usually resets the values to zero. Unless again you installed some OcroPrint plugin that is messing with your gcode while printing.

First, the should be temp went up to 230C. It was set to 175C in the G-code. Then, after telling either OctoPrint or the printer itself (printing from the SD card) to begin printing, the temperature target on the LCD changes to 230C & the temp begins to rise to match.

There doesn’t seem to be any indication that the printer can’t set or hit target temps.

I’m beginning to wonder if I need to check the Marlin code itself, to see if there is, somehow, a setting that gets buried in the compiled firmware.

Problem solved. Last night I decided to find out why my wood filament was stringing so much, so I printed a stringing/temperature tower. In Cura I used ChangeAtZ 5.2.1(Experimental), which is located in the Extensions/Post Processing/Modify G-Code/Add a script, to add temperature changes at various layer numbers. It worked like a charm in that I found the perfect temperature for the filament. My current puzzle is why I didn’t find M104 or M109 entries in the g-code file. Further investigation is required.

Out of curiosity, what temperature did you choose?


Well, in a way, the mistake was a blessing. It re-educated me to the idea of using a higher temp for the initial layer and a cooler 1 for the rest. So, for this project, I settled on 230C for the initial layer and 175C for the rest. The print adhered to the bed really well. Somehow, over the past number of months, I had drifted to using the same temp for all the layers… a mistake I hope never to repeat.

Wow, that’s big difference. Thanks!

I may trim the delta back in the future.

I normally print the 1st layer 5-10 decrees higher than the printing temp but have never tried that big of a difference. Never printed with wood filament either though it’s on my want to try list.

Is your wood filament abrasive? If so how fast does it ruin a brass nozzle?

I honestly don’t know if it’s abrasive. I’m still using the nozzle I installed several months ago.

I think that I have seen on videos (where I learn everything) that it is abrasive. I just wondered to what extent and how much does printing with it choke up everyone in the room.

It only choked me up when I accidentally had the temp @ 250C. I haven’t noticed any abrasion so far.

Do you like the filament?

It’s OK for its purpose. I do recommend doing a temperature tower stringing test as is it will be stringy at higher temperatures. The company recommends 205C to 230C. I found it best at 175C.