Need some help... bonehead mistake with a CR-10

Setting up my CR-10 mini for the first time, I somehow managed to plug in one of the wire bundles incorrectly… must have been sleepy or something. (I did start putting it together the morning after receiving it…)

So the first time I turned it on, the screen glitched out and froze, controls didn’t work, and then I noticed the nozzle starting to smoke. Turned it off, checked the connections, and realized my mistake. Already had some Cap tube to put on it so wasn’t worried about the burnt PTFE.

Plugged it in right and turned it on, the nozzle temp was reading over 300°C, fell down to 265, and kept bouncing between 265-267. Tried a few controls, tried a test print. Everything moved and worked except the nozzle didn’t heat and the current temp always reads 265°. Target temp responds correctly to controls. So obviously the thermistor at the very least is boned.

SO I started the troubleshooting process, and luckily had a spare (matching) heater cartridge & thermistor from my i3 Mega. Spliced them on there, didn’t solve the problem.

My concerns about the mainboard are increasing… but if I end up having to replace/upgrade it, and the hot end too for that matter, I won’t be too upset. My fault, and intended to actually buy some upgrades for this printer anyway.

But this is where it starts to get confusing. I’ve looked up troubleshooting videos, poked around with a multi-meter, and tried different combinations of CR-10/i3M thermistor/cartridge. At some point, the target temp started reading 128-129° (curiously almost exactly half) instead of 265.

Kept following troubleshooting videos, confused by the results I was getting. But eventually realized that the nozzle actually does heat… as long as the target temp is greater than the (incorrect) nozzle temp. So trying to do a “PLA preheat” with the target temp at 185° makes the cartridge start heating… but still neither of the thermistors I have tried make any difference. Placement doesn’t matter, connected/disconnected doesn’t matter, keeps saying 128-129. There is 1.9V on the thermistor wires, which I assume is correct… but no dice.

So now I’m starting to look toward the firmware again. I was thinking that my screwup might have triggered something, and someone on reddit suggested that Marlin has an upper temp limit. So I’m wondering if reflashing/upgrading the firmware or tuning the PID’s might solve the problem. Unfortunately I need a bootloader to do that with this printer. Just so happens I have an Uno on-hand… but I haven’t exactly used one before. Doesn’t seem difficult, but something I haven’t been into yet.

Based on the troubleshooting videos, I could have concluded that the mainboard was toast when I didn’t see any voltage on the nozzle terminals. But then setting the target temp higher caused it to show voltage and heat up. So I can essentially rule out each individual hardware component… but I’m not entirely convinced the mainboard is okay.

At this point I’m more or less resigned to buying a mainboard. I’ve been looking at TH3Dstudio and there’s the “Melzi” board, which comes with a bootloader pre-installed. But it is based on the 1.1.4 mainboard… so if I’m going to buy one I’d kinda rather get an upgrade instead of a sidegrade…

Sorry for the long saga. But does anybody have some rock solid answers? I’ve been through all of the speculative answers by now. The only thing I haven’t been able to try yet is flashing the firmware. The fact that the temperature is still bouncing around a couple of degrees makes me think it’s not entirely dead… just needs to be “zeroed.” And it’s really weird how it went from reading 265 to 128…

So if anybody has made the same dumb mistake I did… please don’t be embarrassed. I’d love to hear from you. I did also message Creality support, so hopefully they’ll get back to me soon.

Suggestions on a good mainboard/upgrade path are also very welcome. I was planning to put some money into upgrading this printer anyway, so I don’t mind getting it out of the way now, especially if it saves me from troubleshooting hell. And the Ai3M is still working great so it’s okay if this one stays sidelined for a little bit.

Thanks for reading, and TIA for any assistance.

It is highly unlikely that your issue created a firmware problem. It is possible that you burnt out the thermistor which senses the temperature of the hot end. I might try a new thermistor, these are relatively inexpensive, first.

In terms of the TH3D boards, I installed one in my ender 5 and it has been excellent. Using Marlin 2.0 is a real plus and the folks are TH3D are solid. I produced a video about this:

TH3D also sells replacement thermistors. Three of them are $8 bucks.…t-3d-printers/

I actually did try a new cartridge and thermistor. Or at least spare ones. The post is too long, sorry about that, I was still testing/re-testing some things while writing.

Done a whole bunch more troubleshooting, found someone who had the same problem finally. Basically I can try to fix this board or replace it. Most likely the resistor or capacitor next to the E-TEMP got screwed up when I mis-plugged that bundle of wires and overheated it. But it gave the hot end a new “zero,” so it said 126-129° even when the thermistor was disconnected. If I set the target higher than that, like 185, the nozzle would heat. If I set it to 100, it thinks I’m telling it to cool down.

The good news is that everything else on the board works fine. So even if I don’t fix it I could use it for some other type of small DIY CNC machine. But yep, for now I’m just going to buy a new mainboard. I haven’t done any SMD soldering yet, so not supremely confident in my ability to fix it real soon.

As for which board… it looks like the EZboard is out of stock (of course, everything is right now). Soooo I’m looking at either the dual extruder one, or the Melzi with a pre-installed bootloader.

Checking out your video. The whole premise is… very relevant to me right now .