Heating Failure and auto level not working correctly

I have a new Tevoup Hydra 2 in 1 printer and laser engraver and yesterday I was able to print a few things mostly to test the settings so I could dial it in. Later in the day it started the 5 point auto level process and all it would do is move to the middle of the bed and measure there then move to the front middle and measure there instead of moving to the front left. It then moved to the rear middle and measure there then returned to the center for the final measurement. When I print a file, the extruder would normally move to the front left and extrude a line to prime the nozzle then move to the center and begin the print. This time it moved to the front center and started laying filament from the front to the back then moved back and forth staying in the center. I stopped the print then tried the auto level again and it did the same thing moving front to back, staying in the center. I tried each point and all it would do is move from the front center to rear after pressing all 5 points but point 5 did move it back to center. I thought maybe something happened when the file was sliced so I re-sliced it and tried it again with the same results. In the config the the 5 points all have the correct coordinates. I reset the firmware back to stock then tried to preheat the extruder and the bed but the extruder showed it was at -15/200. After a few seconds it gave a heating failure error and said to reset. I made a video of it, https://youtube.com/shorts/7sSOrazZEyE?feature=share I am at a total loss as to what happened for it to start acting that way. I have sent a text to Tevoup but I don’t get any replies from them until the middle of the night as they are in china. I have also left a post in the facebook support group and someone said to reseat a ribbon cable for the gantry so I tried that but that didn’t help. Anyone ever experience that type of problem and if so, what was the fix. I’ll even take suggestions at this point.

I’ve narrowed it down to the board the the Extruder and Laser module connect to. I tried using the laser this afternoon and it wouldn’t work either. Here are some videos I made this afternoon.