Geeetech A20M BLTouch

My A20M was working and I was getting good prints from it. Then one day I woke up to a dead printer. Nothing on the screen no movement from any motor. Geeetech Support was very helpful after I got thru the tech support from who seem to know nothing about 3D Printers. Enough about that before I get into a rant. Anyway, Geeetech support determined that it was the motherboard and started the process to send me a new one seeing that my printer was still under warranty.
I received the new board and when I removed the old one and replaced it the cable to the screen was different. Checking the board I had a version 3.0 board and they had sent me a version 3.1 motherboard. Back to tech support and they told me that the 3.0 board was no longer made so they would send me a new screen, and they did. I installed the new screen and everything was hunky-dory including the BLT test. The BLT tests fine from the screen. When I started a print the bed heated and the hotend got to temperature then it went to the right rear position and stopped with the motors screening. I powered off the printer and tried it again with the same results. After rebooting the motherboard it started giving me a “STOP PRINT” on the screen every time I rebooted or tuned the printer on. I went to Geetechs website and downloaded the No BLT firmware and installed it and the printer worked just fine with a manual bed leveling.

Does anyone know what the “STOP PRINT” error means on the Geeetech A20M? and Geeetech support sure don’t. I have checked the wiring, reversed the polarity of the power to the BLT. Everything that I can think of plus some things that others have thought of.

Looking forward to your comments and helpful hints. :o