Cura 4.13.1

I noticed that Cura has a new version 4.13.1.
I tried to download the newer version to see if it fixed the problem with the thumbnail on the printer display, but it will not let me download. Tried over a couple of hours about 4 times. Has anyone been able to download this version?

Yep, dnloaded it no prob.

What printer are you trying to get thumbnails for? If I remember correctly the thumbnails required a cura plugin which depends on your printer.

Yep. I believe the MKS Wifi Plugin is correct.

One of the problems with reviewing a lot of 3d printers is they tend to blur together. I sometimes watch my own videos to refresh my memory.

Yay, 4.13.1 fixes the bug where tree supports would print inside the model in some cases. Time to download!

Don’t know if this is what you are looking for, but 4.13 added:
[INDENT]3MF thumbnail
Show the model in the thumbnail of a .3mf file, contributed by fieldOfView[/INDENT]


I know that this doesn’t help with your problem Lowtack but I was able to download the Linux AppImage a little while ago and that was using Firefox. What’s happening when you trying to download it? When you press the Download button for your OS are you getting a popup window asking if you want to open or save the file?

Just now tried to download with the Firefox subset Palemoon and it still does not respond. I went to Firefox direct and I got it downloaded. That is the first time I have not been able to download a Cura download with Palemoon. Thanks everyone for your replies!