Anyone Seen This??

Hi All

Today I designed a print in place box using Freecad 0.19. I sent it to Cura 4.11. In the Cura Prepare screen it all looked fine, but in Preview there was an odd anomaly and when printed that anomaly was also printed.

This is the Freecad view …

Then in Cura Prepare is this view of the same area…


In Cura Preview this shows (I circled the issue)…

And the printed model has this anomaly

There is no error message when loading the file into Cura. Meshmixer and 3D builder report no errors either and display just fine. I have not tried Cura 5 or another vendor’s slicer. I’ve uploaded the STL file if anyone else wants to look.

The model works just fine for its intended purpose so I have not played with it, but just wondering if anyone has run across this.



HDD CASE.stl (307 KB)

This is a first for me as well. In my cases, Meshmixer caught something.

I don’t see an attachment!?


Opps, I thought I uploaded.


I too have used Meshmixer to find and fix things but it doesn’t see anything wrong…

If anyone wants the Freecad file I can upload that too.


HDD CASE.stl (307 KB)

Set “Refine” to True, within the toolbar on the left for the last operation on the model. This usually cleans and “overlapping connections” in the models.

Refine. Hmmmm. OK set refine to true and exported the model to STL.

No banana…

[ATTACH=JSON]{“alt”:“Click image for larger version Name: after refine.png Views: 0 Size: 37.8 KB ID: 15358”,“data-align”:“none”,“data-attachmentid”:“15358”,“data-size”:“medium”}[/ATTACH]

Interesting Thought though.

after refine.png

Make sure you mark you project, select recalculate model afterwards. Sometimes I just sets the “update” marker, but recalculation does not get triggered.

Refine is basically removing useless lines from a model. e.g. if you have two boxes extruded into each other you get 2 lines around where the overlapping takes place. The result after refine will be one shape with one split line around.

This is often the reason then chamfer and filets are failing. But be warned. In some cases this causes problem and turns your model inside out. I had it recently when I used it to build a filet and when I wanted to cut off a chunk it claimed the result would be two objects, which was bullshit. Somehow the refine caused this.

FreeCAD can be a bitch sometimes. Make sure to use the RealThunder version. The official one is a bad joke.


Thanks for the info. I gave that a try but no change in the slicing view (prepare view still shows no issue). I tried to save the dress-up features in Freecad to the last step, but maybe in my work flow I made other mistakes - the hinges were added after the dress-up. I did a test print of the model before adding the hinges and fillets and the model printed as expected. Just strange how the prepare view in Cura does not pick up on the issue. I’d be curious if anyone here is running Cura 5 beta and see if that does anything different.

I was running the real thunder link branch for a while but recently switched back to .19 in anticipation of moving to .20 when it’s ready. Here is my freecad file. Again my work flows are probably not right. Also, I used the Draft WB to rotate the top case body 180 deg before export to STL so a lot of the sketches show up in the wrong place.

On the bright side I’m really pleased at how well the print-in-place hinges turned out. No binding or catching at all.




HDD Case With Round Corners.FCStd (1.49 MB)

I loaded it into so recent RealThunder edition.

It is dumping a ton of warnings about missing plane references (not sure, but it seems you picked them from different parts of the models), but it loaded it fine, required an overall recompute and it looks good. I exported it and as far as I see it looks ok in Cura5.

My Cura Visuals are ugly like hell as my laptops 3D capabilities are below what the normal display engine requires. Therefor I cannot really see rendered layer lines, but only the fallback rendering, which shows straight lines with the curves coming from the bottom. I have a displayless MacBookPro 2018/2019, which hopefully will be my next printer support system. This annoys me for years. :smiley:

I must say the model itself looks great and I am impressed by the result. Maybe change the names of pad/pockets and sketches to make stuff more readable. Especially when you return in a few years and what to change something (software developer speaking). :slight_smile:

You also used a lot external geometry, which is a very bad ides. if you change stuff like size of the inner fillet, everything below will probably break due to random renaming the references. If you want to use these functions and e.g. put sketches on faces and stuff. That usage is very dangerous with the official version. This is a 10+ year old bug and still not fixed in the official branch. In the real thunder edition 99% of those issues are gone.

In fact since I used the broken branch for years, I still use datum planes and offsets a lot. Mainly because I name them properly and have a surface I can easily find, when I need to a pad or a pocket later on. Something like “DP_HingeTop” is a clear information and you know what you get when adding a sketch to that.

If you want to use the “old” version you need to model around the center point and use datum planes. It is stupid but external geometry and sketching on pads should not be done with the official edition. Their tutorials usually show that, but this is because the examples are not that complex and they never change something in the past of the model. The real thunder version gets frequently updates.

If you want to see what I mean, open the “PartDesignExample.FcSTD” file from the “start”-workbench. This is the official example file, which does what you do: referencing.

Look how the top looks like a castle with the recessed trench and the shoot nodges. Double click the “Sketch” named sketch. Add a circle to the tower at the right. Just put it over the other and with a smaller diameter. You have now changed the past of the work flow tree. This expect a new hole was added through the entire tower, but the model will be inside out, because FreeCAD renamed all references as the circle is a new line and the pocket creates new surfaces and edges.

The castle wall looks different, because the wall top pocket is missing. It is now at the bottom of the model and other features may or may not have been changed, depending on the version. The model is now completely broken and requires massive work to fix all the references. This can even happen, when you change a measurement in spreadsheet, as e.g. if a pocket gets change from “through all” to “4mm”. The inner bottom of the prior hole is now a face and an edge. FreeCAD will rename these in and everything afterwards is broken.

If you do the same test with the real thunder edition, you just get a hole through the tower. I use this simple test to check if the build contains the bugfix or not.

Use this one to get all the features and the bugfixes of the original version plus the reference issue fixed. It appears a little later, but has all the good stuff you want.


Interesting. I’ll go out on a limb on this, but I wonder if the errors are because I rotated the top body 180 deg via the Draft WB so I could export the model as a print in place. Could be the various sketches used in the top body are refencing planes that were moved by the Draft WB. That and maybe the .19 version has changes the link branch takes issue with. Guess I should have built the model with the centerline of the hinges as the drawing origin so I could use the Transform command to rotate the body that way. A lessen for me next time I make something like this…


I tried slicing the STL you uploaded in Prusaslicer and it looked OK to me.

I also tried slicing in Cura 4.12 and Cura 5.0 and it appeared fine in both cases.

Weird. The STL looks ok in Cura 4.12 for me as well.



Apparently, a number of people have had issues with Cura 5.

Thanks everyone for trying different slicers.